PDA

View Full Version : NTFS HDD restricting file access



AaronM
05-11-2006, 02:54 PM
Hi, my system (XP Pro) has 2 HDD. Main HDD is 120GB in 3 partitions, currently FAT32. Second HDD is just 4GB which I store my installation pgms and drivers on for easy access.

I have stayed with FAT32 until now as I have an older version of Ghost that I have imaged my system in a good working state should I need to recover in event of a virus etc. I've discovered a free pgm that will image NTFS dirves so was experimenting by formatting the 4GB drive to NTFS after copying the content to DVD. Then copied the content back from the DVD to the HDD. All this was done logged in as administrator.

Now when I log in as my everday limited user account I can see the 4GB NTFS drive OK, can run pgms/open files from it, but cannot delete files off it. I downloaded a file to the $GB drive, so can write to it OK, and I was able to delete the file I downloaded, but I cannot delete any of the existing files that I did not create whilst logged in as non-administrator - get the message "Access Denied"

Any ideas appreciated.

Thanks

pctek
05-11-2006, 10:23 PM
Because they will all now be READ ONLY.
Check the attributes of each - and make them all not read only.

Also Ghost will image any kind of O/S - FAT32, FAT16, NTFS, whatever. It doesn't care what file system its using.
Didn't you know that?

linw
06-11-2006, 11:54 AM
For future reference, the MS convert program will change from fat to ntfs without the hassle of copying/formatting http://support.microsoft.com/kb/214579

AaronM
14-11-2006, 07:53 PM
HI, I thought of the read only issue - and its not that - the files are not marked read only.

If I log in as Admin I can alter them, but when logged in as the limited access user I can't do anything with the files. New files I create work fine so i think I can probably go in as Admin, erase the files, go back in as the limted user and copy the files back (and set read only = off). Still puzzling as to why it is restricting me in the first place.

The version of Ghost I have is an older one so cannot access NTFS drives.

The reason I formatted instead of using the convert function was to test the new drive imaging software - wanted to totally clean it out and then restore from the image I made. The image restored OK, but obviously something not quite right.

Thanks,
A.

Mamaz
14-11-2006, 08:06 PM
I could by way off with this but this is the only thing I can think off:


Are you using simple file sharing? Check this via any Explorer window (not IE) Click on tools ---> Folder options -----> View TAB and under advanced settings this option is the last one. If so turn it off. (you have to be admin for this I think)

Once you have turned off and applied. Right click on one of the files in question and goto Properties, you will see a new TAB that says Security. Give you limited user or its group whatever access it needs.

Login as limited user and check if it works.. if it does then great. If you have a network running then turning off simple file sharing might cause problems when access network shares etc so turn it back on if needed.