PDA

View Full Version : Linux - Avoiding random selection of sound card



personthingy
17-10-2006, 08:20 PM
I got a new free computer, and onboard sound is ...Well..... Shall we say less than satisfactory?

So i added a card.

KMix sees the onboard as "C-Media PCI CM18738" and the card i added, which is adequate for playing music through at home, is seen as "Ensonic Audio PCI" the problem is that every time i boot up, its a gamble which card is going to work, and all the settings for the Ensonic are lost.

At one point both were working, which wouldn't be too bad a solution, if it's not too system hungry. Free computers aren't that powerful ;)

I'm assuming that there is a way to tell the system to ignore the onboard sound device, and use only the Ensonic card?

I'm running what started as Mepis 3.4.3, although its so updated it's really more up to the minute Debian by now.

Can anyway guide me on this one?

vinref
17-10-2006, 09:56 PM
Recompiling the kernel is fun!

Recompile the kernel to exclude the driver for the onboard card. In fact, make it a loadable module in case you need to use it later. Even better, make both drivers modules, so that you can load one or the other at will. Load them automatically through the kernel module loader.

johnd
17-10-2006, 10:27 PM
Go into the CMOS setup and disable the on-board sound?

personthingy
17-10-2006, 10:31 PM
EEK! the kernel!

Well that would be a trip into uncharted territory for me. I was kinda hoping i could tweak some yet unfound conf file or something.

personthingy
17-10-2006, 10:33 PM
Go into the CMOS setup and disable the on-board sound? i did spend some time failing to find anyway of ignoring or switching of the onboard sound....

johnd
17-10-2006, 10:38 PM
i did spend some time failing to find anyway of ignoring or switching of the onboard sound....

I would be surprised if it is not there somewhere?

personthingy
17-10-2006, 10:54 PM
I would be surprised if it is not there somewhere?So was i, but i just rebooted, had a look through every menu and every sub menu of the BIOS, and again found nothing relating to onboard sound. I'll post the BIOS version tommorow....

TGoddard
18-10-2006, 12:40 PM
What distro are you using? You should be able to disable the card easily, no need to mess around with the BIOS.

personthingy
18-10-2006, 12:44 PM
What distro are you using? You should be able to disable the card easily, no need to mess around with the BIOS.I'm running what started as Mepis 3.4.3, although its so updated it's really more up to the minute Debian by now.
I'm sure there is an easy way, the hard bit is knowing what i is.

personthingy
24-10-2006, 04:13 PM
The solution.....

Let my son go through the BIOS, and under chip conf, he finds some reference to on board sound, and turns it off....

:blush: :D

Jen
24-10-2006, 05:31 PM
You should of recompiled the kernel anyway - good learning exercise :D

Although I could of done it remotely for you as I have a long track record of accidentally leaving out support for the onboard audio chipset and ending up with a mute system :o

personthingy
24-10-2006, 05:53 PM
Mepis seems a wonderful system for people with power to spare. It seems to find everything, and is seriously guzzly

Perhaps a kernel rebuild is in order?
Would this help?

Jen
24-10-2006, 07:33 PM
Recompiling your kernel specifically to your hardware is one way of doing it, but realistically you may not notice much difference.

What will help is reducing what services are starting automatically. You can look at what service runs on what runlevel and stop those that are not required. If you do not have a suitable GUI for editing services, then have a look at this (http://www.mepis.org/docs/en/index.php/Configuring_what_services_start_at_boot_time). :)

pctek
24-10-2006, 08:12 PM
Mepis seems a wonderful system for people with power to spare. It seems to find everything, and is seriously guzzly

Perhaps a kernel rebuild is in order?
Would this help?

Have a read of this:

May or may not help, he teaches UNIX and Linux.
I found it all rather entertaining anyway....

http://homepages.paradise.net.nz/triffid/toshiba/installLinux.html