PDA

View Full Version : printers don't appear on network



bpt2
02-08-2006, 05:00 PM
I have 5 XP computers on a network with 2 printers attached to two of the PCs. I continually get problems with the printers not being accessible, needing to be reinstalled to work correctly, having duplicate entires (e.g. auto lexmark ......), or not even appearing under the workgroup. Can anyone clear up my confusion?

Speedy Gonzales
02-08-2006, 09:10 PM
I take it, you've shared both printers on these 2 PC's?

Graham L
03-08-2006, 01:30 PM
I suspect it's just "Windows is like that :(" rather than any malevolence. :cool:

If the printers are powered up first, then the computers they are on, then the other computers in the network, I'd guess that that's when everything works. :thumbs: (Usually. :badpc: )

Proper printer servers will always work better than sharing printers from workstations. ;)

linw
03-08-2006, 02:51 PM
Adding to what Graham said, I have a small XP network with shared printers attached to PC's and it is very reliable. However, the computers are left switched on (but printers are regularly switched off) and there is only one machine set as "Browser" (See Computer Browser under Services). This way the hardware is always available and the network netbios tables are correct and current.

I suspect with your network that any and all machines/printers are switched off and then switched on randomly as people arrive at work. Yes? It can take up to 15 min for the network to re-establish connections so I think this is why you see the problems you get.

Like Graham said, perhaps you should consider a networked print server which should help in your situation. Give it a static IP no. and leave it on.

Don't know whether this is any use or not!! Happy hunting.