PDA

View Full Version : Dial-up/DNS/Ping problem - take your pick



Pyropete
02-08-2006, 11:11 AM
Hi all,

I have a weird situation on a friends computer. Since last Thursday, he has been able to dial up to his ISP (and they say he is connected after he phoned them to check), but no pages display on his browser – just coming up with page not found etc..

So, I went around there last night to check it out. Yep, I was able to dial up and connect to his ISP, and nope, no pages displaying. His AVG, spybot, adaware, defender etc cannot connect either (say there is no connection or failed to reach server).

Next thing I did was to ping the local machine (localhost) – no problems, except for some weird characters in the name. Tried pinging www.ieee.org as I often do in these cases and it could not find it. Then tried pinging a dns server by name (could not find), but I could ping it by address. I also tried an “ipconfig /all” – returns “Windows IP Configuration” and nothing else at all – just that one line!

I tried setting some DNS addresses in the dial-up settings to no avail. HELP! I am starting to get out of my depth here and need some advice on what to try next.

BTW, he is using Windows XP and dials up through Slingshot.

Thanks for any suggestions, and let me know if you need more clarification on any of these points.

Pete (long time lurker).

Safari
02-08-2006, 11:19 AM
Sounds like a DNS problem again caused by damaged winsock files.

Download and run the winsock fix
http://www.snapfiles.com/get/winsockxpfix.html

You can also do it manually if you want to.

Step 1: Delete registry keys

Open the Registry Editor from the run line. Start --> Run --> regedit --> ok
Navigate to both of the following keys and then delete the key (folder):
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Winsock
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Winsock2
Restart the computer

NB: It is important to restart the computer after deleting the Winsock keys. Doing so causes the XP operating system to recreate shell entries for those two keys. If this is not done, the next step does not work correctly.


Step 2: Install TCP/IP over top of the existing installation:

Open the properties window of the network connection. Start --> Connect To --> Show All Connections --> Right-click the Connectoid --> Click Properties --> Select the Networking Tab
Click Install
Click Protocol
Click Add
Click Have Disk
Type the path to the nettcpip.inf file and click OK. This should either be: c:\windows\inf or c:\winnt\inf (if you click browse, then attempt to browse to the \inf folder, it may not show up in the list as it is a hidden directory)
You should now see "Internet Protocol (TCP/IP)" in the list of available protocols. Select it and click OK.
Restart the computer

Pyropete
02-08-2006, 12:12 PM
Wow - thanks for the quick response. I will try that solution out tonight and report back on how it went in case others have the same probbies.

Cheers,

Pete

Pyropete
03-08-2006, 09:27 AM
Well, tried that fix last night at mates place and it worked perfectly! Many thanks for that - will add that to my list of things to try next time. All I have to do now is "educate" him (or his kids more like it) - just using the computer as it came from the shop with IE and MSN for emails. Installed Firefox and Thunderbird for him and he seems happy enough.

Incidentally, it seems what started this off was his kids had been downloading a lot of rubbish then deleting things and somewhere along the line they got a trojan dialler which he deleted last week (when the trouble started). So...... maybe that managed to stuff up the winsock settings???

Anyway, thanks again for the help.

Pete

linw
03-08-2006, 01:24 PM
Reinforces my resolve not to work on computers used by kids. But it's on-going business if you are charging appropriately!