PDA

View Full Version : My harddrive is missing



Ninjabear
25-07-2006, 07:25 PM
Im running Windows Xp and just yesterday i unplugged my external notebook harddrive and took it with me to massey.Today I've plugged the Harddrive back in.Windows Xp does recognize the Harddrive and it says the device is working properly but in windows explorer I don't see my harddrive.

I tried it on my friend's laptop and it recognize and also showed the harddrive in windows explorer and i can access it.

What happened to my computer?Why isn't it showing my harddrive?

Can anyone help?

Thanks

sam m
25-07-2006, 07:42 PM
Im running Windows Xp and just yesterday i unplugged my external notebook harddrive and took it with me to massey.Today I've plugged the Harddrive back in.Windows Xp does recognize the Harddrive and it says the device is working properly but in windows explorer I don't see my harddrive.

I tried it on my friend's laptop and it recognize and also showed the harddrive in windows explorer and i can access it.

What happened to my computer?Why isn't it showing my harddrive?

Can anyone help?

Thanks

Have you tried a different USB port?

Ninjabear
25-07-2006, 08:16 PM
I've tried 4 other usb port.Its the same

linw
25-07-2006, 08:38 PM
See whether info here is helpful.
http://helpdesk.centre.edu/view.php?type=doc&id=56

snoopy
25-07-2006, 09:52 PM
Maybe something here to help

http://www.usbman.com/WinME%20USB%20Guide.htm

Shortcircuit
25-07-2006, 10:25 PM
A solution that I found and worked for me 1st time... note this was an external HD on a PC, not a laptop (but It looks like you've got both, just not clear if the problem was on your laptop or PC).

Unplug external HD, switch off computer and REMOVE a/c power cord (not sure what you'd do if a laptop!!). Leave unplugged for at least 30 minutes (I left it overnight).

Switch on comp as normal and hopefully Windows will recognise HD. Apparently it's something to do with 'residual voltage' in the motherboard/bios... or that's what they say :)

drcspy
26-07-2006, 02:21 AM
have you tried other usb devices ?