View Full Version : Disable Floppy Drive

07-07-2006, 04:59 AM
I'm getting an error 40 - Floppy Drive Fail when I boot my PC. I don't need the floppy drive and want to disable it so that the error 40 goes away without having to open up the PC.

I believe that I can do this by changing the CMOS setting for hardware devices to disable or none for the floppy drive, is this correct?

Will I also need to change the settings for 'Boot Sequence' and 'Boot Up Floppy Seek' or any other settings?

I'm running Win XP Pro - will I need to change anything there as well or will the CMOS change be enough?

07-07-2006, 07:30 AM
Yes you can use the BIOS to disable the floppy drive. To get into the BIOS of most machines, you just need to tap the DEL key during startup - you should see a brief message at the bottom saying "push the DEL key to enter SETUP" or similar. Have a look around the BIOS (your motherboard manual will assist with the layout) and find the floppy device and set it to disable.

I'm not sure about the boot order if A is first on it after disabling it, but it wouldn't hurt to change the boot order in the BIOS so that it goes CD-ROM first, and then the Hard drives.

If you need more detailed assistance, please post back and Welcome to PressF1. :)

08-07-2006, 05:50 PM
Hi, you really should look at this further you could have a problem with your MB or it is simply the floppy cable is faulty, playing in the bios will not resolve the issue, could and has led to other problems, my advice if you do not know what you are doing get professional help.Forums are good, however you have to be aware without a proper diagnostic of your machine then you are in for more problems...

Speedy Gonzales
08-07-2006, 06:02 PM
You can disable floppy seek, in the BIOS coz obviously you dont want one.

There is nothing wrong with disabling the floppy in the BIOS Jenae.

Actually neither of these have a floppy in them and they're fine without one.

Since both can boot from USB, the only thing I ever used the floppy for was for updating the BIOS. And now, I can use a USB flashdisk instead.

08-07-2006, 06:54 PM
Hi, I undestand you can remove the floppy and reset the BIOS, and no floppy is your choice, my point is referenced to the error 40 which indicates either a MB fault or a possible splitter cable problem , now left alone we know that this may cause a power supply problem or even a motherboard failure, so my advice is to have the computer checked....disable in the BIOS is not going to solve this if it is a solder problem on the MB.

08-07-2006, 07:47 PM
the problem comes from a dud flloppy or some prob such as a bad cable.....anyway goto the cmos/bios screens and disable 'floppy bootup seek'......that is a function that simply tests the floppy at boot and that's what is giving that errr.