PDA

View Full Version : My local account's startup folder is boned.



Zygar
26-06-2006, 10:04 PM
This is the dumbest bug I've ever encountered, not to mention the most annoying. I recently reformatted my computer, set up an account, installed programs, then tried to set up my start menu. I'm obsessive about where my shortcuts actually reside, so I moved the contents of "C:\Documents and Settings\Andrew\Start Menu\Programs" (my account) into "C:\Documents and Settings\All Users\Start Menu\Programs". I can't quite remember, but I think this may have included my Startup folder. I tried to put my more frequently used programs such as y'zdock into my (account's) startup folder, and realizing I didn't have one, just made a new folder called "Startup" at this location: C:\Documents and Settings\Andrew\Start Menu\Programs\Startup.

My All Users startup folder is located at the default place, C:\Documents and Settings\All Users\Start Menu\Programs\Startup.

Now for the problem. When I log in, NOTHING in my account's startup folder gets loaded, but EVERYTHING in the All Users startup folder will try to start twice, if the computer will let it. y'zdock, media player classic, anything which allows multiple copies of a program to run at once will open twice.

I made a new account, titled "Buttz", and the startup folders worked fine under there. Shortcuts under Buttz's local start menu work fine, and the All Users shortcuts only load once, as they should.

Is there a solution to this, or do I have to create a new account? I'd really rather not have to bother copying all my settings over, it's only been a few days but I've already got a bunch of stuff set up and pointed towards this specific account. Any help would be much appreciated. Thanks.

EDIT: Inadvertently moving the startup folder was definitely the cause. Windows typically won't let you delete it, but if you move it, the folder will become no more, and it will **** itself. But can I fix it?

Zygar
27-06-2006, 08:37 AM
After much trawling of the registry, I have finally managed to fix it. I stumbled across a solution on Google Groups here (http://groups.google.com/group/microsoft.public.win2000.general/browse_thread/thread/3936391e066db7d0/b94e5276272f3415%23b94e5276272f3415) but when I changed that value (it was pointing towards "All Users", presumably because the startup folder under my account was MIA) it would reset to All Users every time I logged in. However, I found another registry value, further down, HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\User Shell Folders which, when I changed startup from %ALLUSERSPROFILE%\Start Menu\Programs\Startup to simply %USERPROFILE%, fixed the problem.