PDA

View Full Version : Turning off DEP (Data Execution Prevention)



Brain_Cell_Anon
24-04-2006, 01:23 AM
Hi Peps,
Does any one know how to turn off DEP (Data Execution Prevention) in Windows XP? I now appear to have three (virus free... I've checked heaps of times) folders that this bl*@dy DEP thing keeps stoping access to. Just opening them seems to activate DEP, but (as I typed before) I can't seem to find out why. It also seems to be on by default which bugs me. I didn't ask for it (though most likely loaded it by saying 'Yes' to one of Microsods 'Updates'.
Any clues, oh People I have eep respect for???
Many regards,
The Cell {:o)

zqwerty
24-04-2006, 01:53 AM
I have not changed my settings from default but here is how you get to the relevant window.

rightclick my computer on desktop/properties/advanced/performance, click settings/data execution prevention tab, and now you are on your own!

HTH.

Brain_Cell_Anon
25-04-2006, 01:28 PM
Er, yes! Thank you zqwerty. Unfortunatley, I must have a different version of Windows XP to you. For when I try to "rightclick my computer on desktop/properties/advanced/performance, click settings/data execution prevention tab" I get as far as "rightclick my computer on desktop/properties" which the brings up 'Display Properties' which dosen't appear to have an "advanced" tab.
The way I get to the DEP window is 'Start - Control Panel - Performance and Maintenance - System - Advanced tab - Settings button - Data Execution Prevention tab'. But the only options there are "Turn on DEP for essential Windows programs and services only" and "Turn on DEP for all programs except those I select"
So I guess it's here I 'select' things, or is this like the Registry "Play with extreme caution!"
many regards,
The Cell

yzhu
25-04-2006, 01:37 PM
I think you have to be logged into an account with administrator priviliges.

zqwerty
25-04-2006, 03:18 PM
Sorry right click "My Computer" showing on the desktop. The one that is there on every Windows desktop since Win 95.

SurferJoe46
25-04-2006, 03:59 PM
Might be wrong here (again) but I think one needs to have "Classic Start Menu" option running to get where he needs to go.

Brain_Cell_Anon
28-04-2006, 12:47 AM
zqwerty
I thank you! Yes, when I re-read your answer..... it makes more sense, and yesthe 'My Computer' icon is still there!! :thumbs:
yzhu
By "logged into an account with administrator priviliges" there is only me! I can only log in as me. There are no other options, and when I loaded Winbows I don't remember being asked to make another account. In fact the more I think about it, I think I am THE administrator. :badpc: :D
SurferJoe46
By that ("one needs to have 'Classic Start Menu' option running") do you mean THERE IS a way to turn DEP off?? So far (with huge amounts of tinkering ;) ) I've managed to get to two choices:
1 - Turn on DEP for essential Windows programs and services only
2 - Turn on DEP for all programs and services except those I select
and then (on my computer) already listed are DTVPlayer, Windows Explorer and Windows Media Player.
So I ticked Windows Explorer so that it would be 'exceptated' (??) :D
Wil return here if it makes a difference.
Many regards, Peps, for your answers,
The Cell

Big John
28-04-2006, 05:18 AM
Turn it off in BIOS and that should stop it cold. I have mine enabled in BIOS and defaults everywhere else.

One would assume that if you turn it off in BIOS then it won't work elsewhere as it is part of the CPU code that allows data execution prevention.

intel hunter
28-04-2006, 08:25 AM
Hi Brain_Cell_Anon,

I have found the easiest way to turn off DEP is to right click my computer/advanced/startupand recovery and edit the boot.ini file to read
"Microsoft Windows XP Home Edition"/fastdetect/Execute instead of reading
"Microsoft Windows XP Home Edition"/fastdetect/NoExecute

By taking out that NoExecute reference by changing it to Execute, it turns off DEP altogether. Hope this helps.

Fred :D

Brain_Cell_Anon
28-04-2006, 12:56 PM
Well Peps!
I thank you all for your help (I knew you Braniacs would come up with something interesting), but it seems that what I did before seems to have stopped my computer crashing and doing the 'Error Report' thing. It must have been 'something' (???) in Winbows Explorer that was doing it (new thread and answers on a postcard please to...... :) ).
However.......
Big John
Oo er! In the BIOS, a? :waughh: Well I'll have a peek and see what's there. Must admit, I didn't think to look there. :o
intel hunter
All I can see when I get to that point is this:
"Windows XP Media Center Edition"/fastdetect/NoExecute=OptOut
As it has the 'added flavour' of "OptOut", do you think that makes it, er, different??

Many regards,
The Cell :D

Speedy Gonzales
28-04-2006, 01:48 PM
I dont think this option will be in the BIOS (it might be on 64 bit mobos).

I doubt it'll be on 32 bit mobos tho.

Since most 64 bit mobos/cpu's support this, 32 bit CPU's wont / wouldn't.

Altho SP2 installs this option, it doesnt mean u can use it / or turn it off or on.

Big John
28-04-2006, 02:24 PM
I dont think this option will be in the BIOS (it might be on 64 bit mobos).

I doubt it'll be on 32 bit mobos tho.

Since most 64 bit mobos/cpu's support this, 32 bit CPU's wont / wouldn't.

Altho SP2 installs this option, it doesnt mean u can use it / or turn it off or on.

Well mine does. It is a P4 3.6Ghz and has Data Execution Prevention built into the chip. The BIOS (Award) supports this and has an option to enable or disable this. Just the same as the unique ID of each chip (which mine is disabled)

intel hunter
28-04-2006, 02:25 PM
Hi again, Just take out the No and the part where it says =OptOut and it will work, no worries.

Cheers Fred :thumbs: