PDA

View Full Version : installing Linux



jupiter1
01-02-2006, 05:18 PM
Hi,
I have a win 2k pro system and am trying to install Fedora 4 on a seperate 8.4 gig Hdd.
My system HDD's are formatted in NTFS mode.
The 8.4 was formatted by the fedors install.
The install apparently went without fault.
The win2k system sees the 8.4 HDD but canot read it
I cant boot into the 8.4 fedora system.

What format type does Fedora need ....FAT..FAT32 or NTFS ?

How do I create a dual boot (boot.ini contents ? ).

Cheers,
Phil

Myth
01-02-2006, 05:38 PM
From memory (when I used Fedora 4):
I would select manually partition. Then I would create 4 partitions.. 1 for /boot; 1 for /; 1 as swap; and the last for /home.
The /boot would be an ext2 filesystem, while / and /home would be ext3. Swap partition doesnt have a filesystem.
Make sure that hdb (the 8 gig drive) is the only one selected when doing this.

AS for how to load either 2000 or Fedora, the fedora install should also install and configure Grub (the linux boot manager.

And no, 2000 will not see Fedora partitions. If you want to share a partition, I suggest you make a seperate fat32 partition so that both O/S's can mount it without too much hassle

Haze
01-02-2006, 05:41 PM
If you were wanting to know which filing systems FC4 supported, its supports the following: (according to Wikipedia)

ext2
ext3
FAT
ISO 9660
JFS
NFS
ReiserFS
UDF
XFS

Jen
01-02-2006, 08:13 PM
Best that it is kept really simple if you are new to Linux. Reinstall Fedora on the second drive, let it do the partitioning automatically. Let it install the boot loader to the MBR and that should be all you need to do to dual boot Windows and Linux.

Note, if the 8.4 gig drive is on as secondary master, Linux will call it hdb. Your OS drive (primary master) will be hda. Double check you have selected the correct drive for Linux to use.

Linux can read NTFS (and write to but this is not really recommended) and you can set up Fedora to automatically mount (see) that drive, but it is much easier to share a FAT32 partition between the two OSs as already suggested. :)

jupiter1
02-02-2006, 09:38 AM
Thank you all for your help.
Jan, I have done all you suggested and the install went (apparently) perfect. However although I formatted the 8.4 Gig HDD as FAT32 win2k can see it but thinks it is not formatted.
Neither can I boot from it.
I think the problem is a configuration fault.
My Pri IDE channel has a 80 Gig master HDD with 2 partitions first is win2k second is data. The 8.4 is a slave to this.
My Sec IDE channel is configured exactly the same (as backup) but with the CD-ROM instead of the 8.4 HDD
Could boot.ini be the problem ? which contains that below.

[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Win2K Pro Primary" /fastdetect
multi(0)disk(0)rdisk(1)partition(1)\WINNT="Win2K Pro Secondary" /fastdetect
Any suggestions are welcome.
TIA,
Phil

jupiter1
02-02-2006, 11:52 AM
Jen, sorry about wrong spelling on my last post.

What is this "install boot loader to MBR" thingy?
I assume this happens when you select Auto partition ?

If not, how is it done ?

Phil

Graham L
02-02-2006, 12:14 PM
It won't boot to Linux because you haven't given it a Linux bootloader. :D You are still getting the Windows boot loader. You should be getiing the Linux loader (LILO or Grub) which would then let you choose between Windows and Linux.

Linux is well behaved. It doesn't do potentially destructive things unless you give it permission. The partitioner just does partitioning, with youir permission. The installer won't install a boot loader without permission when it has seen there is another OS present.

Did you read all the screens as the installation proceeded, or just hit Enter each time? ;)

You'll be pretty good at installing, by now. Why not do it yet again. This time select "expert" mode. :cool: It should allow you to go straight to the boot options area, and load a bootloader in the MBR of hda. It will sort out what's needed, because you have Fedora installed. Correct, Jen? I've never installed Fedora.

jupiter1
02-02-2006, 12:49 PM
Hi,
Yes, I read all the screens.
Only options I got were for language, keyboard type location and which drive to use, thats it.
Nothing about MBR's
Watching the install I noticed that the grub thingy was installed (I think, it was mentioned in the information lines underneith the install window).
regards,
Phil

Graham L
02-02-2006, 12:52 PM
Aha. Maybe it installed Grub on the MBR of hdb. :D

Does your BIOS allow you to select the hard disk to boot from? Try setting it to this secondary hard disk. It might all magically work. :cool:

Jen
02-02-2006, 04:48 PM
I think if you read through this Fedora Core 4 Linux Installation Notes (http://stanton-finley.net/fedora_core_4_installation_notes.html) website it will make things easier for you.

As long as you pick hdb (the 8.4 gig drive) for Linux to use, it should be fine. Let it have all the drive so select automatic partitioning and it will sort out swap and your root partition etc. It will format it as ext3 which is a native Linux file system that Fedora uses by default (Windows will not be able to see this format). It will ask you to install the boot loader (Grub) by default. Let it install the boot loader to the MBR (master boot record) on the hda which is the boot sector on your Win2K drive. I think it will also think ask or let you pick which OS is to be default in the bootloader. It will be this OS that gets booted after X amount of seconds automatically if you don't select the other manually.

If any of this is confusing, please just ask for clarification. :)

jupiter1
03-02-2006, 11:16 AM
Hi Jen,
Thanks. I did all you suggested and it work just like you said including the default of Grub to the MBR on hda.

Unfortunately it still doesnt work. I suspect this is because the win2k disk is formatted in the NTFS format so Fedora cant see it.

I tried loading Grub to hdb (the 8.4 linux HDD) and hdc (the back up win2k hdd) and then tried going into bios and booting from these other drives but none of this worked either.

Is my HDD h/ware setup suitable ?
I really dont want to get into re-formatting my win2k drives to FAT and re-installing everything. I'm sick of re-installing windows every time it goes awol, that's why I want to try Linux !
However, I can't afford too much downtime, that's why I have two win2k systems.

Cheers,
Phil.

FoxyMX
03-02-2006, 11:53 AM
Get yourself a hard drive caddy system.

The base goes into one of the drive bays and each hard drive with its own OS goes in its own caddy and slotted in when you want to use it. That way you don't need to muck around with Grub and boot.ini files.

It's way better and allows you to play or work with each OS to your heart's content then switch to the other with a yank of the caddy (after closing down, of course) when you have had enough.

Murray P
03-02-2006, 12:09 PM
Where the bootloader resides has nothing to do with the file system used (NTFS, FAT 32, etc). I supect you have a confused boot sector now, one on hda (C drive) and one on hdb (whatever windows has assigned, prob E). I got into a real pickle with this when I reloaded a Linux distro which previously was set to use hdb, but muggins here decided to use hda instead without letting the original bootloader in on the secret (in fact, I'm pretty sure it knew what I was up to, it's just that I ignored advice).

I presume you can still get into win2k, which is a good sign. My advice would be to use a Live Linux CD like *cough* Mepis, which runs from the CD without (necessarilly touching your HDD) and has the ability to change your boot partition without you having to edit anything. Once done, I'd be inclined to carry on and install Mepis (or some such) as it's a smaller and, IMO, easier to use for those having there first look at Linux.

Edit: If you want a Mepis CD, I can provide one or pop over to www.mepis.org

Jen
03-02-2006, 07:29 PM
I agree with Murray, and think you may have one confused system now because it should of just *worked*.

FoxMX's suggestion is ideal for your situation. If you get one of these 3.5" Removable Rack & Tray (http://www.dse.co.nz/cgi-bin/dse.storefront/en/product/XH5067) plus a spare tray, then there is no risk to your Windows installations (or Linux!) while you are getting familiar with Linux. The rack fits in a spare 4.25" bay and you just switch the trays depending upon which OS you would like to run.

An even better idea would be to get another hard drive for Linux and install your current 8.4 gig drive as a slave formatted as FAT32. That way both OS's can access the shared drive and files can be shared between them.

Graham L
04-02-2006, 01:19 PM
It should have worked.

You can't have a "confused boot sector" even if you have put Grub on both disks. Only one of those modified MBRs is accessed when you start the computer. The BIOS loads the first level boot code from the disk it is told to use. That code is executed to read the code for the rest of the loader. Any code in that sector on the other drive doesn't matter. Its partition table will be read if necessary, but that part of the sector is not affected by loading Grub or LILO. Did you try telling the BIOS to boot from the 8GB disk?

Windows can see a drive whichj has Linux on it. But it says that an ext2 (or any other Linux) filesystem isn't formatted. Windows is ignorant. ;) There are programmes around which will mount the Linux file systems on Windows, but the best way is to have a FAT32 partition which both can see and work with.

marty124
05-02-2006, 11:37 AM
hi all if any one is on dialup
do you have problems with a linux sys
finding drivers
in particular the modem driver
i have mandrake 9.1 .10.ubuntu and lycoris disks
but the modem driver is very hard to configure
i can configure man,9.1
but any thing after that thve changed the
konsole configurtion
marty124

Murray P
05-02-2006, 05:11 PM
It should have worked.

You can't have a "confused boot sector" even if you have put Grub on both disks. Only one of those modified MBRs is accessed when you start the computer. The BIOS loads the first level boot code from the disk it is told to use. That code is executed to read the code for the rest of the loader. Any code in that sector on the other drive doesn't matter. Its partition table will be read if necessary, but that part of the sector is not affected by loading Grub or LILO. Did you try telling the BIOS to boot from the 8GB disk?

Windows can see a drive whichj has Linux on it. But it says that an ext2 (or any other Linux) filesystem isn't formatted. Windows is ignorant. ;) There are programmes around which will mount the Linux file systems on Windows, but the best way is to have a FAT32 partition which both can see and work with.


Ah well, what I ultimately ended up with was a corrupted boot sector. Maybe it was just coincidence that I had changed where the (Lilo at the time) boot partition resided.

Graham L
07-02-2006, 11:35 AM
I doubt if it was corrupted. LILO has to be told about changes. ESP is still not programmable. If you make changes, you change the lilo.conf file accordingly and run /sbin/lilo to change the boot manager section of the MBR. It doesn't do that automatically. The documentation tells you that. ;) Grub works differently: it reads the grub.conf file each time.

Murray P
07-02-2006, 12:59 PM
Different installation though GL, I installed off a new CD (same OS, diff ver), to a different partition using a different boot partition (and thinking I had preserved my old home folder separately). I didn't edit anything in the old installation, belatedly I tried to edit the new (uh-oh!). WIndows, of course was estatic, because I hadn't told it either, but I attempted to from the recovery function by booting the Windows CD (uh-oh! x2). What I got after that was some squiggly ASCII characters playing cards when I attempted to boot.

The more I tried the deeper the hole got. I'd bore you with the details about examining the boot sector, etc, using a rescue CD, but, I suspect, neither of us would be able to fathom what I was blathering about :D

jupiter1
11-02-2006, 02:03 PM
Hi Guys,
Been away for a while.
I got a live cd of Linux and ran it. It saw all my HDD's including the 8.4Gig Linux HDD.
Grub was on there. But I still can not boot into it.
The 8.4 Linux HDD is slaved to the Win2k HDD on IDE Chnl 0.
Could this be the problem ?
Will I have to make it master on IDE 0 or maybe IDE1 ?
IDE1 master has a bootable copy of Win2k (as back up) which has now been corrupted by my attempts to install Grub.

Any idears anyone ?

Regards,
Phil

Graham L
11-02-2006, 02:28 PM
It's a separate disk. Linux happily coexists with Windows in separate partitions on the same drive. So it doesn't matter that it's a slave drive.

Can you select the drive to boot from your BIOS? Try that. I/m sure the problem is that Grub hasn''t been installed properly.

Your reserve Windows should be easily fixed ... just replacing the MBR will do that. I'm not sure of the method with W2K... I've never had to do it with W2K (and all of mine share a disk with Linux).

jupiter1
11-02-2006, 05:22 PM
Hi Graham,
Thanks for such a quick reply.
Yes, I have tried changing the bios to boot from the Linux disk, didn't work I'm afraid.

My next question obviously will be how to fix the MBR.

The whole purpouse of thisLinux exercise (and the backup win2k disk) is because windows is so flakey. :-(

Cheers,
Phil

jupiter1
11-02-2006, 05:23 PM
I think I will try one more install of Linux (it is pouring with rain).
Phil

Murray P
11-02-2006, 05:34 PM
At the Recovery Console prompt, type fixmbr , if that doesn't work, type fixboot at the prompt.

Didn't work for me in the example I gave previously, but then I'd totally muffed the whole show.

BTW, if you can access your Linux drive/partition from the live CD, you can fix Grub and/or edit /etc/fstab (is the latter correct Graham).

Have a tootle around NTFS .com (http://www.ntfs.com/) for info on the MBR, Boot Sector and Patition Tables.

jupiter1
11-02-2006, 08:12 PM
Hi Guys,
Well, the re-install of Linux although it apparently went faultlessly didn't work.

All the suggestions you gave Murray for the MBR problem including some on the NTFS.com site didn't help my backup Win2k problem either.

It must be obvious by now why I want to migrate to Linux.

Course, I could always go back to win 3.11 or 95. At least they were more solid and securer than the what I've got at the moment :-((( (and I could fix any prob's that I did get).

Cheers,
Phil.

Murray P
11-02-2006, 09:50 PM
I got back into my win2k installation by doing a parallel installation (instruction on MS site and various others). It was never quite right, though it allowed me to shift the stuff I wanted to keep, in the end I reinstalled win2k and put Mepis back on with the boot loader on C:\ (hda), and I've not had an issue since. Oh, and I whiped all partitions, reformed them and formated using Qtparted from the Mepis Live CD prior to installing win2k, then went through the usual formatting during that.

Graham L
12-02-2006, 10:25 AM
A nasty thought, Jupiter. Does your BIOS have a boot sector protection option? That's intended to stop viruses being installed, but it can make OS installation interesting. :D I would expect some sort of error message when it stops you doing things, though. :(

jupiter1
12-02-2006, 04:58 PM
Hi Graham,
Not to my knowledge but will investigate and get back to you.
Phil.

jupiter1
14-02-2006, 07:58 PM
Hi Graham,
Yes, it does have a boot sector protection option but it is disabled.

Where to now ??

Phil.

Haze
14-02-2006, 08:10 PM
If you wanna fix the MBR, and happen to have a floppy disk drive, then hop onto www.bootdisk.com, download a MS-DOS 6.22 bootdisk, write it to a floppy.

Now, make sure the floppy is inserted, and restart the computer.

Now, it should come up with a DOS prompt like:


a:\>

Now, type:


fdisk /mbr

Now press enter once that is done, eject the floppy, and restart the computer, the MBR should now be fixed.

This worked for me when a sloppy uninstallation of Xandros left LILO intact.

Sweep
14-02-2006, 08:41 PM
Hi Guys,

It must be obvious by now why I want to migrate to Linux.

Course, I could always go back to win 3.11 or 95. At least they were more solid and securer than the what I've got at the moment :-((( (and I could fix any prob's that I did get).
Phil.

It cetainly is not obvious to me why you want to go to linux.
If so then why try to dual boot?
Why not back up all important documents from your Win2000 installation and install Linux on hda?

Your immediate problem is you are trying to install Linux and it does not work the way you expected.

Secondly you started with Win2K Pro and Linux Fedora and now it looks like you are putting Mepis on.

Sorry for me being confused.

Ex Haze.
If you wanna fix the MBR, and happen to have a floppy disk drive, then hop onto www.bootdisk.com (http://www.bootdisk.com/), download a MS-DOS 6.22 bootdisk, write it to a floppy.

And how exactly will a MS-DOS 6.22 boot disk fix the master boot record on a NTFS partition? I'm even more confused.

Murray P
14-02-2006, 09:21 PM
And how exactly will a MS-DOS 6.22 boot disk fix the master boot record on a NTFS partition? I'm even more confused.

Essentially Jupiter has done the same thing with the w2k (ah, don't you love that monicker) CD, fixmbr and/or fixboot.

I think the ref to Mepis was only my suggestion of it as a live Linux CD. Not a bad choice though.


When I had similar issues, looked at my boot sector and MBR, via a boot CD, which had reference to boot/LILO still pointing at hdb, where no LILO was (BTW, the newer version of the OS changed to Grub), for which I didn't have the knowledge/bravery to try to edit (pretty arcane stuff in there). Once I did the paralel installation of win2k, I used a utility called dskprobe.exe to have a look at much the same info in a slightly different format, and there the reference to booting from hdb remained, this time I attempted to edit it, but nothing useful seemed to stick, hence wipe > reinstall.

Nasty thought number two for the evening, you have something similar lurking in your boot sector. Why it is protected I don't know or can't remember, I don't remember which :D ).

Haze
14-02-2006, 09:38 PM
And how exactly will a MS-DOS 6.22 boot disk fix the master boot record on a NTFS partition? I'm even more confused.
AFAIK, the MBR doesn't pertain to any particular disk format, be it FAT16, FAT32, NTFS, and others. This means that even the archaic fdisk can still fix the MBR of an NTFS formatted hard drive.

For more information, look no further than a very reliable source:
Microsoft (http://support.microsoft.com/?scid=http://support.microsoft.com%2Fdirectory%2Fworldwide%2Fen-gb%2Fdefault.aspx%3Fscid%3Dkb%3Ben-gb%3B315224%26amp%3Bln%3Den-gb)

jupiter1
18-02-2006, 08:31 PM
Hi Guys,
Finally got Linux Fedora in and working.
Like I said earlier, the installation of grub corrupted my backup version of win2k on hdd g and no ammount of fdisk mbr etc. or windows repairing could fix this.
Consequently I installe Fedora on this drive after formatting the 8.4 gig has fat32 and transfering my working files.
Fedora does now work, kind of. It can only see the HDD that it is installed on but can not see any other of the fat32 drives.
Fedora has also made its self the default op system so I have to go through 2 boot menus.

At least I'm a bit closer !

Cheers,
Phil

jupiter1
19-02-2006, 08:45 AM
Hi Guys,
I now have a working Fedora install but have two minor problems left to solve.

1. The dual boot works but defaults to Fedora and only gives me 2 seconds to opt for the other op system.

2. The Fedora install can not see my other (8.4 Gig) HDD which is formatted in FAT32 style.

How do I fix these two items please ?

Phil.

Jen
19-02-2006, 09:03 AM
For the boot issue:

Open up a terminal (console) window, and at the $ prompt enter in this:

su - [press enter] (note the space between the su and the dash)

Enter in roots password at the prompt, then enter in this:

gedit /etc/grub.conf

Wait for a second or two, and a window will appear with the contents of your grub.conf. This window is the editor program called gedit.

You will see Fedora and your Windows (probably called "other") listed beside the word "title". The very first entry line which starts with "title" is number 1, the second entry starting with "title" is number 2 and so on. So, if you look to where it says:

default=1

This is specifing that the operating system (or kernel version) given under Title 1 is the default. Change that 1 to a 2 if that is where your Windows (Other) entry appears. This will make Windows the default OS to boot

Where it says:

timeout=5

That is the time in seconds that the bootloader will give you before booting the default OS. Just change that to 10 or 15, or whatever time you would like it to give up before booting the default OS automatically.

Once you have done your editing of the grub.conf, click Save and then close the window. You will see the changes when you next boot up.

-------------------------------------------------------------------------------

For your FAT32 partition, if you could enter into the same terminal window while still as root (root has the # prompt while a normal user has a $ prompt) this command:

fdisk -l (note that is a lowercase L)

Post back here with that information (if you just highlight the text with the mouse and then click the middle (scroll wheel) button of the mouse, it will paste whatever you selected.

Now also enter in this command and again post back here with the output:

cat /etc/fstab

The command "cat" just lists the contents of the fstab file, a good way of viewing the contents of a file without the risk of accidently making a change in it. :)

jupiter1
19-02-2006, 03:08 PM
Thanks Jen,
The fix for the boot problem worked perfectly, many thanks.

I have the 2 lots of data for the invisible HDD problem but am having trouble transfering it over to my windows system for reply to you on PressF1. My Linux system is not yet configured for internet or eMail, my next project !
Will keep at this transfer problem as I'm sure I can ace it somehow.
Will get back to you.
Phil.

jupiter1
19-02-2006, 03:43 PM
Hi Jen,
I knew I could do it :-))

PART 1

[phil@localhost ~]$ su -
Password:
[root@localhost ~]# gedit /etc/grub.conf
[root@localhost ~]# fdisk -l

Disk /dev/hda: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 1275 10241406 7 HPFS/NTFS
/dev/hda2 1276 9964 69794392+ f W95 Ext'd (LBA)
/dev/hda5 1276 9964 69794361 7 HPFS/NTFS

Disk /dev/hdb: 8455 MB, 8455200768 bytes
255 heads, 63 sectors/track, 1027 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 1027 8249346 c W95 FAT32 (LBA)

Disk /dev/hdc: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 1275 10241406 83 Linux
/dev/hdc2 1276 9964 69794392+ f W95 Ext'd (LBA)
/dev/hdc5 1276 9964 69794361 82 Linux swap / Solaris
[root@localhost ~]#



PART 2

[phil@localhost ~]$ su -
Password:
[root@localhost ~]# cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
LABEL=SWAP-hdc5 swap swap defaults 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
/dev/hdd /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
[root@localhost ~]#


Gibberish to me but I expect you can make sense of it.
Cheers,
Phil

Jen
19-02-2006, 04:25 PM
Righto, what we are going to do is put an entry into fstab so that it automatically mounts and gives you read/write access to it, then make somewhere for it to be mounted, and finally a shortcut from your home directory to the shared drive. Please observe all spaces and case sensitivity.

Open up a terminal window and su - to root again. Enter in:

gedit /etc/fstab

Insert a new line after this one (actually not sure if it matters what order it appears in, but to be safe) :

/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0

And put in:

/dev/hdb1 /mnt/shared vfat auto,umask=000,user 0 0
Save and close gedit.

Now while still as root (#) in the terminal, you need to make a directory called "shared" under the /mnt directory. This is where we specified above that the 8.4 gig FAT32 drive would be mounted.

mkdir /mnt/shared

Next up, we shall make a shortcut (symlink) to this /mnt/shared directory to save time navigating to each time to find your FAT32 partition. This shortcut will appear as a folder in your /home directory and will take you straight to the shared 8.4 G drive. Still as root, enter in:

mkdir /home/phil/shared

Then enter in:

ln -s /home/phil/shared /mnt/shared
(note lowercase L in ln, and white spaces)

You will need to reboot your machine for the new fstab entry to be read and the shared drive will be mounted automatically and give you read/write access to it.

Try putting some files in the shared 8.4 G drive when in windows and then make sure Linux displays those files after rebooting. Let me know if you have problems.

jupiter1
19-02-2006, 04:46 PM
Hi Jen,
Thanks for that. I will attempt this change when the house is empty and quiet !
Below is a picture of my final objective for your information.

My final objective is to have two systems on the same computer vis:-

HDD C and D is one drive on IDE chnl 0 as the master drive.
C is 10 Gig with Win 2k on it: D is 70 Gig. with data on it.
C & D are formatted as NTFS.

HDD G and H is one drive on IDE chnl 1 as the master drive.
G is 10 Gig with Linux on it: H is 70 Gig with data on it.
G & H are formatted in the Linux format (ext3 ?).

HDD J is one drive on IDE chnl 0 as the slave drive.
J is 8.4 Gig formatted as FAT32 which I would like to be seen by both Windows and Linux.

The CD-RW is on IDE chnl 1 as the slave which I would like to be available to both systems.

Drive F is a HP card reader. Drive I is a Iomega Zip 100 drive. Long term I would like both of these to be available to Linux.
Even longer term I hope to ditch Windows completely in favour of Linux.
Win2k, Excel, Word and Money are the only MS products that I use at this time.

I will get back to you once I have done your latest fixes.

Regards,
Phil H.

jupiter1
21-02-2006, 09:28 AM
Hi Jen,
I have completed all the instructions that you gave me and all seemed to work exactly as you said.
However, when I try to access the 8.4 Gig (which has many files on it ex Win2k) I get an error msg vis:-
Unable to mount HDD. "unknown file system type, "/vfat".
In both "my computer" and my "home folder" the icon of the 8.4 Gig has a red circle with a red slash over it.
The 8.4Gig is formatted in the FAT 32 format.

With respect to spaces in entered commands,
in gedit how many spaces between "shared" and "vfat" also "vfat" and "auto"

Also please confirm that there is a space between "ln -s" and "/home"
also a space between "shared" and "/mnt".

I'm fairly certain that I have done it correctly but best to check.

Cheers,
Phil

Jen
21-02-2006, 10:03 AM
The single white spaces are as you mention. In fstab, you can use the tab to line up each section with the one above it eg. all the devices (/dev) under the one column, the mount point under the others (/mnt/shared), the file system type (vfat) under its column etc. It doesn't have to be accurately lined up, or I think a single white space between each section is fine as well.

The red circle over the folders means that you do not have permission to access that folder. Can you please post back with your fstab again now that you have edited it. It should of set the permissions so that everyone can access that drive. It also looks like you have an / in front of the vfat in the fstab?

cat /etc/fstab

Graham L
21-02-2006, 11:19 AM
You have to be careful with the slash character ("/"). In MS-speak, it's the marker for options to commands. In *nix, it's the separator in a directory tree. A slash, with nothing before it means the root of the whole system directory tree (not of the /root directory, which is the home directory of user "root" :D).. So, /tmp specifies the tmp directory in the top level. "tmp" specifies a directory in the current directory. /home/fred/tmp explicitly specifies a directory of that name in user "fred"'s home directory. It's not an option marker. Ever. It might be the start of an argument which is a directory. You haven't got a directory called /fat32 .

If you give a command, or use an editor to insert a command line in a file such as /etc/fstab, you must have "whitespace" between the elements of the line. "whitespace" is a set of characters containing the space character, the tab character (most often within a line) and often linefeed (which you get by usng the return key), formfeed, etc. You sometimes strike that if you enter a command from the keyboard, and hit enter without giving any arguments. The system will just wait until you give it something it can work with. You have given it the whitespace, and it still want more.

In MS you can often run options together, like "/b/s/w". *nix does not like that. It doesn't see that as a set of separate arguments; that's a root based directory tree. *nix options are prefixed with "-" . You might give a command like "ls" with no options. "ls -l" has one option: "l" . If you type "ls-l" it complains because it hasn't got a command called that. (If you wanted to be smart, you could give it such a command ... alias ls-l=ls -l. :D) If you give it multiple options, you should do it like tar -t -v -z -f filename.tgz, but there is another way ... tar -tvzf filename.tgz or, for tar, which is a very old programme, tar tvzf filename.tgz. If you want to use a spelled out option, they are prefixed with "--". A useful one is, say ls --help.

If you still have problems with accessing that Windows disk, it might be due to the permissions on the mount point. That's the /mnt/shared directory. It exists, whether or not the disk is mounted to it. It normally has no files in it unless a physical disk is mounted.
You could do (as root), chmod 777 /mnt/shared. (I don't like that "777" 755 would give read access to all; with only root allowed to write.)

jupiter1
21-02-2006, 12:40 PM
Hi Jen,
Below is what it looks like now.
On boot up I get error msg = "unable to mnt, format error in superblock"



[phil@localhost ~]$ su -
Password:
[root@localhost ~]# cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
LABEL=SWAP-hdc5 swap swap defaults 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
/dev/hdd /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/hdb1 /mnt/shared vfat auto,unmask=000,user 0 0
[root@localhost ~]#
Cheers,
Phil

Jen
21-02-2006, 02:33 PM
/dev/hdb1 /mnt/shared vfat auto,unmask=000,user 0 0
[root@localhost ~]#Ah, there is a typo in that line. It should be umask and not unmask. Change that, and it will help with the user permissions. Also make sure you have a single carriage return at the end of that line you added so that the cursor sits on the line underneath, and then save it. See if this helps.

Let us know if you still get the error message when you reboot.

Graham L
21-02-2006, 04:13 PM
The misspelt option is what is preventing the mount (though it's a strange error message). ;) Anyway, umask just sets the default permissions on any files created on that disk which it is mounted. As far as I know, it's the permissions set on the mount point which control access to the mounted disk.

jupiter1
21-02-2006, 05:55 PM
Hi Guys,
Yes, the typo refered to was the cause, the HDD now mounts OK. strange thing is I can see and access it from "computer" on the desktop but not from "home/phil/shared". Not realy a major.

I have also managed to install my printer but have not had any sucess with the internet email or browser, (ie the modem).

Although I can see HDC1 and 2 and 5 in system tools/hardware browser/HDD
I can't see or access Hdc2 or 5 from the desktop or computer.
This is the 70 Gig partition of the 80Gig hdd with the fedora system on it.

I will be away from about 9:00am tomorrow for a couple of days so don't flag me away if you don't hear from me for a while.
I really appreciate all of your help.

Phil

Jen
21-02-2006, 06:09 PM
Hi Phil, good to see we are getting there. :)

For your /home/phil/shared folder denying you access, try this command from a terminal and as root (su -).

chown phil /home/phil/shared

hdc5 according to your fdisk -l output you posted earlier, is the swap partition. You are not meant to be able to mount it and look inside, so to speak. The hdc2 looks like the shell of the extended partition.

Modem is next on the list huh? Please tell me you either use broadband with a ethernet connection or an external serial dialup modem ... :p

jupiter1
21-02-2006, 08:28 PM
Hi Jen,
CHOWN doesn't seem to work but this isn't a major prob as I can access the disk and data OK from the "computer" icon on the desk top.

HDc2/5 is supposed to be my 70 Gig data section of the Hard Disk which has Fedora in the first 10 Gig (HDc1) partition, not a swap file.

My modem is a standard 28.8 dial up on COM2.

jupiter1
21-02-2006, 08:50 PM
Graham's CHMOD didn't work either :-(

Graham L
23-02-2006, 03:13 PM
The problem with /home/phil/shared is that you tried to create a symbolic link with the same name. (I suspect that didn't work). You can have one of these, but not both. ls -l /home/phil will show what you got.

The symbolic link is the way to do what Jen suggested. Making a directory doesn't do it. (Of course you could mount the partition there rather than on /mnt/shared ... that would work).

Anyway, to create a directory inside a user's home/user/ tree you should be the user to do it. That way the directory will automatically belong to the user, not root.

jupiter1
01-03-2006, 07:13 PM
Hi Guys,
I'm back. Been messing with my linux install for a couple of days but with no improvement.
Life would be soooo much easier talking to you guys if I could get my internet connection going. I wouldn't need to re-boot to Windows all the time and back again.

I still can not see the top 70 Gig of my Linux HDD. This seems to be one wopping big swap file instead of my dedicated linux data area !
Any idears ?

Cheers,
Phil
ps I can see the 8.4 Gig shared hdd ok