PDA

View Full Version : Parallel port



taly
16-10-2005, 10:57 AM
Hi there!

I am connecting printer and / or scanner to the parallel port, but PC don't detect them. Device manager sais that LPT1 is ok.

Pehaps the hardware problem with the connector, because USB way printer works, but scanner don't have USB, so I have to use LPT1

Any ideas?

Speedy Gonzales
16-10-2005, 12:10 PM
Go into the BIOS and put the parallel port on EPP.

taly
16-10-2005, 10:35 PM
Go into the BIOS and put the parallel port on EPP.

Tried, but did not help. Was suggested to get a parallele portcard PCI, but it will involve to fiddle with some jumpers, that I don't know yet how.

bartsdadhomer
16-10-2005, 10:51 PM
Have you installed the drivers yet
Many parrallel devices won't be detected until the drivers are installed and you have selected which port you want to use it on
Also makes a difference what OS you are using, for example XP will automatically install most parallel laser printers automatically, whereas 98 won't even recognise it till the drivers are installed.
Also trying another cable wouldn't hurt, yours may be jiggered

taly
17-10-2005, 10:04 AM
Yes, driver is installed. Sys is XPhome. Now, Help sais to test port printer connection using command prompt. If paper moves -the port is ok. It sais : type at prompt: COPY CON LPT1 and enter. After that it said: 1 file copied. then type: showpage, press contr+z, enter. But it does not recognise this command, sais wrong command. May be it is case sensetive or other suttlety?
Canon buble jet are they postscript printers?
Any ideas?

Speedy Gonzales
17-10-2005, 10:13 AM
So, is the printer parallel and USB?

If it's USB, just plug it into a USB port. Then the scanner, will be using the parallel port by itself.

godfather
17-10-2005, 12:36 PM
Yes, driver is installed. Sys is XPhome. Now, Help sais to test port printer connection using command prompt. If paper moves -the port is ok. It sais : type at prompt: COPY CON LPT1 and enter. After that it said: 1 file copied. then type: showpage, press contr+z, enter. But it does not recognise this command, sais wrong command. May be it is case sensetive or other suttlety?
Canon buble jet are they postscript printers?
Any ideas?

You must be entering the DOS command incorrectly.

COPY CON LPT1

means copy from the console (keyboard) to the parallel port (LPT1)

It should noy say 1 file copied, the cursor should drop 1 row and await the input expected from the keyboard (in this case the text "showpage")

Ctrl+Z terminates the command and "writes" the text to LPT1.

But reading the thread, I am very confused with what you are trying to do. If we knew the printer and scanner models it would help.