PDA

View Full Version : Login/Logout irritation - Linux



Myth
05-10-2005, 08:25 PM
OK, I have this problem that it seems I am unable to answer, even with help from some people in IRC.

When I logout of linux, I end up at the login screen. The problem is, the login screen is at a lower resolution than the rest of linux. Because of the lower resolution, I can only see part of the screen (the session and system buttons are out of range). To fix this I press the combo of Cntl+Alt+Bkspc which returns the screen back to normal resolution. I know this is not normal .. please help.

BTW it doesn't matter whether I am using kde and kdm; or gnome and gdm.

I'm thinking it is a possible x problem, but Im not sure.

Have any of you had this problem, and if so what was the fix?

Jen
05-10-2005, 08:37 PM
Post up your xorg.conf plus what your monitor brand/model is and what resolution you run it at. :)

Myth
05-10-2005, 08:45 PM
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/lib/X11/rgb"
ModulePath "/usr/lib/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/CID/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
EndSection

Section "Module"
Load "glx"
Load "extmod"
Load "dbe"
Load "record"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

Section "Monitor"

#DisplaySize 320 240 # mm
Identifier "Monitor0"
VendorName "PTS"
ModelName "304"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Device"

### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]
#Option "FPDither" # [<bool>]
#Option "CrtcNumber" # <i>
#Option "FPScale" # [<bool>]
#Option "FPTweak" # <i>
Identifier "Card0"
Driver "nvidia"
Option "NoLogo" "1"
VendorName "nVidia Corporation"
BoardName "NV17 [GeForce4 MX 440]"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 16
Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubSection
EndSection

Monitor is a Proview series model 786N series KX-772NSG and I normally run it at 1024*768 and 75hertz

Jen
05-10-2005, 09:11 PM
Why is your monitor set as a PTS brand and model? Have you tried a generic 17" CRT and manually specified your HorizSyn and VertRefresh rates? You will need to find what these settings are otherwise you might end up with a weird looking display.

You should also be able to run your monitor at a Default Depth of 24. It might be better if you remove the "1280x1024" from the Modes as well seeing this is not what you are using. Your "Screen Section" looks like it is missing information. The default depth is 16, yet you only have settings for 8??

Have you been using KDE or Gnome to manually adjust the resolution settings via its GUI?

Here is an example of what my section looks like:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1152x864" "1152x768" "1024x768" "800x600"

Chilling_Silence
06-10-2005, 12:33 AM
xorgconfig is your friend :-)

vinref
06-10-2005, 01:59 AM
xdm/gdm/kdm is clearly not using your normal xconfig file.

Your distro may have another configuration file for the xdm/gdm/kdm. Look for something along the lines of /etc/xdm, /etc/X11/xdm etc etc, and point it at your normal xconfig file.

Myth
06-10-2005, 11:00 AM
Ok... Vinref .. I searched darn near every file on my system with any mention of /etc/X11 or xorg or xorg.conf. All seemed ok

Jen and Chilling_Silence .. I reconfigured xorg first using xorgconfig, then compared it to original; then did manaul editing (had one terminal with org.conf open, and had application launcher running xorgcfg to get the various horizontal and vertical modes (as no specs for my monitor were online).
After much changing of each variable, I think I have finally hit a happy medium between horizontal, vertical rates as well as refresh htz that also enables the gdm to show a consistant res of 800*600 on initial login, and also logout while still showing the entire screen. In other words success (finally).

Thanx :D

Now ... kindly follow me to my next thread :p

Chilling_Silence
06-10-2005, 02:49 PM
If you've had enough fun with gdm, try Entrance.. Its pretty, looks beautiful!

beama
08-10-2005, 09:30 AM
Heres a tip, if your monitor manufacturer doesnt publish HorizSyn and VertRefresh rates like one of mine, Run a live cd on your system then get the generic screen settings from its config file then carry those across to your setup I used vi.

Myth
08-10-2005, 09:38 AM
Sweet, never thought of that. Time to pull Knoppix out :D just to double check my settings