PDA

View Full Version : Unable to update WinXP, no BITS in Services



sal
30-09-2005, 08:37 PM
I've been updating WinXP (Pro SP2) at the start of the month with no probs this year, went to update this month and wasn't able to do so (http://imagef1.x10hosting.com/files/noWU.jpg). Something about certain Services not running, of the 3 mentioned only BITS was not only not running but not on the list. Anyone know how to fix this?

Attached file: no_BITS_in_Services.png (http://imagef1.x10hosting.com/files/no_BITS_in_Services.png) (16 KB)

Freejack
30-09-2005, 08:55 PM
This may be a little too obvious but shouldn't the Automatic Updates service be set to automatic? Change it and try starting it before re-visiting Windows Update.

gibler
30-09-2005, 08:58 PM
Er, isn't BITS the Background Intelligent Transfer Service I can see in your screenshot. Doesn't it give an error when you try and start it?

may this forum thread (http://www.broadbandreports.com/forum/remark,13605896) covers your problem.

sal
01-10-2005, 03:33 AM
Argh, I swear I double and triple checked for Background Intelligent Transfer, how stupid is that. Well anyway, they were both on manual, the reason they're not started in my screenshot is I restarted, but even going to Windows Update and running the scan, I still get given the no go update even though the services are started.

I've made my way to the Windows Help News Group on the issue (http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?query=0x8DDD0018&dg=microsoft.public.windowsupdate&cat=en_US_56d1dd45-de9e-4fc5-9bc1-2d1d0de6daee&lang=en&cr=US&pt=&catlist=&dglist=&ptlist=&exp=&sloc=en-us), I should find a solution there and the link you posted gibler looks promising too. Thanks.