PDA

View Full Version : Windows XP Can't see external USB hard drive!



Chemical Ali
09-07-2005, 01:55 PM
Hi there

I have an 80GB hard drive inside a USB Enclosure that Windows XP can't seem to pick up under "My Computer".
Disk Management can see it as a primary disk okay and identifies it as a primary partition (NTF ) so why can't "My Computer" see it so I can access the data on it?!

The laptop's primary drive is formatted as FAT32 -- is this why it is having trouble seeing it or is it beacuse i now have 2 primary partitions??

Graham L
09-07-2005, 02:40 PM
Is the hard disk in the USB enclosure formatted? Windows can't use it, therefore can't "see" it, unless it has one of the Windows formats. Go a step further in Disk management ... tell it to format the disk. ;)

It doesn't matter how many primary partitions you have (up to 4 ;) ) but only one will be marked as "bootable" at any time. The file system of the boot partition doesn't matter either. It knows what its own format is. It also knows to use different access software to talk to disks in other formats.

pctek
09-07-2005, 03:17 PM
And make sure its jumpered to master.

Graham L
09-07-2005, 03:22 PM
The jumper should only affect the IDE-USB adapter (if it makes any difference ... it's the only disk in the USB box), and Disk Management can see the disk.

Chemical Ali
09-07-2005, 04:36 PM
Sorry

Original post done in a rush!
Yes external hard drive is formatted (NTFS) and has 39GB of data on it which I can see and access via "My Computer" on my main PC but not on my laptop which is the problem.
Internal drive on laptop is formatted on FAT32 basis but as laptop has XP Home on it I didn't think it would have any problem reading/recognizing the external drive formatted as NTFS system.
I want to be able to access the data from both my main PC and my laptop!
Any ideas as to why I am having problems accessing the external hard drive on the laptop -- obscure Operating System settings or something??!

Graham L
09-07-2005, 04:50 PM
If you normally use the Administrator account of the desktop, and a "user" account on the laptop, perhaps it's a security conflict. Though I would expect you to be able to "see" the partition and its directories, just be not allowed to access it.

Try using the "Owner" privileged account on the laptop, anyway. It might make a difference. ;)

Chemical Ali
09-07-2005, 06:41 PM
Only have myself set up with an administrator account with fullprivleges so no difference there to whats happening on the main desktop PC.
I was wondering if it could be due to an overtaxing of the USB connections on the laptop.
It only has 4 USB connections on the back of the laptop with 3 of them being occupied by:
Mouse
Creative external sound card (Audigy 2 NX)
The hard drive in question

Or possibly a USB port/controller conflict???


Any thoughts or comments?

Chemical Ali
09-07-2005, 06:50 PM
I can see the drive (the external one) in " Device Manager" as well!
But still not in "My Computer"

pctek
09-07-2005, 08:33 PM
Hmmm. Have a look at the drive letter arrangement - its probably disabled all of them past what drive letters you already have.
And XP in Fat32 will read NTFS drives without a problem.

Chemical Ali
09-07-2005, 10:16 PM
And where do you look for that (the drive letter arrangement)?

Chemical Ali
09-07-2005, 10:21 PM
PC Tek -- yoiu were right.
Looked under "disc management" and no drive letter was assigned to the external drive (should've noticedthat before!!).
Right clicked on drive and assigned drive letter and all okay now -- "My Computer"now displays selected drive.
Thanks for the tip!

Cheers

Paul