PDA

View Full Version : Drive not reading Discs



Ollie123
28-06-2005, 12:20 AM
I have installed a combo drive, (reads/writes CDs and reads DVDs).
But when I put any type of disc in, the light blinks for about 20 seconds and then stops and dosn't recognise the disc.

The last drive that I had was exactly the same worked for about 1 month and then did the same thing. I returned it and got this new one that hasn't even worked for a second.
I have a DVD writer installed as well, could they be competing against each other or is this just another faulty drive? :illogical

Any help would be appreciated.
Thanks. :)

lazydog
28-06-2005, 01:36 AM
Hi there,

I have the same problem on one of my computers. It has a cdrw drive that sometimes does that when i put a disc in to play. Sometimes when its doing the blinky light bit and i sort of know its not going to play, i try to eject the disc and when i push on the eject button, the light turns from green to red. And on some other cd's that i try to run in the drive, ( two different games in the last two days), the splash screen comes up on the monitor and when i push install to install the game nothing happens!. If i open up explorer to view the cdrw drive it doesnt recongnise that theres anything there, in the cdrw drive. Yet on most discs its good as gold.
It's only an old 4x4x20x cdrw. I've run Everest but it doesnt tell me what make/model it is only the speeds it runs at. I was going to try updating the drivers for it but dont know the make/model number. I'll have a look inside the box to see if it says anything on the sides of the drives case.

The other thing i was going to try is upgrading the motherboard drivers.
The reason for this is because the computer is fairly old now, P3, 733mhz, 20gb hdd,396mb ram, G4mx420 32mb graphics card on an Asus CUV4X-C motherboard running XP home. I was having trouble getting the computer to run after installing the graphics card 4 days ago and found out that the agp slot drivers for the motherboard need upgrading to run the card at 4x otherwise it will only run at 2x agp. I'm hoping that the driver package (theres 4 drivers/utilities in the pack) will also help the computer recognise the network card too as thats been playing up too. Sometimes when i start the computer it will reconise the network card and other times it doesn't.
I've found and downloaded them (the mobo drivers) from the Asus site and will load them up in the next couple of days. Bit busy tomorrow.

Sorry if i'm jacking your thread Ollie123, but it looks like our troubles may be similar and the same answer could fix both of our problems.
If theyre different then i appolligise and i'll start a new thread. Just thought we cought kill two birds with the same stone as they say.

Have you tried upgrading the Cd/Dvd drivers for your drive?
Does it recognise the drive under My Computer?

I wont try to help you with your problem cause i cant even fix mine :rolleyes: and theres people here who know a hell of alot more than computers than i do.
Goodluck with your problem and people, after your've sorted Ollie123 out, can you have a crack at mine.

Cheers, Brian.

Ollie123
28-06-2005, 01:55 AM
Hey,
Yeah the drive is been recognised in my computer and in the BIOS as the secondary and slave drive.
Shall see if I can find some drivers, but you can usually just plug in these optical drives and they are installed automatically.

One thing we can try is to swap the positions of the drives, cause sometimes one of the drives likes to be the master drive.

If this dosn't work I will just swap it for another drive, have swapped two of these drives in the last 2 months for new ones since they stopped working.

Thanks

Greven
28-06-2005, 09:42 AM
I would suggest checking the manufacturer's website to see if there are any known issues with your drive & see if they have released updated firmware to fix it.