PDA

View Full Version : Linux nonroot on line



sarum
13-04-2005, 08:37 PM
Hi there, I'm still trying to go on line while in non-root. (I can only go on line as root). I have found the following in a 'How To'
"...ensure that the file /etc/hosts.deny contains the following line:

ALL: ALL

Also add the following line to /etc/hosts.allow:

ALL: LOCAL"

So far I've done (in a terminal of course)
su
password To get me into root
cd /etc Then
ls To see the files; and there they are 'hosts.deny' and 'hosts.allow' but can someone tell me please how do I add the 'all: all' & 'all: local' to these files. You may have guessed that I'm a newbie (for rather a long time now - but I'll not give up). So please keep it like instructing an elderly beginer.
I've 2 computers; Fedora Core2 linked to my M.E. machine with the modem.
Thanks in advance
Sarum

johnd
13-04-2005, 09:16 PM
Sarum

There is something wrong here - you might have to explain a bit more - how do you know that you are on line as root?

Are you using kppp to get on line? If you are and you are logged in as a normal user, then it does require root privileges to run. You should get a key showing on your panel. You should click this to remove it so that other programs are then blocked from running with root priviledges. If you do this, you are not on line as root.

The hosts.deny file is for blocking hosts (other computers) from accessing your PC.

johnd
13-04-2005, 09:22 PM
The hosts.deny file is for blocking hosts (other computers) from accessing your PC.

I just wanted to point out that this does not replace a firewall. Use your in-built fireall or better still, Firestarter from http://www.fs-security.com/.

John

Graham L
14-04-2005, 12:50 PM
It's probably a good idea to have those lines on the .deny and .allow files.

Just use a text editor (not a word processor) to work on system files. The files must always remain "text" files. (Try using the Midnight Commander for navigating around in a command window ... it is wonderful. It even includes a simple text editor (F4) ). My favourite text editor is joe, but gedit is fine too. Life is too short for emacs, and vi is not nice.

sarum
15-04-2005, 07:09 PM
Johnd, Thanks for your reply. I may not have been as clear as I should have been:- ...to get on line I have to start my Windows ME computer and dial-up. Once connected, to the internet I switch my KVM box to Linux and turn on my Linux computer. If I log in as root and go to Mozilla; then I'm on the 'net (Google, bookmarks etc:.). But if I login as nonroot - there's no way to connect that I can see. Even clicking on the update icon(bottom right end of panel) I get a box asking for root's password and up comes Mozilla but off-line and yes there's a key showing.
On a previous distro: I had an icon on my nonroot desktop panel; a click on that and a small box asked for root's password and all was well. I think I was dual booting then though. Did I mention that I'm the only user of these computers. You mention kppp - can't find it in the start column.

GrahamL, my thanks to you also. This seems to be the answer to what the HowTo was suggesting. I've not used a text editor to work on system files, but I'll give it a go - after a good read-up. I'd be inertested to hear John's comments after reading the above, and apologise for not being more explicit in the first place.
My regards to you both Sarum.

johnd
15-04-2005, 09:30 PM
Still not very clear here - hope I am not being thick. I thought a KVM switch was for one system unit and two sets of keyboards, screens and mice?? Yet you talk about turnign on the Linux PC.

YOu might have to detail clearly exactly what your setup is.

If your goal is to get both on the net at the same time then you should be using a LAN cable and either the inbuilt ME internet sharing or Linux IP masquarading.

John

Also which Linux distribution are you using?

johnd
15-04-2005, 09:32 PM
Also which Linux distribution are you using?

I meant to delete that bit!

Jen
15-04-2005, 09:38 PM
I meant to delete that bit!There is a edit button under your post John which is available for only 15 mins after hitting post for such oopsies :p

sarum
16-04-2005, 09:52 PM
Thanks John, My KVM connects two boxes to one k/b, mouse and monitor. Both boxes are connected via LAN; that's why I have to get on the 'net first with the ME computer, then KVM over to the Linux and if logged in as root; I'm on the 'net. Hope this helps. Cheers Sarum

Graham L
17-04-2005, 03:17 PM
So you connect to the ISP using ME, which shares the connection with the Linux. I'm not quite sure how limits you to connecting as root. :confused:

I believe that the GUI setup for modem connection has been obstructed by default security restrictions (it's a very serious loophole if individual users are able to use a modem on a multi-user system), though I would hope that that's been tidied. Is it KPPP?

I think I would look for a proxy server which would run on Windows ME, since your modem is on that machine. You ought to be able to access through that using any user account. ;)

johnd
17-04-2005, 08:29 PM
I think I would look for a proxy server which would run on Windows ME, since your modem is on that machine. You ought to be able to access through that using any user account. ;)

You don't really need a proxy server since 98SE and ME have inbuilt internet sharing software (ip masquarading I believe).

John

sarum
25-04-2005, 07:31 PM
Hi,
My apologies for the delay in replying (I've been away). Thanks for your help John and Graham it's been sorted with 'gedit' and a bit of help from a mate. Thanks also to Jen for interesting note on correcting text.
Cheers Sarum.