PDA

View Full Version : Internet Connection Sharing



Petermcc
11-03-2005, 10:38 PM
My PC and laptop both have Windows XP SP2.
They can both dial-up to the Internet using their own modems, with IE and Outlook both working fine on both machines.
The dial-up Internet connection on my PC has Internet Connection Sharing enabled. My laptop and PC are connected with a network cable, and that works fine.
However, I canít get the laptop to use the PC Internet connection.
The Internet connection shows in the notification area of the laptop task bar, showing activity when the PC uses the Internet. It also appears under Internet Gateway in Network Connections.
IE and Outlook both timeout when trying to use the connection.

Iíve tried playing around with IPs and DNSs.
Iíve tried ticking every service under ICS settings.
Iíve scoured the Windows help and support information on the computer.
Iíve tried uninstalling SP2.

Now what?

Peter

Speedy Gonzales
11-03-2005, 10:44 PM
Look under my network places on both. For the LAN icon. Highlight this right mouse/properties/TCP/IP.

The one with ICS enabled. Is the option under the LAN on use the following ip??

IP address: 192.168.0.1
subnet: 255.255.255.0

And on the networked PC, under the same info as above

Also on use the following ip: 192.168.0.1
subnet mask: 255.255.255.0
default gateway: 192.168.0.1

And preferred DNS server 192.168.0.1 ?

Also, do both have the same workgroup??

And any firewalls installed?? Is SP2's firewall enabled??

And r u using a crossover cable or a hub?? for the network??

Petermcc
16-03-2005, 07:12 PM
Thanks for the suggestion.
I've just tried that:
IP address: 192.168.0.1 and subnet: 255.255.255.0 on the PC.
IP: 192.168.0.1 subnet mask: 255.255.255.0 default gateway: 192.168.0.1 and preferred DNS server 192.168.0.1 on the laptop, but got messages about IPs already in use and in conflict.
They're on the same workgroup, with SP2's firewall on, using a crossover cable.

Now what?

Peter

Speedy Gonzales
16-03-2005, 07:17 PM
Oops slight mistake there Pete

Change the networked one to 192.168.0.2, and leave everything else, as is.

Leave the main PC ip stuff as is..as well.

Then it should be fine. It'll work.

Petermcc
16-03-2005, 08:07 PM
Thanks, the network is operating again! But not the internet.
Since the original posting, I reinstalled SP2 on the laptop, and now the internet icon doesn't show up in the notification area any more. Even when it did though, the laptop wouldn't connect to the internet through the pc. When I open IE, it "detects proxy settings" the tries to "connect to 66.102.7.104" or something similar, then times out.
Can you help?

Peter

Speedy Gonzales
16-03-2005, 08:24 PM
Hmm is Spybot or Adaware installed on the laptop?? Do a scan..

Dont know where the 66.102.7.104 comes from...


Umm if u use the laptop to go thru the main PC, the internet icon/dialup icon (if this is the icon you're talking about), on the laptop wont come up, if you're going thru the main PC.

Only, when u actually dialup from the laptop (if the laptop has a modem installed).

Or do u mean the LAN icon?? if it's the LAN icon, you're talking about, just go to My network places / highlight the LAN icons on one or both, and select properties / Under general tab.. Tick the 2 options down the bottom. Then OK. That'll fix the icon bit.

In Internet Explorer on the laptop, try going to Tools/internet options/connections / LAN settings. Untick the top 2 options. Then see what happens. If that doesnt work, it maybe XP SP2's firewall thats stopping the laptop, from getting on the net.

Are any other firewalls installed besides the XP SP2 one on both the PC and laptop? Is SP2's firewall enabled on both computers?

Speedy Gonzales
17-03-2005, 07:58 AM
The main thing, I forgot was the ICS itself Pete.

On the main PC, under the dialup/properties/advanced. Tick allow other network users to connect through this computer's internet connect then OK.

Then the laptop should get on the net. If there are no other firewalls stopping it.

Chilling_Silence
17-03-2005, 08:21 AM
Tell IE not to auto-detect settings, it doesnt need to...
Unless you're running a proxy to share Internet. Ive had good results with:
http://www.youngzsoft.net/ccproxy/

Petermcc
19-03-2005, 10:46 PM
Thanks for the suggestions.

I've installed and run Adaware and Spybot. I've tried turning the XP firewalls off (they're the only firewalls I've got installed). I've reset the defaults and tried exceptions.

For a while the dial-up icon was showing up on the laptop along with the LAN icon when the PC was connected to the internet. The laptop does now make the PC dial up when it starts up, and when IE starts, but still doesn't use the connection!

I don't know about proxies, but perhaps I'll visit youngzsoft and see what it's about.

By the way, what's SR_GUI? When I rebooted the PC before, the firewall said it was blocking it and do I want it to continue doing so?

Peter

Speedy Gonzales
19-03-2005, 11:02 PM
Did u enable ICS on the main PC?? Under the dialup/properties/advanced??

The first option under Internet Connection Sharing?

This has to be ticked before the laptop can get on the net.

Wouldnt have a clue what SR_GUI is. Never heard of it before.

BUT according to google this is for a firewall or VPN software.. Namely something here??

http://www.checkpoint.com/

This maybe one reason why u cant connect?? BUT then u say u have no other firewalls?? Are you sure about that?

You havent given this file access. This maybe why the laptop cant get on the net. Is this a site u tried to access from the laptop??

I wouldnt LEAVE XP's firewall off, if I were u.. If this is the only firewall u have. You're asking for trouble.

drcspy
20-03-2005, 12:54 AM
if you have a working network forget microcrap ics and goto www.analogx.com and get their lovely littel program 'proxy' .......i'tll make sharing your internet connection an absolute breeze............

Petermcc
20-03-2005, 10:35 AM
Thank you drcspy. You've made me a happy chappy!

drcspy
20-03-2005, 06:35 PM
:) :) :) ......a pleasure that proxy is such a nice little prog....