PDA

View Full Version : Ubuntu problem



Overdrive_5000
10-03-2005, 04:32 PM
Hi just installed Ubuntu 4.10 today it installed ok downloaded all updates but it would load up the GUI says something like 'I cannot start xserver because xfree86 may need to be set up' ? and then it says it has disabled the xserver ? until the problem is corrected. :help: What can I try have reinstalled but still the same. :badpc:

Jen
10-03-2005, 05:52 PM
Sounds like the XFree86 just needs to be configured again. At the root prompt just enter in XFree86 -configure and follow your nose. See if that helps.

Overdrive_5000
10-03-2005, 06:02 PM
Thanks Jen will try

Overdrive_5000
10-03-2005, 06:26 PM
Tried that but its says 'bash: Xfree86: comand not found

Jen
10-03-2005, 10:54 PM
Try this command instead xf86config. I think the other might only be for the new XFree86 4.4.0, and I see that you have a slightly older version. :)

beama
10-03-2005, 10:56 PM
try this then
at the bash prompt type X then press tab key tell us if if Xfree86 is there. The capitalisation is important of the X you must be logged in as root user for this to work because I dont think a normal user has access to this command ( not part of nonroot users enviroment setup) That may also be the reason Jen's command didnt work for you.

Overdrive_5000
11-03-2005, 09:39 AM
Ok i restarted choose recovery mode it came up with "root@ubuntu:~ #" so from there typed X then tab came up with X11 then the list of things did not have Xfree86 listed but it did have:
.bash_history
.bashrc
.gconf
.gconfd
.gnome
.gnome2
.gnome2_private
.gstreamer_0.8
.profile
.dbootstrap_settings
install-report.template.

Overdrive_5000
11-03-2005, 12:34 PM
Just found xf86config so I went through it saved it but when i go to startx i get fatal IO error 104 no screens found (my monitor is a LG Studioworks 710s and video card is a Geforce 6800LE).

Overdrive_5000
11-03-2005, 01:44 PM
I have managed to get into ubuntu now had to do 'dpkg-reconfigure xserver-xfree86'
the thing is it would only work if i set my video card to 'vesa' not 'nv' the problem now is that even though the refresh rate in desktop preferences says 85 its not running at that rate its more like 60 (flickering real bad) how can I resolve this problem? :help:

Jen
11-03-2005, 06:08 PM
Have a look at your XF86Free config file and make sure the HorizSync and VertRefresh settings for your monitor are correct. As root, just change them to the correct rates if wrong and then restart X.

/etc/X11/XF86Config or /etc/X11/XF86Config-4

Graham L
12-03-2005, 02:26 PM
And if that doesn't work, a trick I have used is to boot Knoppix (the live CD) and copy its XF86Config-4 to a floppy, and copy it to the appropriate location in the other OS later. Knoppix is very good at identifying video stuff. (If you haven't got a floppy drive, youi can mount the HD OS's disk, and copy to that. To a /home directory would probably be safest. Root can grab it from anywhere).

Overdrive_5000
13-03-2005, 09:40 PM
Thanks guys for your help but after that I realised I had no sound and a few other minor issues, decided to nuke it and went back to SuSE and so far have had no major problems even managed to get some of the updates to download. I may try ubuntu again in the future but will stick with SuSE 9.2 and XP for now, thanks again :thumbs: