PDA

View Full Version : Intermittent Keyboard Problem



Cptn Hotshot
10-03-2005, 02:44 PM
A friend of the good Cptn's is running a P4, 512mb RAM with XP Prof installed. Computer was purchased about Oct2003. Major other software installed is MS Office 2003. Keyboard is a MS branded one ... not sure of the model but it is a PS2 connection.

For sometime, friend has being having an intermittent keyboard problem when typing when what is typed is not what is displayed ..... infact it is all gobble-di-gook. This problem manifests itself out of the blue .... there is no pattern to it. One day it is fine ... the next day it happens. Friend tells me that if they sometime hit 2 keys at once, this can somteime invoke the problem, but not always (coincidental?). When it happens they need to reboot the computer to clear the problem and then all is fine until the next time it unexpectantly happens.

The good Cptn has:
1. run spyware (ad-aware & spybot) and anti-virus through it. All are running the lastest updates/signature files.
2. deselected Sticky Keys from Control Panel / Accessibility Options

Can anyone throw any light on the problem and how to correct it for good?

mark c
10-03-2005, 02:54 PM
First thing I'd do would be to try another kboard.

Cptn Hotshot
10-03-2005, 02:57 PM
That is the next think on my mind to do to see if it replicates itself. Also intend to use the keyboard on my computer to see if it happens there as well ... at least that would isolate the problem to the keyboard if it happens on my computer.

Cptn Hotshot
11-03-2005, 12:25 PM
Keyboard was swapped on friends PC and the same problem manifested itself again, so obviously it is not keyboard related.

I believe this isolates it to software (Win XP or MS Office) or something in the PC configuration. Any ideas anyone?

Cptn Hotshot
12-03-2005, 10:45 AM
Bump

Myth
12-03-2005, 11:32 AM
The only other thing I can think it might be are the keyboard drivers.....situated in BIOS :( but it shouldn't be
What (if any) config changes have been made prior to this problem?

Cptn Hotshot
12-03-2005, 11:42 AM
There have been no changes at all made ..... it has just started happening out of the blue.

mark c
12-03-2005, 12:09 PM
Sure nobody has fiddled with the comp? Not that i know how you could set it up to do that anyway.

You've got a real puzzle there. Next maybe start unchecking some progs in msconfig sort of trick. See if you can isolate which one's it does it with.
Not very helpful but....m

tweak'e
12-03-2005, 12:12 PM
i would suspect courpt fonts for starters.

what prog are they useing to type in when it goes all werid ?

Cptn Hotshot
12-03-2005, 01:36 PM
Problem occurs in Word. Also occurs in replying to emails through Hotmail or Yahoo Mail site when connected to the net. There is no pattern that I can identify causing the problem.

Could hardware be an issue?

Personally, I have never seen anything like it. As a last resort was thinking of a reformat and clean reinstall of XP and MSOffice and take it from there.

Graham L
12-03-2005, 02:31 PM
It's most likely to be a Windows setting. As a silly example,the Library computer I am sitting at has a little icon "En" in the bottom toolbar. Clicking on that gives me the choiice of variious Asian and Arabic languages. If I choose Farsi, لعثس صاشف اشححثدس فخ صاشف ] فغحث. What, can't you read that?

Cptn Hotshot
12-03-2005, 06:05 PM
It's most likely to be a Windows setting. As a silly example,the Library computer I am sitting at has a little icon "En" in the bottom toolbar. Clicking on that gives me the choiice of variious Asian and Arabic languages. If I choose Farsi, لعثس صاشف اشححثدس فخ صاشف ] فغحث. What, can't you read that?
Well, thanks for the hint/suggestion ... you were nearly spot on with the solution to the problem. I found the solution in Control Panel, Regional & Language Options, Languages, Detail, Key settings, Change Key Sequence. The trick was to deselect both Switch Input Language and Switch Keyboard layout.

Both of these setting, when active, were the cause of the problem whenever Left + Shift or Control + Shift were hit at the same time.

Not sure why anyone would want these both activated as default, which turned out was the case .... hence the problem in some shape or form since computer purchase.

Am now a happy chappy again (and so is friend) :thumbs: