PDA

View Full Version : Need to set the drive letter on a 2nd drive



netchicken
04-03-2005, 08:26 PM
This is the sort of question that was at the fore about 5 years ago :) :badpc: :badpc:

I have win98 2nd ed, I thought I would enter the 21st century and add a 2nd drive (after feel proud of posessing a free 20gig I was in Dick Smith and saw a 120 gig for only $110. sheesh...)

Anyway I set the bios for it to auto, and I can see it as a seond drive in the device manager. Unfortunatly it doesn't seem to exist anywhere else and doesn't have a drive letter. The place to set the drive letter in properties is greyed out.

Whats the trick to get it running?

Thanks

Speedy Gonzales
04-03-2005, 08:31 PM
Dont think 98 or se will see a 120gb will it unless u fdisk / format it beforehand? Or use something like Partitionmagic?

Can u see it in DOS??

zqwerty
04-03-2005, 08:34 PM
Possibly you should right click and format the drive, afterwards I think you will be able to name it. Maybe.

Speedy Gonzales
04-03-2005, 08:35 PM
I think thats the prob Z. It doesnt show, so u can format it. Only in device manager.

netchicken
04-03-2005, 08:40 PM
Man THAT was fast!

Its only a 20gig, but I was amazed that a 120gig was so cheap.

I don't want to format it as it has some files on it.
it came from another machine,

How would I look for it in DOS if it doesn't have a letter?

Speedy Gonzales
04-03-2005, 08:46 PM
Oh OK. SO, you SHOULD be able to access it, if there's something on it.

What IDE connection is it on?? The primary?? If so, did u jumper it to slave??

And select secondary slave in the BIOS??

netchicken
04-03-2005, 08:50 PM
Its on the same cable as my main drive,

I set the jumpers to slave on it, it was brining up an error till I worked that out, so its OK.

In the bios I just set the secondary slave to auto, otherwise I had to put the numbers in by hand which i don't know...

Speedy Gonzales
04-03-2005, 08:58 PM
Err if the 20GB is on the main ide connection, (connected to the main hdd with windows on it), it SHOULD be set to primary slave in the BIOS.

Secondary ide isnt primary ide. It should be set to primary slave in the BIOS.

Speedy Gonzales
04-03-2005, 09:18 PM
Oops i did an error, 3 posts back that should be primary slave in the BIOS NOT secondary...

tweak'e
04-03-2005, 09:20 PM
unplug your main drive then boot with a dos boot disk and partition/format the drive.

netchicken
04-03-2005, 09:29 PM
OK, I tried the secondary slave, and it didn't work (well it wouldn't would it, but i am getting desperate)

Then i set both drives to auto but still the master came up as C and no way to set the secondary,

Then on resetting them the primary slave automatically picked its own settings - instead of being on auto., well thats a start, it is working,

There must be some place in the registry, or similar where you can set the drive letters. its still greyed out, and I can't change the drive letters on ANY drive.

Tweek don't want to format the drive, just use it as a backup drive and get the data off it.

netchicken
04-03-2005, 10:16 PM
Well I am 90% there....

From here...
http://www.geocities.com/~budallen/98reghak.html

I went into the registry and changed the letter of the new drive..
HKEY_LOCAL_MACHINE\ Enum\ ESDI.

It didn't work,

but under system settings of the drive I set the drive to removable, rebooted, then it gave me the chance to change the letters.

Now however it wants to format the drive to make it usable, ... if I do that I lose its information. ...

netchicken
04-03-2005, 11:20 PM
It will also only format to 8meg.....
I can't format it in dos, as it doesn't have a drive letter, seems to only get it in windows.

Any way of permanantly getting a letter for it?