PDA

View Full Version : TCP/IP issue - very frustrating



nzsp
01-03-2005, 10:44 PM
I have a problem trying to set up my home network. I have two PC's going into my Telecom Nokia ADSL modem/router. Both running XP SP2.

I have set up the network with the XP wizard on both computers. One can see the other computer fine including shared folders (but cannot access the folders). The problem is with the other PC. I think I have traced it back to the network controller. Using the ping command I cannot ping the local computer. According to Microsoft help that means I have to reset the TCP/IP protocol stack. I did that but no luck.

I have no problem accessing the internet through the modem.

I am using the nvidia network controller on my Gigabyte GA-K8NF-9 motherboard, with the latest driver from the Gigabyte website. According to the device manager it is working fine.

I am stumped where to go from here. If I can get the local network controler working I think the network should fall into place. Should I consdider a nerwork card?

Any ideas?

Growly
01-03-2005, 10:47 PM
On the computer that is having problems, do two things:

1) ping localhost
2) ping 127.0.0.1

If either fails, (more importantly if the bottom one fails) you have a hardware issue.

3) Reset CMOS - this usually involves removing the power, removing the onboard battery and switching a jumper for about 10 seconds, then putting the battery back and replacing the power - it should be outlined in your user manual.

This will take care of hardware issues - then you can look at the network setup.

/Edit: If things are playing up, and aren't acting as they should, then definitely consider a network card -they're so cheap it shouldn't matter.

Also, type ipconfig on each PC in Start -> Run -> cmd, and tell us the result :D

nzsp
01-03-2005, 10:56 PM
"ping localhost" works OK
"ping 127.0.0.1" works OK

ipconfig gives:

IP address: 192.168.1.2
Subnet mask: 255.255.255.0
Default gateway: 192.168.1.254


"ping 192.168.1.2" times out

Murray P
01-03-2005, 10:58 PM
Firewall, what are you using, have you allowed the connection on both PC's?

Still no luck, cables ok, ditch the XP networking wizard and set them up manualy via Control Panel > Network Connections > Properties >Network Adapter TCP/IP Properties > (for sharing internet) set the Gateway in both PC's to your routers IP (say 192.168.1.1 or whatever your router is set to), give each PC a it's own IP (say, 192.168.1.2 & 192.168.1.3), subnet in both is 255.255.255.0, put your ISP's DNS numbers in the field provided > Click OK, OK, OK. Now check out the PF1 Networking FAQ on sharing folders and permissions, make sure your firewall is configured to allow the network.

Come back if you have any problems or queries.

Chilling_Silence
01-03-2005, 10:59 PM
What are the settings on the other device?

Firewalls?

nzsp
01-03-2005, 11:02 PM
Further info:

1) XP firewall is off on both PC's

2) on the "OK" computer I have McAfee firewall, but as I can see the whole network from there it should not be getting in the way

3) On the "problem" PC I have Norton firewall configured to have the network in the trusted zone

I will have a try at the manual approach

nzsp
01-03-2005, 11:07 PM
Murray,

Can you confirm where I find the ISP DNS server number

Cheers

Big John
01-03-2005, 11:24 PM
"ping localhost" works OK
"ping 127.0.0.1" works OK

ipconfig gives:

IP address: 192.168.1.2
Subnet mask: 255.255.255.0
Default gateway: 192.168.1.254


"ping 192.168.1.2" times out

Usually indicates that a firewall is preventing communication. Temporarily diasble ALL firewalls and try again. If the PC IP address 192.168.1.2 then you should be able to ping it unless a firewall prevents the ping on the port.
Maybe you are running something else that has closed off IP ports

tweak'e
02-03-2005, 09:20 AM
the other way is to simply don't use tcp/ip for the lan. install ipx/spx, set the frame type type to 802.3 on both and your away (don't forget to turn netbios off for tcp/ip).

nzsp
02-03-2005, 10:39 AM
Big John,

Thanks for that idea - I tried that already but with no luck. I will double check tonight, but that is what led me to thinking it was a network controller issue.

How can I check for other programs other than firewalls that might be closing the ports?

Cheers

Speedy Gonzales
02-03-2005, 10:53 AM
Are you using Norton Internet Security?? The firewall? on the problem PC?

If so, instead of using the trusted zone, click on Personal Firewall / Home networking tab and use the wizard, so it adds an ip and subnet mask under the Home networking tab.

I would also configure the ip's manually not use XP's network wizard.

nzsp
02-03-2005, 03:04 PM
Speedy,

Thanks for the advice. I am using Norton Internet Security on the problem PC and actually had already run the firewall wizard to get the home network into the trusted zone.

I will try to have a go at the manual configuration tonight but I am confused as to why that would resolve the problem of not being able to ping the IP of the local computer. What is the difference between getting an automatic IP and specfying one? If I can see what my automatically generated IP is using ipconfig but cannot ping it, why would this be any different with a manually specified IP?

Trying hard to increase my knowledge level here!

Cheers,
Steve

nzsp
02-03-2005, 09:22 PM
Progress!

It turns out that Norton Internet Security Firewall was the problem after all - thanks big john. By setting the security level of the firewall to low I can now ping my local computer IP and see the network and computers on the network under microsoft windows network.

New problem... if I try to look in the shared folders on the network (even on my local PC) I get the error that:

"computer name\\folder name is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Not enough server storage to process this command"

I have set the folders to share on the network. Any ideas on the way forward from here? The "Shared Documents" folder should always be accessible surely?

Thanks for your ongoing help - much appreciated

EDIT: Problem has miraculously fixed itself through no user intervention. Man, these modern OS's must be good! :D

Thanks again.

nzsp
03-03-2005, 10:17 PM
Ok we're close now.

I can now see the other computer and the shared folders from both PC's. So they are talking to each other OK - I can ping and get replies. However, when I try to access the contents of the shared folders on the other PC I still get the error message from my previous post.

Tried switching off all firewalls - no luck.

Is there something I need to do with the router settings? Is the router or the other PC the server referred to in the error message?

Any ideas? and thanks in advance.

Steve

EDIT. I was just looking in my router (Nokia M1122) settings and under "routing settings" the Dynamic Routing Protocols for ethernet send and receive are off and there are no static routes. This looks like a problem to me! My choices for Dynamic Routing Protocols are RIP Version1, v1-compdat.v2 and RIP version2. What do I need to change to get the router working.

(Its a Telecom rental modem/router so I don't have any documentation and I'm not sure that Telecom support would help me with the routing side of things.)

Growly
03-03-2005, 10:25 PM
I can't find the previous error message you speak of (too tired), so just try this:

Go to cmd, and issue the command:

net use drive: \\ipaddressofotherpc\sharename password /USER:ipaddressofotherpc\username

This maps network drives. So, if you were trying map drive S: to a share called "stuff" on a PC whose IP address was 192.168.0.200, and you were using a user account that was present and enable on the PC you're trying to access called "John", with password "MyPassword123", then you would use, from the PC you're connecting with, the command:

net use s: \\192.168.0.200\stuff MyPassword123 /USER:192.168.0.200\John

That works when browsing doesn't.

nzsp
03-03-2005, 10:28 PM
Thanks for the reply Growly - I found something in my router settings which I think might be it. See the edit to my last post - any advice gratefully received

Murray P
04-03-2005, 12:52 AM
Leave the router, if it was wrong it would not work at all.

Have you allowed user rights on both PC's as Growly indicated? that is, in Control Panel > Users & Passwords, set up a user name and password to access each PC. I just use the same user and P/W for both.

Speedy Gonzales
04-03-2005, 09:43 AM
Speedy,

I will try to have a go at the manual configuration tonight but I am confused as to why that would resolve the problem of not being able to ping the IP of the local computer. What is the difference between getting an automatic IP and specfying one? If I can see what my automatically generated IP is using ipconfig but cannot ping it, why would this be any different with a manually specified IP?

Trying hard to increase my knowledge level here!

Cheers,
Steve


The difference between manually entering in an ip and automatic, is if on auto it has a habit of changing the ip everytime u boot/reboot (if u do).

And the PC with the automatic ip will disappear from the network. (If u use the XP Network Wizard)

If u type the ip address in manually (give it an ip of say 192.168.0.1 etc), it'll stay the same, everytime u reboot the system.

nzsp
04-03-2005, 12:15 PM
Growly/Murray

Thanks for the advice - I will leave the router alone.

On one PC I have usernames for myself and my wife. On the other I have just a user name for myself (same name on both). No passwords are set for usernames on either PC. The files I am trying to share are under my username (the "my Music" folder).

Is there some setting on the username I need to set to allow network access? I thought just allowing the folder to be shared on the network would be enough to have it accessible to other PC's without the other PC needing to know anything about the username/password of the person doing the sharing.

Can I use Growly's command without the password flag?

Cheers,
Steve

Murray P
04-03-2005, 02:25 PM
Set a password for your user and use the username and password to log in to the PC over the network when prompted.

Graham L
04-03-2005, 03:03 PM
For XP, I think you need users registered (identically) on both machines. That means same username and password. "Null" passwords should work (even though they are Bad Things ;)). Just enabling the Guest account on both machines might work.

Speedy Gonzales
04-03-2005, 03:10 PM
Well to solve the username / pw login, just enable simple file sharing. Then u wont have to add this and that and whatever username or password.

Murray P
04-03-2005, 03:48 PM
No need for a password with simple file sharing!! can that be a security risk or am I being a simpleton? sorry couldn't help it :D

Speedy Gonzales
04-03-2005, 03:55 PM
Nope nothing wrong with enabling simple file sharing on any XP PC. It makes it a lot easier to network folders.

Well you're not actually "sharing" the whole hdd are you. Just a folder u created.

It might be a prob if u get something like a worm tho, if u get one. And if u have no software or hardware based firewall.