PDA

View Full Version : Can't setup a dial up connection in XP



chopperman
05-02-2005, 11:24 PM
I have just installed win xp on my win 2000 computer. I have lost my dialups, and if I try to set up a new one manually in the new connection wizard I can't select "connect using a dial-up modem" - it is grayed out.

Everything was working on win2k before.
Any ideas?

Safari
05-02-2005, 11:28 PM
Open Regedit (Start --> Run --> regedit --> ok)
Navigate to HKey_Local_Machine --> System --> CurrentControlSet --> Services --> Rasman --> PPP --> EAP
Left click on EAP there should be 4 keys > 13,4,25,and 26
Delete the keys 25 and 26
Reboot the PC
Try to setup a new connection.

drcspy
05-02-2005, 11:40 PM
Dial-up modem or PPPoE option in New Connection Wizard is unavailable
Applies To
This article was previously published under Q320558
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
If you use the New Connection Wizard to create a new dial-up modem or PPP over Ethernet (PPPoE) connection, you may experience any one or more of the following issues:
The Connect using a dial-up modem option in the New Connection Wizard is unavailable (appears dimmed).
The Connect using a broadband connection that requires a user name and password option in the New Connection Wizard is unavailable.
Therefore, you cannot create a dial-up modem connection or PPPoE connection to the Internet.
CAUSE
This issue may occur if both the following conditions are true:
You upgrade your computer to Microsoft Windows XP from Microsoft Windows 98 Second Edition or Microsoft Windows 98.
One or both of the following entries in the Windows registry are damaged or contain incorrect settings:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Telephony\Cards\NextID

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Telephony
For additional information about other causes for this problem, click the following article number to view the article in the Microsoft Knowledge Base:
329441 You cannot create a network connection after you restore Windows XP
RESOLUTION
Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, use the following methods in the order that they are presented.
Method 1
Delete the NextID value in the registry. To do this, follow these steps:
1. Click Start, and then click Run.
2. In the Open box, type regedit, and then click OK.
3. Locate and click the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Telephony\Cards
4. In the right pane of Registry Editor window, click NextID.
5. On the Edit menu, click Delete.
6. When you are prompted to confirm the deletion, click Yes.
7. On the File menu, click Exit to quit Registry Editor.
8. Restart the computer.
9. Start the New Connection Wizard, and then create a new dial-up modem connection or PPPoE connection.

If you can create a new dial-up modem connection or PPPoE connection, do not go to the next method. If the issue is not resolved, go to Method 2.



Method 2
Delete the Telephony key in the Windows registry, and then perform an in-place upgrade of Windows XP. To do this, follow these steps:
1. Click Start, and then click Run.
2. In the Open box, type regedit, and then click OK.
3. Locate and click the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Telephony
4. On the Edit menu, click Delete.
5. When you are prompted to confirm the deletion, click Yes.
6. On the File menu, click Exit to quit Registry Editor.
7. Perform an in-place upgrade of Windows XP.
REFERENCES
For additional information about how to perform and in-place upgrade of Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
315341 How to perform an in-place upgrade (reinstallation) of Windows XP
For additional information about how to create a dial-up modem connections in Windows XP, click the following article numbers to view the articles in the Microsoft Knowledge Base:
305549 How to configure a connection to the Internet in Windows XP Professional
310410 How to configure and use dial-up connections in Windows XP
For additional information about how to create a PPPoE connection in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
283070 How to create a PPPoE connection in Windows XP

drcspy
05-02-2005, 11:43 PM
MUCH EASIER METHOD By the way this WORKS........

copy and paste the text below into a notepad file and save as dialup.reg then right clik it and clik 'merge' on the menu you have......reboot and voila you'll havwe it all fixed......I've been there and used this and it works well........

Windows Registry Editor Version 5.00

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\RasMan\PPP\EAP\25]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\RasMan\PPP\EAP\26]

ihgsiiugfer
07-05-2005, 09:29 AM
Non Regedit, No Restart Solution - worked for me after I tried everything else

My "Remote Access Connection Manager" service was disabled, and that was causing the problem.

Don't know why I didn't think to try adding a connection by this route sooner, but I went to Internet Options (via contol panel or IE options) and selected connections. I didn't see my configured dialups on the list. I clicked add, and unlike the "new connection" wizard where the option was simply greyed out (dimmed), I actually got an error message. Try this and investigate the error.

In my case, the error said something about the "Remote Access Connection Manager" being unavailable. This is a system service, so I checked it out.

Right click on "My Computer", select manage, and double click on "services". I scrolled down to Remote Access Connection
Manager, and saw that it was disabled. I switched it to manual startup (right click, properties, the "startup type" drop down box) and that was it, problem solved. Everything was back to normal and running as it should.

Note that the other solutions in this thread change/clear settings for this service (rasman = remote access connection manager), but in my case, the service had simply been turned off. Check it out - this is analogous to making sure the light is plugged in before rumaging around for a new bulb.

hope this helps,
me

ninja
07-05-2005, 06:07 PM
Dial-up modem or PPPoE option in New Connection Wizard is unavailable
Applies To
This article was previously published under Q320558 FYI I have never seen this fix the problem.


MUCH EASIER METHOD By the way this WORKS........This however does, though it was already posted at the beginning of the thread.

SnotShooter
06-10-2005, 03:25 AM
I was getting this: "ERROR: Malloc failed for RasEnumDevices" when starting my Global Roaming program which in turn couldn't hook up with the modem.

I, too had tried "everything" else. But this was the solution.
Thanks,

ShotShooter



Non Regedit, No Restart Solution - worked for me after I tried everything else
...
My "Remote Access Connection Manager" service was disabled, and that was causing the problem.
...
Right click on "My Computer", select manage, and double click on "services". I scrolled down to Remote Access Connection
Manager, and saw that it was disabled. I switched it to manual startup (right click, properties, the "startup type" drop down box) and that was it, problem solved. Everything was back to normal and running as it should.
...
me

drcspy
06-10-2005, 06:30 AM
hmn............ninja my second suggestion may very well have been covered in one way at the beginning of the thread but my solution was much easier to use for folks who are not comfortable using the registry............especially when safari simply said 'open regedit.........'..........you would get lots of users saying .............HOW do i do that.......here on the forum you cant assume that people know how to do that stuff.......