PDA

View Full Version : Dual booting FC3 and FreeBSD



johnd
04-02-2005, 11:23 AM
I am helping a friend dual boot a FC3 system with FreeBSD 5. At this stage, he knows more about FreeBSD than I do since he has installed a number of times and has had goes at configuring the system with varying degrees of success.

We have started from scratch with a fresh install of FC3. We have allocated the (Linux) primary partition hda2 for the FreeBSD slice. At first we went with the automatic allocation of FreeBSD partitions inside hda2, then we tried manually partitioning.

In both cases we cannot get past the acceptance of the partitions. We get a message something like: "cannot find /dev/ad0s2b" which is the swap partition. This was not a problem when FreeBSD was installed by itself on the disk.

The basic problem seems to be that the install routine cannot allocate the space given to the swap partition (inside the FreeBSD slice) by the disk partitioning tool.

A peruse of the web did not seem to give any clues.

Any ideas?

johnd
05-02-2005, 08:19 PM
No FreeBSD experts out there?

vinref
05-02-2005, 08:52 PM
... We have allocated the (Linux) primary partition hda2 for the FreeBSD slice. At first we went with the automatic allocation of FreeBSD partitions inside hda2, then we tried manually partitioning.

In both cases we cannot get past the acceptance of the partitions. We get a message something like: "cannot find /dev/ad0s2b" which is the swap partition. This was not a problem when FreeBSD was installed by itself on the disk.

The basic problem seems to be that the install routine cannot allocate the space given to the swap partition (inside the FreeBSD slice) by the disk partitioning tool.

A peruse of the web did not seem to give any clues.

Any ideas?

Are you deleting all the partitions within the FBSD slice before trying to disklabel them again? I have never come across this problem before.

Try using the linux swap space instead of creating another swap space. Swap space is swap space. Saves on disk space too.

johnd
05-02-2005, 09:13 PM
Are you deleting all the partitions within the FBSD slice before trying to disklabel them again? I have never come across this problem before.
It was a partition made during the FC3 install with nothing in it. We changed the partition type from Linux to FreeBSD (forgotten the numbers).



Try using the linux swap space instead of creating another swap space. Swap space is swap space. Saves on disk space too.

Yes - we could try that. I see there is HOWTO on that:
http://www.tldp.org/HOWTO/Linux+FreeBSD-3.html

vinref
05-02-2005, 09:50 PM
It was a partition made during the FC3 install with nothing in it. We changed the partition type from Linux to FreeBSD (forgotten the numbers).

Did you re-label the slice as UFS using the FBSD tool, or did you do this using the Linux tool. Somethings never go right when you use a tool from another system.

johnd
05-02-2005, 10:21 PM
Did you re-label the slice as UFS using the FBSD tool, or did you do this using the Linux tool. Somethings never go right when you use a tool from another system.

We did it as part of the FBSD install.

Caesius
05-02-2005, 10:21 PM
How are the slices set up within the FreeBSD partition?

johnd
05-02-2005, 10:27 PM
How are the slices set up within the FreeBSD partition?

Isn't it the other way around. You have a slice (which is a partition to us in the DOS/Linux world). The slice is divided up into partitions (in much the same way as you make an extended partition and logical drives).

YOu can choose the default partitions offered by the install or delete them and make your own - we tried both but it will not make the swap partition.

Caesius
05-02-2005, 10:42 PM
Yes sorry, my mistake, other way around.

What about installing FreeBSD first?

johnd
06-02-2005, 09:43 PM
Yes sorry, my mistake, other way around.

What about installing FreeBSD first?

I expect that option would work! But quite a lot of setup has been done in Linux and my friend probalby doesn't want to start again. We will probably try sharing the swap partition.

Thanks