PDA

View Full Version : Similies and Hyperlinks in PF1



Prescott
05-01-2005, 01:32 PM
hey there,
when ever i want to use a smilie, i click on the one i want, then my page automaticly scrolls to the top and it doesnt insert the smilie, it does the same thing when entering a hyperlink,
im using winxp sp1 and firefox,
anyone have any ideas becuase it is getting really annoying........

godfather
05-01-2005, 01:44 PM
To which the obvious solution is, use IE?

Prescott
05-01-2005, 06:10 PM
but it has worked before

Mike
05-01-2005, 06:21 PM
anyone have any ideas becuase it is getting really annoying........
Type it in instead of clicking on the picture.

Mike.

MMM
05-01-2005, 06:34 PM
hey there,
when ever i want to use a smilie, i click on the one i want, then my page automaticly scrolls to the top and it doesnt insert the smilie, it does the same thing when entering a hyperlink,
im using winxp sp1 and firefox,
anyone have any ideas becuase it is getting really annoying........
Same thing has happened to me using Avant Browser, so it's not a FF issue.
I am on WinXP SP1 too.

I solve it by going out of the browser completely and then going back in. I didn't have to disconnect from the ISP though. Maybe it's something to do with the cache.

Cicero
05-01-2005, 06:51 PM
:thumbs:
To which the obvious solution is, use IE?
:thumbs: Very droll.

Mary
10-01-2005, 08:12 AM
Not true, the smilies work fine in firefox - I myself use firefox and haven't had any issues.
Strange that restarting the browser fixes it.

Edward
10-01-2005, 08:48 AM
It happens on and off for me. It's a painin the bum having to load a new page which takes forever (Bittorrent taking up nearly all of the little bandwidth :annoyed:), and find it's code, go back and put it in when it's staring me in the face in the "Insert smiley" box _

Prescott
10-01-2005, 09:11 AM
mine is still not going..... oh well i might just have to enter them manually

Prescott
01-04-2005, 07:16 PM
sorry to bring this up but im getting a tad annoyed :(
after upgrading FireFox to the latest version i am still having this problem, this time it does it everytime i click on a smilie face or any other features when making a post. it used to work but now it doesnt......

Graham L
01-04-2005, 07:24 PM
Hyperlinks give me no trouble and similies work like a dream. :cool:

But what do I have to do to make metaphors work? :badpc:

Winston001
01-04-2005, 09:02 PM
Hyperlinks give me no trouble and similies work like a dream. :cool:

But what do I have to do to make metaphors work? :badpc:

Bum. Too quick for me Graham. :lol:

Prescott
01-04-2005, 09:38 PM
yes i see the mistake haha, im laughing so much, geez you guys understood a few months ago....... :rolleyes:

now getting back to the orginal topic of smiley's and hyperlinks not working in pressf1. i have upgraded FF and it still doesnt work, it used to but now it doesnt, i cant seem to find a fix. now does anyone have a solution.

no one is the perfect spelling machine, we are only human :groan:

beetle
01-04-2005, 09:51 PM
Prescott i also have this problem and have found nothing that makes it work at all.
so cut and paste or if known smilie type it in...frustrating.

if you find a fix let me know id like to fix my FF too.

b

Prescott
01-04-2005, 09:53 PM
yup, its been months of cutting and pasting, i have actually never experienced the new fourm with its new replying features...... im a tad sick of it actually.

Graham L
02-04-2005, 03:13 PM
But no one picked up my failure to correct the spelling. :p I was concentrating on getting the wording right, so I was on my way home when I thought: "Oops, similes". :(

Mary
02-04-2005, 03:24 PM
Hey Prescott,
I've just tried replicating the problem myself in FF.
I did get the problem, but all I did was click in the message field and then try a smilie again and it worked.
There is an error that comes up in my js console when it happens -- its because it can't find the target field to insert the smilie.
Next time it happens scroll back down and see if clicking in the message field first helps.

FoxyMX
02-04-2005, 03:32 PM
Out of interest, Mary, have you done any tweaking to the emoticons since the new forum began?

When the new forum first came online the smilies were always inserted at the end of a message paragraph when clicked on whereas now they appear where they should, where the cursor is.

I'm just wondering whether you changed something or whether my upgrade to Opera Beta 8 had something to do with it.

Prescott
02-04-2005, 06:44 PM
look at this!!!its actually working now i can even put a link in (http://www.google.com) this is amazing i can press the formating buttons and it now works, i havent even touched any settings, now to try those smilies :) :rolleyes: :thumbs: wow, wicked

when it didnt work the page just scrolled to the top and do nothing, but now it works,
thanks for the help guys, hopefully it wont go back to its usuall habits. just wondering is this some sort of bug in vB?

Biggles
02-04-2005, 06:59 PM
No, it is just the mysterious power of rhubarb.

Prescott
02-04-2005, 07:05 PM
now it doesnt work, what the hang is going on?
i went to the JS console and it gave me this


Error: vbmenu_register is not defined
Source File: http://pressf1.pcworld.co.nz/search.php?searchid=58242
Line: 527


Mary, i tried what you suggested and it doesnt work :(

Graham L
03-04-2005, 02:26 PM
Don't you know all the smilies by now, Prescott? Just type then in. Real programmers don't use mouses. :cool: ;) :thumbs:

Myth
03-04-2005, 03:00 PM
I know occassionally I have problems with Firefox with some sites (including the reply feature in PC World). When that happens I just empty the cache, and then it works sweet again.

One thing I have noticed with Firefox (haven't tried it in I.E. ... try not to waste my time with sinking ships:p) is that I can't copy or paste using right click. I end up using shortcut keys (Ctrl+v to paste etc).

Prescott
03-04-2005, 05:14 PM
yeah i know most of them but i cant be stuffed typing out the whole command you could say for posting a link,

i wonder if it is just my username?

Mary
04-04-2005, 08:56 AM
Prescott: it won't be anything to do with your username, it will be something to do with the browser. Each browser handles differently (just to keep us developers on our toes).
I will look into it further, but the error your getting is caused by not being able to find the field to insert the smilie to. You need to make sure you select the field first i.e. click the field and make sure the cursor starts blinking.

FoxyMX: possible the change was in a recent upgrade applied to VB.

:thumbs:

Mary
04-04-2005, 09:01 AM
just out of interest which message editor are you using?? do you have a drop down menu for the smileys, or a click menu?


(http://pressf1.pcworld.co.nz/images/smilies/@@.gif)

Prescott
04-04-2005, 03:45 PM
the menu on the side, so im guessing its the click menu?

Graham L
04-04-2005, 03:57 PM
Prescott (http://pressf1.pcworld.co.nz/images/smilies/badpc.gif) :confused:

Seems all right.:cool:

Prescott
04-04-2005, 04:05 PM
hhhmm, well im at school using IE and it seems to work, but once i get home and start to use firefox i get "the problem" but when i use IE it works perfectly. could it be somesort of setting? is a extension avaliable?

Prescott
04-04-2005, 04:06 PM
oh and im not going to use IE as my main browser, no way :o

Mary
04-04-2005, 04:39 PM
oh and im not going to use IE as my main browser, no way :o

I'm not suggesting that - I myself am using firefox with no problems.

There don't seem to be any fixes on the vBulletin forum either, it just seems to be a variation in how the javascript works across browsers.
My only suggestion is that you check that the message window is active before using smilies.

Ahhh, I just had the problem myself now: I just scrolled back down, clicked in the message field, and inserted a smilie - worked fine. :@@:

Prescott
04-04-2005, 06:00 PM
just checking here, how do i know it is active? that just means that my cursor is in the reply box?

when i scroll back down and then click in the message box, it still doesnt work, seems that i might just have to deal with it :rolleyes: (yeah i know that command for it :p)

beetle
04-04-2005, 06:40 PM
LOL

so no smilies for us sweeties..... :eek:

buts its working again?

:confused:

beetle

Prescott
04-04-2005, 07:16 PM
nope, not in firefox, but in IE it does.

meh ill just deal with it...... until a fix comes out or something that will make it work.

FoxyMX
04-04-2005, 09:09 PM
nope, not in firefox, but in IE it does.

meh ill just deal with it...... until a fix comes out or something that will make it work.
Well you could always use Op... oops!! :xmouth:

Prescott
04-04-2005, 09:37 PM
its tempting, but im enjoying the firefox era at the moment.....

Mary
05-04-2005, 12:35 AM
well i'm stumped. :@@:
I can't replicate the problem in my firefox, except very randomly and when the browser hasn't completely loaded (which is normal).
is anyone else having this problem??

Prescott check that you definately have javascript and java turned on and see the "advanced" button beside these settings also (my browser has the first 3 and last 1 checked).
I note that the error you posted above mentioned the search form, which I definately can't replicate. What were you doing when you received this error?
You say that it "was working" when was this? Was this with a "clean" version of firefox? Perhaps its one of your extensions??

There is an update available for vB but it will have to wait till we have the time to install it. And I'm not sure it will fix the problem anyway...
Sorry I can't offer an answer ..

Just thought of a potential work around - do the smilies work if you use the "More" menu instead of the righthand "quick bar"??

Metla
05-04-2005, 12:49 AM
is anyone else having this problem??


I had it for a short time, doesn't do it now, and I have upgraded firefox twice since then,tweaked numerous setiings,and installed,uninstalled numerous apps.......So no chance of tracking down when the issue went away.... :groan:

Prescott
18-04-2005, 09:13 PM
hhhmmm, after a clean install of xp and an installation of SP2 it seems to work now...... wicked :) :rolleyes: :D