PDA

View Full Version : Changing Defualt Browser in Mandrake Linux



dwnz2003
10-12-2004, 09:52 PM
Hey,
I have Mandrake Linux 9.2, and have downloaded FireFox 1. How do i make it my defualt browser? because the one that is, is reaaaaaaaallllllllllllllllllllllllllly bad (its not konquer, its something else)

Cheers
Daniel

Caesius
10-12-2004, 10:58 PM
You may have to change the file associations or maybe Mandrake has a nice little control box to do this all for you.

This question screams out to be RTFM'd; you're lucky that this forum is so nice.

personthingy
11-12-2004, 07:56 AM
I'm curious because i'm running mandrake10, and the default browser is konqueror. Just what is the default browse in 9.2?

In manndrake 10, if you wish to choose the graphical approach, file associations can be done through konqueror itself.

Settings > Configure konqueror
.... a pop up window opens, and one can clearly navigate to file associations

You can also get to the same, or atleast a very similar menu, thus:
system > Configuration > KDE > components > file associations

These associations only effect the user who makes the changes

:-)
Chris

personthingy
11-12-2004, 08:10 AM
Heres the KDE menu way:
http://www.millerton.co.nz/images/pics/file-ass-menu.png

and heres the konqueror way
http://www.millerton.co.nz/images/pics/konq-menu.png

please excuse my messy desktop
:-)
Chris

dwnz2003
11-12-2004, 09:55 AM
9.2 comes with the defualt as Konqueror, but i find it slow to open, so i use firefox. But when i open things out of emails ect, it loads Galeon (Which i hate.) I will have alook at those pics now.

Daniel

dwnz2003
11-12-2004, 10:09 AM
Ok, i made it so that it opens html files in Firefox, but i need it for everything. Mabye its because i use evolution mail, could that have anything to do with it?

Daniel

personthingy
11-12-2004, 10:37 AM
I think its unlikely that using evolution as your email client is going to be a problem in itself.
Unfortunatly im not 100% sure what the problem is even though you say "but i need it for everything".
if you have associated .html with firefox, then unless specified by another action, any *.html file should open in firefox. You may need to associate other file types such as .htm, .php and so forth. Perhaps also image files such as .jpg

Computers of course have a habit of doing exactly as we tell them (nomatter how silly the instructions turn out to be) which is why a *.png filelink i was sent via a IM program last night was proudly opened in the GIMP, which then attempted to upload the changes when the GIMP was finally closed

personthingy
11-12-2004, 10:45 AM
:8}

big oops......
i just tried evolution out, and decided to check the my weather link offered in the summary, and much to my horror, the link was opened with a Epiphany...

:-)
Chris

personthingy
11-12-2004, 11:32 AM
OK, finally.. got it right...

Its a similar deal, but best done in gnome

From the apps menu system > configuration > gnome > Gnome control center > preferred applications.

This is where you change what will be opened by evolution and other gnomish applications.

i took some pretty pictures... will have them up in 5

:-)
Chris

personthingy
11-12-2004, 11:47 AM
In gnome go here:
http://millerton.co.nz/images/pics/gnome-menu.png

which will let you get here:
http://www.millerton.co.nz/images/pics/file-ass-gnome.png

This will let you make the changes you need

:-)
Chris

dwnz2003
11-12-2004, 05:43 PM
Thanks for that, but i use KDE. Would changing it in GNOME fix it up in KDE?

Cheers
Daniel

personthingy
11-12-2004, 06:10 PM
I use KDE too, and was surprised to find that indeed the gnomey preferences seemed to be what effected this programs behaviour, even within the KDE enviroment.

It just works that way, i know not why.

:-)
Chris

dwnz2003
11-12-2004, 06:15 PM
Ok, i went into GNOME and changed things that opened up in Galeon, but it doesnt fix the problem. I need it so that if i open a link from a email in evolution that it opens in FireFox. So far no luck :(

Daniel

personthingy
11-12-2004, 06:35 PM
http://millerton.co.nz/images/pics/file-ass-gnome.png

is this the bit that you changed?
this *should* cause links within evolution to open the browser of choice, however if firefox isn't in the list, then you may have to go to the lower panel and place a value (at a guess it is) /usr/bin/mozilla %s.
It will be very similar to the command used to start firefox, have a look at the property's of any desktop icons you may have for it to see what it might be. I'm guessing that the %s part makes it upon what the link specifies.

At this point, because i'm starting to guess, i can offer no further advice. Hopefully someone else can help if you cant get it going from that.

:-(
Chris

dwnz2003
11-12-2004, 06:42 PM
Yea i think thats the way, but when i goto that part it comes up with a big window with lots of options (memba im running 9.2). Ill try again.

Daniel