PDA

View Full Version : Fedora core 2 sound problem, video question



Nigel Thomson
26-09-2004, 06:23 PM
Ok my problem is not that the sound isn't working,
it is infact working, but only on one speaker,
and yes i have tried different speaker, headphones etc

When i reinstalled FC2 (after an embarrasing deletion of my linux partition)I did the sound test and it worked fine, I heard the sound in the left speaker then the right then both (middle), I have a feeling that the problem may have occured after my last yum update as it gave me a new kernel.

So when I put my music on today there was no sound coming out at all but everything seemed to be working (no errror messages etc), after checking everything i could think of I went
redhat Start thingie >> SystemTools>> soundcard detection
it detected my soundcard and played test sounds, but they all seemed to play in the left speaker

I can find articles on no sound but none on half? sound

the other thing I have noticed it when i go to
redhat Start thingie >> Sound and Video>> volume control

there are two tabs (I can't remember if there were two last time, it worked so i didn't bother checking)
one tab saying
realtek alc650 rev2 [oss mixer]

and the other saying

nvidia nforce2 [alsa mixer]

on to the video problem,

do the nvidia drivers ship with fedora, i vaguely remember having to download something from nvidia last time I had a linux install, and I haven't seen the nvidia splash screen when booting into X, this time

Thanks Nigel

Nigel Thomson
26-09-2004, 06:23 PM
Soory should have said it was an nforce2 motherboard

Jen C
26-09-2004, 07:23 PM
> So when I put my music on today there was no sound
> coming out at all but everything seemed to be working
> (no errror messages etc), after checking everything i
> could think of I went
> redhat Start thingie >> SystemTools>> soundcard
> detection
> it detected my soundcard and played test sounds, but
> they all seemed to play in the left speaker

Try this. Open up a konsole window and "su -" to root. Then enter in aumix. Use the up/down arrows to move between lines, and the left/right arrow to change the setting. Use the tab key to active the L R Balance section. You will see a key on the left for how to Save, Quit etc. Do this as root first, and if that doesn't make a different, try it again as user instead.

> the other thing I have noticed it when i go to
> redhat Start thingie >> Sound and Video>> volume > control
> there are two tabs (I can't remember if there were
> two last time, it worked so i didn't bother
> checking) one tab saying
> realtek alc650 rev2 [oss mixer]
> and the other saying nvidia nforce2 [alsa mixer]

Hmm ... I have two tabs as well.

> on to the video problem,
>
> do the nvidia drivers ship with fedora, i vaguely
> remember having to download something from nvidia
> last time I had a linux install, and I haven't seen
> the nvidia splash screen when booting into X, this
> time

Fedora does not ship with official nVidia drivers. You will need to download the latest nVidia drivers and install them. I am still trying to finish off a FAQ on how to install the nVidia driver, but the readme is straight forward. One important thing to remember, is that whenever you upgrade a kernel, you will need to reinstall the nVidia driver afterwards before loading X again.


Did you previously install the nForce drivers from nVidia? If you did, and then you updated the kernel, you need to reinstall the nForce driver again because it was compiled against the previous kernel. To test this out, you should still have your old kernel listed in Grub bootmanager. Boot into the old kernel and see if your sound works OK there. This is probably what is behind your current sound issue if you did have them previously installed.

Linux nForce Driver - IA32 (http://www.nvidia.com/object/linux_nforce_1.0-0283.html)

Linux Display Driver - IA32 (http://www.nvidia.com/object/linux_display_ia32_1.0-6111.html)

Wood-Chuck
26-09-2004, 08:38 PM
Depending what kernel you have and how it was setup might answer your sound problem.
In later kernels OSS (Opensource Sound System ?:| I think) is depreciated in favor of Alsa (Advanced Linux Sound Architecture), so if you're still using OSS that might explain the problem.

The easiest way to get over to alsa is:
Get to your favorite terminal (xterm, gnome-terminal, konsole, whatever you want to call it)
su -
"alsaconf" (no quote marks)
Let it do its thing and see if it can pickup your soundcard.
Add the entry to modprobe (this is an option)
"alsamixer" (no quote marks either) and just sort out the mixer
exit

Then go into xmms/gaim/etc and change the default audio codec to Alsa or Automatic depending on what options are available. The one problem with this is things like the Macromedia plugin for linux still require OSS to be around and working so you may end up without sound in shockwave applications.

As for nvidia drivers - I don't use Fedora so I can't answer that question. However:
1 - Download:
Grab the latest drivers from Nvidia linux (http://www.nvidia.com/object/linux.html). Unless you have a 64bit computer you want the IA32 drivers.

2 - Killing X:
Switch to runlevel 3 (either edit /etc/inittab or run "telinit 3" from a terminal - you have to be root to do either one of these)

3 - Installation:
as root "sh [nvidia drivers].run" (no quote marks) and follow the onscreen instructions
Once this is done, it will give you a file to read with regards to changing your xorg.conf file. All that is required is enabling glx and changing the graphics driver over from "vesa" to "nv"

To switch back to runlevel 5 you can run "telinit 5" or if you edited /etc/inittab before you will have to edit it again (use nano/vi/vim) and change it back.

Nigel Thomson
26-09-2004, 08:47 PM
Cool thanks guys

I'll try these sugestions over the next few days.