PDA

View Full Version : Firefox extremely slow going back a page



alphazulusixeightniner
17-09-2004, 01:32 AM
1) Hi, I've been using Firefox for a while now and have noticed that when you click the 'back' button to go back a page it is extremely slow loading, it's almost reloading the entire page again instead of from the cache, where it should be.

I compared it to Opera which does an instant backtrack rather than waiting 5seconds or longer to go back to the page it was previously on. Pretty annoying if you ask me, slows your surfing down by a lot.

Any way to get it going super fast like Opera? I prefer Firefox over Opera for the way the bookmarks are managed. It's almost a nightmare trying to get order out of Opera.

2) Is there some way you can import your Firefox bookmarks into Opera if a solution to the above can't be found?

Thanks :)

Chilling_Silence
17-09-2004, 01:35 AM
AFAIK there's a setting somewhere.... In the address bar type:
about:config

Have a look in there


Chill.

Jester
17-09-2004, 10:18 AM
I think that pressing the backspace button on your keyboard works.

J
:D

Jen C
17-09-2004, 10:38 AM
It must be one of your cache settings. Like Chill suggested, enter in about:config into the address bar, and then under "Filter" enter in cache. Compare your settings to the default ones listed here (http://www.mozilla.org/quality/networking/docs/netprefs.html) - scroll down to the Cache section.

Let us know if that makes a difference.

alphazulusixeightniner
17-09-2004, 02:43 PM
I tried looking for filter or cache. I can find some cache options like setting the size of it etc, but I can't find anything with 'filter'.

Do you reckon you could screenshot what you are meaning? Thanks :)

Jen C
17-09-2004, 06:07 PM
> Do you reckon you could screenshot what you are
> meaning? Thanks :)

about:config screenshot (http://sal.neoburn.net/imagef1/files/aboutconfig.jpg) :)

metla
17-09-2004, 10:15 PM
What would that skin be called Jen C?

alphazulusixeightniner
17-09-2004, 10:23 PM
It's similair to the Noia 2.0 (eXtreme) theme that I use with a different font along the top?

I didn't notice the filter input text bar till I saw the screenshot :)

My about config is the same settings as yours Jen? Except for some different things along the line:

ISO-8859-1, UTF-8, windows-1251, UTF-16LE, windows-1252

That's mine, otherwise I don't know? Does yours go back a page really fast for you?

Jen C
17-09-2004, 10:23 PM
That skin is Noia 2.0 (eXtreme) (http://update.mozilla.org/themes/moreinfo.php?id=72&vid=652).

Jen C
17-09-2004, 10:28 PM
> It's similair to the Noia 2.0 (eXtreme) theme that I
> use with a different font along the top?

Ah, I run Linux so I use the Linux version of Firefox. My font along the top title bar is part of my KDE I have customised. :)

> My about config is the same settings as yours Jen?
> Except for some different things along the line:
>
> ISO-8859-1, UTF-8, windows-1251, UTF-16LE,
> windows-1252

Mine is probably different because it is Linux and not Windows.

> That's mine, otherwise I don't know? Does yours go
> back a page really fast for you?

Yeah, mine reloads the page in an instant from the cache.

I wonder what else could be causing this problem for you then?

metla
17-09-2004, 10:33 PM
Thank You Jen,This skin is the ace.

Susan B
18-09-2004, 09:52 AM
Hmm... my theme has been Noia Lite since using Firefox so just decided to try the Extreme version. Looks quite pretty with the extra icons in the menus, otherwise it is much the same.

alphazulusixeightniner
18-09-2004, 03:46 PM
"I wonder what else could be causing this problem for you then?"

Yeah, me too. I might try posting at the mozilla forums if no-one else has any more ideas?

Thanks for your efforts so far. :)

Jen C
18-09-2004, 05:25 PM
> Yeah, me too. I might try posting at the mozilla
> forums if no-one else has any more ideas?

I would try to uninstall and then reinstall Firefox first. Do it cleanly and also remove your profile folder. Don't forget to backup your bookmarks.html somewhere safe first. The easiest way of doing this is to go Bookmarks > Manage Bookmarks > File > Export. Save them to your desktop. Take note of what Themes and Extensions you have installed as you will need to re-download these again.

Go via Add/Remove and uninstall Firefox. Not sure if it asks you whether you want to uninstall your profile folder as well, but say yes if is does. Otherwise you need to do this manually. Make sure Explorer is set to display hidden files and that Firefox is closed. Now go to C:\Documents and Settings\{username}\Application Data\Mozilla\Firefox and delete the Firefox folder.

Now reinstall Firefox again. You will need to download any Extensions and Themes you had previously which is probably a good idea just in case one of these was behind your problem as you will get the latest version of them. You can re-import your bookmarks.html via Manage Bookmarks. This surely must fix your problem :)

Jen C
18-09-2004, 05:29 PM
> Make sure
> Explorer is set to display hidden files and that
> Firefox is closed.

Never a good idea to proof read your posts after hitting Post Message. Of couse Firefox will be closed, as it is already uninstalled from the previous step :p

need coffee ...

alphazulusixeightniner
18-09-2004, 05:58 PM
Lol, I'll give it a go after dinner. I normally copy the whole profile over when I reinstall my OS, so it's about 4 generations old probably. :)

alphazulusixeightniner
19-09-2004, 02:26 PM
Yep, thanks Jen that worked marvellously :) Fast back button in action!!

I deleted the profile folder completely after backing up the bookmarks, and deleted the Mozilla Firefox programs folder, then went with a fresh install of Firefox 1.0PR and everything is working great.

Thanks for the help :)