PDA

View Full Version : The handle is invalid, RPC crashes, all on a 2 day old install (2K adv srv)



george12
30-08-2004, 08:02 PM
Hi, I am having a lot of strife with my two-day-old installation of Windows 2000 Advanced Server Evaluation (120-day) with SP4.

It's on one of my 2 new servers, both identical 333Mhz Celeron w/64MB RAM and a 3GB Western Digital HDD. I installed windows fresh on this computer, and then duplicated the hard drive for the other one (and changed the MAC address, ip address, name etc to make it do what I wanted).

My problem is that with the first one, I am having no end of problems. RPC has crashed twice, using 100% cpu and causing clients on the internet to get:

The handle is invalid.

...when they try to goto a site hosted on the server. I know it worked before RPC crashed because I have had people go to it.

I rebooted which fixed RPC, but just now the error is back. ?:|

What do I do? Note that I had no problems before SP4 but then I only ran it without SP4 for about a day.

Try it yourself, try these addresses:

http://local.jgih.com (JG Industries e-shop)
http://local.thestagegame.com (The Stage Game)
http://222.152.55.106 (Default site when no host headers - basicly empty)

My IP address is of course static, so the third one won't change.

The hosted versions of these sites are available by replacing the 'local' with 'www'.

Thanks in advance, George

george12
30-08-2004, 08:06 PM
Curiously the Stage Game site has never failed. But I can confirm that there is nothing wrong with either of the other to (like a scripting error). But there could be something in that the shop (first in list) is ASP, and the intranet (3rd in list) is ASP, but the working Stage Game site is plain old html.

Also, I forgot, when I try to administrate IIS it says 'JG-SRV2 - Access is denied' even though it IS that computer. Arg

George

stu120404
30-08-2004, 11:56 PM
** bump **

george12
31-08-2004, 10:04 PM
Please, I really would like an answer more helpfulk than 'bump'.