PDA

View Full Version : No Mouse in Linux



heaton
27-07-2004, 03:28 PM
Been given Linux Redhat9 and have loaded it into my second computer. Everything seems to work except the mouse which the programme will just not recognise. Tried all different mouse configurations but no joy. Anybody else had this problem and can suggest what might be wrong ?
The mouse works perfectly in other programmes.
Cheers.......heaton

Chilling_Silence
27-07-2004, 03:40 PM
Try this:
Login as root
Open up a text editor of your choice (Its been a while since I used Redhat 9, almost a year to be honest) and then open the file:
/etc/X11/XF86Config

Scroll down until you find:
Section "Pointer"

Now, mine says:

Section "Pointer"
Protocol "PS/2"
Device "/dev/psaux"
Emulate3Buttons
Emulate3Timeout 70
EndSection

You may want to try two things:
Changing between:
Device "/dev/psaux"
and/or:
Device "/dev/mouse"

As well as:
Protocol "PS/2"
and/or:
Protocol "IMPS/2"

Im sure there's an easier way in Fedora Core 1/2 to do this.. IIRC you run redhat-config-xfree but I dont believe that was part of Redhat9.

Might pay to get a newer distro to be honest, things are more likely to "just work" ;-)


Chill.

heaton
27-07-2004, 05:20 PM
Thanks Chill but I am afraid your help is somewhat meaningless due to my complete ignorance of Linux. When I get to the stage where it says LOGIN, I type ROOT. It asks for my root password and then it goes to a panel and asks for my username. Having typed all that in I get to a screen with three icons
HOME , START HERE and TRASH. Using the arrow left and right buttons I highlight the HOME icon and I get a screen with a menu along the top and some icons along the bottom of the screen. Now without the mouse I am helpless to start anything. I can't even shut the screen down and have to pull the big switch. If I go into START HERE I get a screen with three icons APPLICATIONS, PREFERENCES and SYSTEM SETTINGS.
Going into PREFERENCES by using the arrow keys I get into a lot of icons and there is one there labelled MOUSE. This tells me how to configure my mouse settings but I cannot navigate the screen settings without a mouse.
Please don't go to any trouble with this. One day I might find a solution but I realise now that Linux is an entirely new country and I have no maps or compass to tell me where I am going. I am not overly concerned as this is my number two computer and putting in linux is in the nature of an experiment. Cheers.......heaton

Graham L
27-07-2004, 05:24 PM
Mice have "just worked" in most linux releases. Even without a GUI. :D

What sort of mouse is it? Is it a USB one? There might be problems with that, but most recent distribuition kernels have been compiled with the "Human Interface Devices" USB modules compiled. (I've had trouble trying to stop Mandrake 9.2 from having the HID stuff when I don't want it. :D).

From a terminal, do dmesg | grep mouse to see if a mouse has been detected while booting.

Chilling_Silence
27-07-2004, 05:27 PM
Graham's right - They _just_ work.

To be honest - try Fedora Core 1 or 2, or Xandros Desktop OS 2.01

Graham L
27-07-2004, 05:37 PM
BTW, when you have problems in a Linux GUI the magic keys are Ctrl/Alt/Backspace. That combination will kill the X Window server. (The command startx will start it again). The traditional Ctrl/Alt/Del will usually do the slightly more drastic step of shutting down everything (in a reasonably orderly fashion) then rebooting.

There's nothing wrong with RH9. :D I have always felt that there are always less extreme fixes for minor setup problems than changing OS versions. ;-)

Jen C
27-07-2004, 05:46 PM
Have you tried rebooting? I had one distro (SuSE 8.0) which wouldn't detect my mouse first time around, a reboot located it.

To get a terminal window open without a mouse, just go ALT-F2 and enter in xterm. Also try ALT-F2 and enter in redhat-config-mouse and see if your mouse is correctly identified.

Graham L
27-07-2004, 05:51 PM
IF you have booted to the GUI you need to do Ctrl/Alt/F2 rather than Alt/F2 to get another session. :D To get back to the GUI, Ctrl/Alt/F7 does it. The Alt/Fx works when there isn't an X Window server running.

Jen C
27-07-2004, 05:55 PM
> IF you have booted to the GUI you need to do Ctrl/Alt/F2 rather than Alt/F2 to get another session

Umm ... I just meant to use ALT-F2 to get the Run Command dialog box, not to start a new session.

JohnD
27-07-2004, 11:53 PM
I suggest starting a shell window and type "su -" (without the speech marks) and put in the root password. Then type setup and scroll down to mouse configuration. Try some options - one must work!