PDA

View Full Version : Weird Network Problem.



Kenshin
30-06-2004, 08:23 PM
Hi, I have 2 computers networked using 2 802.11b PCI wireless LAN card. Both machines runs windows XP professional and the are connected in a adhoc configuration.

For some reason, when I first boot up the computers the network would be connected ("shown by the little tray icon") for like a minute or less and then disconnect ..... and i have to go to my server computer and disable the network and then re-enable it to get it to work again..... also the internet connection sharing needs to be disabled and re-enabled as well before that starts working! Once that is done the network will work, until you restart the server computer....

Any help would be appreciated : )

TCP//IP is used to network the 2 computers:
server:
IP:
192.168.0.1
255.255.255.0

===================================
client:
IP:192.168.0.2
255.255.255.0

Gateway:
192.168.0.1

DNS server:
192.168.0.1

Murray P
30-06-2004, 08:56 PM
I take it your server and gateway are one and the same machine and you are using MS ICS to share the internet connection with the client (ie, the PC with the internet connection)? By DNS server do you mean a local domain?

Cheers Murray P

Berryb
30-06-2004, 09:40 PM
More likely to be the wireless configuration utility. What are you using, the XP one or the one that came with the cards?

Kenshin
01-07-2004, 12:20 AM
I am using the wireless configuration utility that came with the card.

by DNS I mean the one inside the TCP//IP advance settings where u get to specify ur ip address and DNS.

...Berryb I think u mit be onto something tho ....cos I have a strange feeling that it may be the utility as well....

John H
01-07-2004, 12:22 PM
I am not sure whether this will solve your problem or not, but I have had some months of trying to solve a problem where my WLAN would connect at boot, then after a few minutes lose the connection, and then if would automatically re-connect after a while, or I had to take all sorts of different actions to get it to re-connect.

No-one on PressF1 was able to solve the problem despite lots of helpful comments about the possibility of interference from microwaves, 2.4 Gb phones, conflicting devices being used in the neighbourhood etc etc. The main solution suggested was to try using different channels to see if that would work. Nothing worked and I had decided to live with it until I could lay a cable from my outside office (where the Wireless Network Access Point lives) and the house (family computer).

As a last resort I had another go at solving it, and found two sites that pointed me in the right direction to solve my problem. My WLAN is now completely stable for the first time in months, but I don't know if this will help you...

The first site was Linksys (http://linksys.custhelp.com/cgi-bin/linksys.cfg/php/enduser/std_adp.php?p_faqid=696&p_created=1084219779&p_sid=iECvjefh&p_lva=&p_sp=cF9zcmNoPSZwX3NvcnRfYnk9JnBfZ3JpZHNvcnQ9JnBfc m93X2NudD02NzImcF9wYWdlPTE*&p_li=)

In itself this site did not help, but it got me on to thinking about the setting under Authentication: Enable IEEE802.1X authentication for this network. This was checked on the main desktop with the WAP and on the two laptops that connected to the WLAN.

The Linksys document directs you to Microsoft 828940 (http://support.microsoft.com/default.aspx?scid=kb;en-us;828940)

That page says:
"CAUSE
This problem occurs because the wireless access point receives a connection request while the access point is trying to re-authenticate the wireless client for the same wireless network card. This later reconnection request is interpreted as a network attack on the access point. When this event occurs, the access point rejects the connection from the wireless client."

I decided to experiment with my settings, and I have now checked "Enable IEEE802.1X authentication for this network" on the main desktop, and unchecked it on both of the two laptops. This is the only change I made, and the network now stays completely stable. I also tried it unchecked on one laptop, and checked on the other one whilst it was sitting within 2m of the WAP. The one that was unchecked stayed stable, whilst the one that was checked kept dropping the connection. So they are now both unchecked and both stable.

I don't know if this means that the two laptops (and hence the whole WLAN) are now insecure to drive-by Net Stumblers, but it does mean that family members using the laptops have stopped throwing wobblies because they lost the network in the midst of downloads or whilst they were entering data in remote workplace databases. Family life is much more peaceful and the laptops are in less danger of infuriated fist pounding. I too am less under attack for being an incompetent husband or father who is supposed to know better, hunt and gather, and provide expensive bombproof computer technology.

Life is good once again, and it is worth the trade off of some potential lack of security. Who would be interested in my digital crud anyway???

If you want to try this work around and don't know where to find "Enable IEEE802.1X authentication for this network" then post again! This post is long enough already...

John

Murray P
01-07-2004, 01:17 PM
Hi John

Did you apply the XP Hotfix from MS or, as you have tweaked it yourself you have decided to leave well enough alone?

If the latter, maybe the Hotfix will not have negative affects re security, then again who knows with an MS patch what the implications are down the line. It's all got rather hefty and cumbersome. MS no longer have much useful info or a link to a file in the KB articles, which is a real pain in the butt.

Looking at the files that are modified, they seem to be a mix of system files and XP driver files, maybe an update from the cards/access points manufacturer could cure it too (or better)

Cheers Murray P

John H
01-07-2004, 01:42 PM
Hi Murray

I checked in Add and remove programs (sic - American Engish), and found that the Hotfix had never been downloaded and installed, so it can't have shown up on Windoze updates.

I didn't feel like messing with the Hotfix as my first option, so I tried the tweak. Seeing that worked, I didn't install the Hotfix. If is ain't broke etc...

I am pretty sure I have the latest stuff from Linksys who are the manufacturers of both the WAP and one of the network adapters, but maybe I should do a check... I certainly know I have the latest firmware and software for the Intel adapter in the Fujitsu Centrino laptop, cos I did a search of that site a couple of weeks ago trying to find a Linux driver (that laptop dual boots W XP and Xandros Bus Ed).

Thanks for the suggestions.

John

Berryb
01-07-2004, 03:11 PM
You could try the XP wireless configuration utility instead of the one that came with the cards. I have wireless on my laptop running the utility that came with the card as the XP one would not work. Whereas on the desktop PC I had to use the XP utility as they one with the card wouldn't work. I still had problems with the desktop working fine then stopping for no reason and now have an access point and hardwired to the desktop and wireless to laptop. This is very stable.

Kenshin
01-07-2004, 05:30 PM
cool ...thx for the reply guys.

So where do u find this "authentication" thing?? I have seen it before ...but now I can't find it anywhere!

also after I get everything going, if I right click on the network tray icon and goto view available wireless network...I cant see anything!! I think that's where the authentication thing is... : *(

Supertrooper
01-07-2004, 07:56 PM
Wireless networking seems to be a pig at the best of times. I have recently had problems just getting two PCs to talk to each other and even now it is not fully resolved. WinME was a no-show when it came to trying to get another PC running 2kPro to talk to it, so ME was discarded in favour of 2kPro.
WinXP was just another nightmare, although I wasn't aware that it had its own built in Wi-net configuration.

John H
01-07-2004, 10:47 PM
>So where do u find this "authentication" thing??

In WinXP, go to the Start menu, and select Connect to - Show all connections. Right click on your Wireless Network Connection and select Properties.

There should be three tabs on the Properties display. Select Wireless Networks. If you see your Wireless Network's name (or ssid) under Preferred networks, select it and click the Properties button below it.

Your WLAN properties display has two tabs - select Authentication. Near the top, uncheck Enable IEEE.802.1x authentication for this network.

Now I don't know whether to do this on both of your computers. As I said in my earlier post, I have left the "gateway" computer (the one that owns the WAP and internet router) checked, and unchecked it on the other computers.

I will be interested to see whether this works for you as it does for me, but I offer no guarantees about the security of your WLAN to passers by looking for available networks!

John

Murray P
02-07-2004, 12:23 AM
Perfect timing. There is an article on trouble shooting WiFi bugs and glitches in the latest NZ PC World. Shame on you if you don't subscribe or haven't got your copy yet.

Cheers Murray P

John H
02-07-2004, 09:36 AM
I have subscribed for about three years Murray, and read the article before doing anything. The main help that article provided was to make me try again after having given up for some months, but it didn't provide the solution.

The article introduced me to the Wireless Zero Configuration Service, but ultimately that was no use at all. It only dealt with the symptoms not the cause. Sure, I could get the thing to connect again more quickly, but I had learnt other tricks to do that anyway, and it didn't stop the problem.

I found the solution myself by going to the Linksys website, then following their lead to the Microsoft site, and then finding a parallel way of doing what those web pages suggested.

John