PDA

View Full Version : Having problems installing stuff on SuSE



willie_M
30-06-2004, 01:24 AM
Hi guys... still a n00b but slowly getting the hang of it...

How do I install dctc and dcqt... dctc has INSTALL, Makefile.in and Makefile.am but i can't ./ cat or sh them... ?:|

Also, I tried to install firefox 0.9, but it used its stoopid installer and now the browser won't run... I installed it to /opt/mozilla-firefox/ and then it wanted to install it into /firefox-installer for some reason. No amount of dot-slashing or sh'ing would fix it either...

Cheers

willie_M
30-06-2004, 02:42 AM
When I type make install it says:

b]make: *** No rule to make target 'install'. Stop[/b]

Any Ideas?

Also can older SuSE programs (8.0) run on newer versions (9.1)?

johnboy
30-06-2004, 01:19 PM
Look thru these
Here (http://www.google.com/search?hl=en&lr=&ie=UTF-8&q=make%3A++No+rule+to+make+target+%27install%27.+S top&btnG=Search)
Here (http://portal.suse.com/sdb/en/2002/09/mozilla.html)

Chilling_Silence
30-06-2004, 01:30 PM
Try this in the directory you've extracted dctc to:
./configure --prefix=/usr
make && make install

./ is normally followed by the name of an executable file, eg ./configure
sh is normally to execute shell scripts

Try this as root:
mv firefox-0.9.1-i686-linux-gtk2+xft.tar.gz /usr/share
cd /usr/share
tar xvjz firefox-0.9.1-i686-linux-gtk2+xft.tar.gz
cd /usr/bin
ln -s /usr/share/firefox/firefox

Then Firefox should work when you run the command 'firefox'
:-)

Hope this helps


Chill.

willie_M
08-07-2004, 04:09 PM
Sorry guys... went to taupo..

Umm, nope it still does it even when I try that chill...

?:|

Graham L
09-07-2004, 02:43 PM
Have you got the "development" package installed? To have "make" you probably have, but you might still be missing some things, like the kernel headers. They normally live around /usr/src .