PDA

View Full Version : Samba problem



JohnD
26-06-2004, 09:07 PM
I have an annoying little problem with SAMBA running on RH9. I have about 7 PCs running XP connected to the server. I already have a number of shares for the users and needed to create one for everyone. I made a new group called everyone and added everyone to it. I made a new folder /home/shares/everyone and gave it the appropriate permissions assigning rights to the group everyone. I made a new section in smb.conf as below:

#Setup for EVERYONE folder
[EVERYONE]
comment = Shared directory for EVERYONE (sharable) data
path = /home/shares/everyone
valid users = johnd tricia secretary sharonw nichola user1 user2 user3 user4 user5 \
user6 user7 user8 user9 user10 user11 user12 user13 user14 user15 \
user16 user17 user18 user19 user20 user21 user22 user23 user24 user25 \
user26 user27 user28 user29 user30 user31 user32 user33 user34 user35 \
user36 user37 user38 user39 user40 user41 user42 user43 user44 user45 \
user46 user47 user48 user49 user50 testuser
public = no
writable = yes
;browseable = yes
create mask = 0770
force group = everyone


The problem is that it works well for the users at the start of the list but doesn't for (it seems) for the user* ones. I initially had user* and replaced this will the actual users.

Message from XP says no rights to the folder. But it is working for some!

Any ideas?

Gorela
27-06-2004, 11:46 AM
Hi John,

I'm not to sure which Users are working and which aren't, but ass u me (a line from "I Dream of Genie" from memory :) ) that the problem lies with the user1 on accounts. One possiblility is that you haven't set the smbpasswd for these users.

A quick way to check if this is the problem would be to set a password for user48. If the problem is solved we know that was the problem and if not we can look at other possibilities ;)

It might also be an idea to check the smb log file as that might give a few more clues to the problem as there are some great resources available at the Samba (http://au1.samba.org/samba/docs) site :)

HTH

Chilling_Silence
27-06-2004, 02:54 PM
Are all the usernames on the one line by any chance?

Graham L
27-06-2004, 03:57 PM
I strongly suspect that for a user to be a member of a group, the user must actually exist. :D

If you have done this to avoid shutting down the SAMBA server each time you add a user, remember that you can change the configuration file, then just tell it to read it again. It doesn't stop service to do this.

I don't know off hand which signal you give it ... there may be an option (other than start stop restart) in the "service samba <option >" command. kill -HUP processname does it for some servers; others use different signals to reload their configuration files.

JohnD
27-06-2004, 08:59 PM
Thanks for your responses everyone. Some points:
1. All the listed users are active samba accounts and are all working before I added them to the new group.
2. The users are not all on one line in the smb.conf file - but have the / as shown for a new line.
3. I performed "/etc/rc.d/init.d/smb restart" after the changes to the config file. "testparm" shows no errors.

John

Dolby Digital
27-06-2004, 10:48 PM
Hi John,

Is there a limit on the number of connections to the server although that would imply that a user who connected one day, couldn't connect another day.

Graham L
28-06-2004, 04:03 PM
You have e.g. user48 who can use Samba , but can't access this shared directory?

Try making the line into one line. ;-) It will be messy, and look like some threads here, but it might work. Though testparm should have complained, I suppose, if the split line with the escape"\"wasn't working, because the extra couple of lines would be syntax errors.

JohnD
28-06-2004, 09:37 PM
Thanks for the suggestion - will try next time I am there.

Another suggestion or long shot I have picked up. I am using Samba as a Windows Domain and the users that can access the share called "everyone" are also local users on the PC. The users that cannot access are domain users only (no local account). XP has a group called "everyone". So I am going to change the Samba group to "everybody" to see if there might be a conflict??