PDA

View Full Version : Sorry, another XP network problem



Rob99
21-06-2004, 03:39 PM
Hi I am having problems networking a Desktop comp XP Pro and a Notebook XP Home.
I have followed instructions at Microsoft
I have followed instructions in FAQ
I have followed instructions on various networking websites

The problem is the desktop cannot access the notebook by clicking into it alltho it shows up ok

The notebook can access files off the desktop ok

Pings work ok on both

They both have the same user on each machine

Their IP's are different the desktop is 192.168.0.1 and notebook is 192.168.0.2

They both share their shared docs folder

Is there anything else I can do?

Rob :(

beama
21-06-2004, 03:57 PM
checked your firewall settings on the laptop ?

Rob99
21-06-2004, 04:03 PM
Both firewall are disabled, eg Sygate is set to allow all on both and MS Firewall is switched off on both

Jester
21-06-2004, 06:30 PM
> The problem is the desktop cannot access the notebook
> by clicking into it alltho it shows up ok

Do you mean in My Network Places, you can see the shared folder on the Notebook but when you click it, it doesn't open? Do you get a message saying it is unaccesible?

Sometimes it may take a few mins to show up all the details, depending on the size of the folder.

Try sharing another Folder - in addition to the "shared" folders, and see what happens if you allow others access to it (Allow network users to change my files).

Ensure the PC's use the same protocols, including File and Printer Sharing is selected in the properties of your network connection (right click My Network Places on desktop, choose properties, and its on the General Tab). While there, double check the XP Firewall is off.

To be sure, reboot again after doing the above steps.

J
:D

Rob99
21-06-2004, 11:59 PM
Hi there I have figgured out the map network drive and am able to put and get files that way, but when you go to the workgroup in this case MSHOME you can see the icons for each computer.
The laptop can click into and browse this no worries but the desktop has this error (http://sal.neoburn.net/imagef1/files/error.jpg)

Rob

beama
22-06-2004, 12:26 AM
have you got file and print sharing installed

beama
22-06-2004, 12:39 AM
there list of possiblities here (http://www.google.co.nz/search?hl=en&ie=UTF-8&q=you+might+not+have+permission+to+use+this+networ k+resource&spell=1)

Jester
22-06-2004, 01:29 AM
Try changing the workgroup name to something other than "MSHOME", which is the default. Try just "HOME".

As asked before, ensure that you have File Sharing enabled.

Are you sure the firewall is off? I used to get that when using Zonealarm, even after it being configured right one day, the next day it would spit the dummy.

For testing purposes, share the root of the C drive on the laptop (best not to leave this shared for good).

Maybe you have tried to share or access the program or user files on the laptop, which will have access only if you set up user names and permissions on both PCs <--- messy.

J.

beama
22-06-2004, 08:01 AM
also is the laptop using NTFS file system as its possible to set a password access to network shares using this file system, which going by the image you provided, is what is happening, check the properties of the share.

Rob99
22-06-2004, 05:58 PM
Ok I have unshared, rebooted, shared, rebooted, changed the stack size several times in the regestry, rebooted, not to mention waiting numerious amounts time to see if it would work, completly removed network cards and protocols and all other stuff like that, rebooted and set everything up again, and buggar me it STILL DOES NOT GO!!! X-(

I have come to the conclusion that it is completly impossible for this to be done. :O

Not all bad, mapped drives works just fine and probally easier too.

Rob :)

Chilling_Silence
22-06-2004, 06:11 PM
First things first:
File-systems dont matter, you could be using the Linux Ext3 and it'd still share. Its all handled by the SMB protocol, so filesystems dont come into account.

Next:
It said "You might not have permission to access this resource" so surely that would point you in the direction of User accounts!

What is the username you're using on both PC's?

Try this:
Make a new user on both PC's, we'll call it "Chill" so you know what you're going (And just coz Im helping you... Call it Rob99 or whatever you want, just make sure its the same on both PC's!)
Next, give Chill a password on both PC's. Make it "password" for the time being, but again it doesnt matter what it is, so long as there is a password and it is identical on both systems.

Now, temporarily logout of both PC's and Login as Chill.

Browse the network on both and let me know if it works


Chill.

Rob99
22-06-2004, 06:18 PM
Tried this already Chill, and both accounts were administrators, both logged on with the same password and still the desktop cannot browse.

Rob

kiki
22-06-2004, 06:21 PM
Disable the firewalls completely till you get it working, then manually add each computer's IP address. For networking I recommend a static IP for each computer.

Then can go drop to the run box and type in the other computer's IP address e.g

\\192.168.0.11\

With XP, you need to make user accounts on each of the PCs. If computer one uses Rob as username/login, then make a user account called Rob on the other computer. Do that for both PCs.

Rob99
22-06-2004, 06:33 PM
I will give that a go later tonight kiki, thanks all.

Chilling_Silence
22-06-2004, 06:39 PM
Were they "Administrators" or THE Administrator???
You want them both to have an identical login...... Who cares if one is Admin and one has User rights, as long as the Login name and Password is IDENTICAL!

00falcon
22-06-2004, 09:45 PM
Ive just gone thru sorta the same thing... kinda....

Ummm... i dont really know but...

if you can ping you've got your TCP/IP set right...

In your "local area conection" properties in "networks conections" you have got
"client for microsoft networks"
and
"File and print sharing"...

four things...
Client...
Service...
Protocol...

Reboot...

???

Rob99
23-06-2004, 12:20 AM
Still no go

Fire walls completly dissabled
Anti virus completly dissabled
Exactly the same username and password logged into each comp
Ping works on both
Network connections correct
Reboot and wait still no go

Rob

Rob99
23-06-2004, 01:40 AM
Tried your idea kiki but no go

these were tried from the desktop's run...

\\192.168.0.2\ which is the notebook had the error message above

\\192.168.0.1\ is the desktop and worked fine

Rob