PDA

View Full Version : chmod 777 to server



Mzee
18-06-2004, 08:19 PM
I am setting up an online shopping basket and need to FTP some files to it.
I get "550 permission denied"
I need to do chmod 777 but when I try it repeats "permission denied".
I can get the ISP to do it but it sometimes takes a while.

How can I get it to accept my commands & can the ISP set it to do this?
The server is Unix, my OS is XP prof and my FTP is WS_FTP prof.
Any help will be appreciated.

stu120404
18-06-2004, 09:56 PM
> I am setting up an online shopping basket and need to
> FTP some files to it.
> I get "550 permission denied"

Is that when you try & upload the files?

> I need to do chmod 777 but when I try it repeats
> "permission denied".

The reason why you are getting that error message is because the server is not set up to allow "Chmod" or there is a permission problem with the serverů.

> I can get the ISP to do it but it sometimes takes a
> while.

Who is your web host?

> How can I get it to accept my commands & can the ISP
> set it to do this?

Yes, the ISP/ web host can do this

>my FTP is WS_FTP prof

It is not a problem with the FTP client/program, as I also have WS_FTP pro & I have just tried chmod a folder on one of my web server & it works

By the way what version of WS_FTP pro do you have?

>The server is Unix

Are you 100% sure about this?

Have you tried a different FTP client/program???

Post back with above answers & I will try & help you more :)

Mzee
19-06-2004, 12:28 AM
> I get "550 permission denied"
>Is that when you try & upload the files?

I have to upload the files to two folders. The FAQ sheet tells me that they should be chmod 777, I can change it back afterwards if I wish.

> I need to do chmod 777 but when I try it repeats
> "permission denied".

The reason why you are getting that error message is because the server is not set up to allow "Chmod" or there is a permission problem with the server….

> I can get the ISP to do it but it sometimes takes a
> while.

>Who is your web host?

Utopia. they are very good but busy. I set up another identical shop last week and had that 'fixed', would just like to be able to do it myself.
The other one is on chmod 772 & works well.
Current one is chmod 775 but doesn't work. book says chmod 777, so its all a bit of a mystery. There must be a master setting in the server.

> How can I get it to accept my commands & can the ISP
> set it to do this?

Yes, the ISP/ web host can do this

Gets a bit tedious asking every time I need to change it.

>my FTP is WS_FTP prof

It is not a problem with the FTP client/program, as I also have WS_FTP pro & I have just tried chmod a folder on one of my web server & it works

By the way what version of WS_FTP pro do you have?

V8.02T

>The server is Unix

Are you 100% sure about this?
I am pretty certain that it is Unix (Apache). It is case sensitive.

Have you tried other FTP

Several.

stu120404
19-06-2004, 12:35 AM
> Utopia. they are very good but busy. I set up another
> identical shop last week and had that 'fixed', would
> just like to be able to do it myself.
> The other one is on chmod 772 & works well.
> Current one is chmod 775 but doesn't work. book says
> chmod 777, so its all a bit of a mystery. There must
> be a master setting in the server.

have you tryed 772 it on this shop?

stu120404
19-06-2004, 12:38 AM
> Utopia. they are very good but busy. I set up
> another identical shop last week and had that 'fixed',
> would just like to be able to do it myself.

All I can suggest is e-mail them explaining that you cant chmod to 777 & see what they say.....

Let me know how you get on :)

Graham L
19-06-2004, 03:36 PM
If you "own" the directory you want to FTP to, you should be able to if the permissions are set to 772. That means that root (the ISP) and owner(you) both have "read, write, execute" rights, and world can only write to it (which seems an odd one).

"7" is all rights (RWE). If you have read and execute rights ("5") to a directory, you can "read" (see what's in it) , and "execute" it --- that is, use the directory information to access a file. You have to be able to write to a directory to add or remove files.

The mode number is 3 octal digits (add Read=4, Write=2, Execute=1 to get the digit for each of Root, Owner, World).

stu120404
24-06-2004, 12:32 PM
Hello Mzee :)

How did you get on?

Mzee
26-06-2004, 01:29 AM
Hi,
The chmod problem has been fixed :)
Michael Baxter of Utopia flicked the switch for me!
I presume that the ownership had to be transferred to my FTP password, or something like that. Works fine now & both stores are set up.

Thanks for all the help.

Greg S
26-06-2004, 11:41 AM
> Hi,
> The chmod problem has been fixed :)
> Michael Baxter of Utopia flicked the switch for me!
> I presume that the ownership had to be transferred
> to my FTP password, or something like that. Works
> fine now & both stores are set up.

Yeah the ISP has to allow it before you can alter all your settings. What software are you using for the store?