PDA

View Full Version : "Spybot" requires missing file.



Randolf
16-06-2004, 12:38 PM
When attempting to run "Spybot" for the first time, it required a missing file - WS2_32.dll, which I read is part of the WinSock 2 update for Windows '95. (My system is Windows '95B.)

I want to know the easiest way to install the file. Do I have to download all of the updates:
DUN 1.4
WinSock 2
Y2K 2000
or can I just download the file in question from www.dll-files.com, or something in between?

I really don't want the updates, as my system is working OK, just want to do the minimum, so I can run "Spybot".

Thanks for any help.

Susan B
16-06-2004, 12:44 PM
Just download the one you want and see how it goes. If it complains about needing the other stuff then I guess it will have to be done, but try just the Winsock one first. :-)

Randolf
17-06-2004, 04:06 PM
Thank you for your comments. Yes, this is one of my options.

However, could I get away with downloading just the file in question?

Maybe "Spybot' just overwrites the file? This is the sort of thing I would like to find out if possible, prior to doing what may be unnecessary.

Chilling_Silence
17-06-2004, 04:15 PM
As far as I can see you can get away with downloading just the file in question:
http://www.helpscreen.com.au/index.php?msgid=684393767&cid=4

Susan B
17-06-2004, 04:36 PM
Yes, I think I would agree with Chill that you can just download the WS2_32.dll file but if that does not fix things then you will have to install the complete WinSock2 thing.

Have a look here (http://www.liutilities.com/products/wintaskspro/dlllibrary/ws2_32/) for the WS2_32.dll file, or here (http://www.dll-files.com/dllindex/index.shtml).

Susan B
17-06-2004, 04:39 PM
Duh! I just noticed the link in Chill's reply and had a look..... :p :D

Randolf
18-06-2004, 03:19 PM
Grateful for your assistance. I decided to download the dll file. Spybot immediately asked for another - Ws2help.dll, which I duly fed it, and away it went, finding the malware I was looking for.

Only thing is, when asking it to update it yells (as there is an exclamation mark) 'Error retrieving update info file!" I think this is something to do with proxy servers or something which is over my head. I downloaded an update manually from "Major geeks" but I think it is a few months out of date.

If you can help me with this update question I'd be very pleased.

Pheonix
18-06-2004, 04:14 PM
Some guidance on your problem here (http://www.safer-networking.org/index.php?page=faq&detail=10)

Randolf
18-06-2004, 10:34 PM
Thankyou for this. However as I don't use a proxy server, and my configuration in Spybot is set accordingly, I don't think this is the problem.