PDA

View Full Version : Problem with opening folder



utopia
02-06-2004, 01:28 AM
Since I attpted to change some of the system icons to custom-made icons, Windows will no longer open folders when I double-click on them - instead it opens the command prompt! I can open the window by right-clicking on it and selecting "open", however.
I tried System restore but got a "Restoration Incomplete" error message with all the restore points I've tried.
Help!

metla
02-06-2004, 01:31 AM
Whats your os?

utopia
02-06-2004, 10:27 AM
sorry... I forgot to mention that.
I'm using XP PRO SP1

godfather
02-06-2004, 10:47 AM
Try a system file check.

Start - Run - type "SFC /scannow" and enter. Sans the quotes of course, and note the space between sfc and /scannow

metla
02-06-2004, 11:02 AM
Strange,last night i found dozens of results that may have been exactly what you were loking for,thos morning i can find none of them.

Plus,i make terrible coffee,i really need to hire someone who can make coffee.....

I did grab this,but it doesnt say whether its for xp or not,so use at your own risk.

this can be fixed with two simple commands which should be run from a command session (cmd.exe)

1. From the Start menu select Programs and then Command Prompt (or select Run and enter cmd.exe)
2. Enter the following commands:
ftype folder=%SystemRoot%\Explorer.exe /idlist,%I,%L
assoc folder=folder
3. Close the command session

The first command creates a new file type, folder, and the action associated with it. The second command creates the association between the "extension" and its file type.

which was sourced from here

http://www.winnetmag.com/Article/ArticleID/14586/14586.html

utopia
03-06-2004, 01:03 AM
the System File Checker didnt come up with any errors, and the solution metla offered dates back to 1999 - probably not compatable with XP (haven't tried it yet, but thanks anyway).
Any other possible solutions?

bishfish
13-08-2004, 06:24 PM
Took a long time but found it -

http://www.computing.net/windowsxp/wwwboard/forum/111078.html


To resolve this problem, edit the registry to set the value data for the Default string value in the registry keys that are described in the "Cause" section of this article to none:
Start Registry Editor (Regedt32.exe).
Locate and then click the Default value under the following keys in the registry if this problem occurs with folders:
HKEY_CLASSES_ROOT\Directory\shell

If this problem occurs with drives:
HKEY_CLASSES_ROOT\Drive\shell

Click Modify on the Edit menu.
Type none in the Value data box, and then click OK.
Quit Registry Editor."

Worked fine for me