PDA

View Full Version : ChatF1 Facelift



nz_liam
26-05-2004, 04:15 PM
The ChatF1 login page has had a wee facelift, (actually just a script modification, the 'facelift' has been there all the time, itís now been changed to default).

All credits for the login page go-to Sal :)

We will also be making a few modifications to ChatF1 over the coming months ;)

As always http://www.chatf1.net.nz !

/me is off to Uni now :)

somebody
26-05-2004, 05:23 PM
umm... is it just me or has ChatF1 lost the ability to select styles?

beetle
26-05-2004, 05:28 PM
Classic blue or classic blue????

whats the go liam???

same old same old otherwise i guess.......


havent seen some of you people in there yet though??????

and then there's some who musta forgot how to get back cos its been a while since chat f1 seen ya.

beetle

Pato
26-05-2004, 05:30 PM
For some reason I cannot access Chatf1. My ISP is Paradise.net would this have anything to do with it?.

stu120404
26-05-2004, 05:49 PM
Yep :( it is a know issue (which one day will be fixed) for now e-mail liam
liam [at] farr [dot] net [dot] nz.

Pato
26-05-2004, 06:00 PM
Many thanks Stu. Will do that. cheers.

R2x1
26-05-2004, 06:01 PM
> and then there's some who musta forgot how to get
> back cos its been a while since chat f1 seen ya.
> beetle

Now I remember :D
R2

nz_liam
26-05-2004, 06:03 PM
> For some reason I cannot access Chatf1. My ISP is
> Paradise.net would this have anything to do with it?

Hi,

The short term advisory for paradise users is change ISP. There are no known issues with ANY other ISP's. Otherwise please hang tight as we are working with paradise to resolve this issue.

Regards

nz_liam

nz_liam
26-05-2004, 06:12 PM
> umm... is it just me or has ChatF1 lost the ability
> to select styles?

Yes, that is correct, its only for the login page, and seeing as it's only used to login multiple styles are not needed, and have been removed.

Enjoy, nz_liam :)

agent
26-05-2004, 06:13 PM
> havent seen some of you people in there yet though??????

I would've logged in a few days ago, but I've forgotten my password :8}

The thing is, I stored it in a database sometime last year, but since I formatted my computer, I haven't reinstalled Microsoft Office, and hence Access.

nz_liam
26-05-2004, 06:17 PM
> Yep :( it is a know issue (which one day will be
> fixed) for now e-mail liam
> liam [at] farr [dot] net [dot] nz.

We did have the paradise problem fixed, however because their proxy IGNORES no cache meta tags we require them to put another manual exemption for chatf1, (due to some changes made to the system a few weeks back). Also the fact that most of paradises CSR's actively deny that they have a caching proxy in operation doesnít help, although I believe all their support is now being handled by Telstra clear, who are very helpful.

nz_liam
26-05-2004, 06:19 PM
> > havent seen some of you people in there yet
> though??????
>
> I would've logged in a few days ago, but I've
> forgotten my password :8}
>
> The thing is, I stored it in a database sometime last
> year, but since I formatted my computer, I haven't
> reinstalled Microsoft Office, and hence Access.

I can perform a password reset for you if you require, I'm at Uni at the moment so just let me know here.

agent
26-05-2004, 06:40 PM
Don't bother, part of the reason is me being too lazy - I'm installing Access now (besides, I kind of need it to look at other databases), so I can pull my password out soon enough.

nz_liam
26-05-2004, 07:22 PM
Hmm, there seems to be some problems with that facelift, is anyone else getting classic white displayed instead of blue on the login page? (Or perhaps its the proxy im sitting behind.)

ilikelinux
26-05-2004, 07:44 PM
What????

I het this error when i go to chatf1.net.nZ


Parse error: parse error in /home/farr/public_html/chat/chat/lib/index.lib.php3 on line 697

Fatal error: Call to undefined function: send_headers() in /home/farr/public_html/chat/index.php on line 14

the time now is 1843 27/5/04
Are we undegoing an update?


OH: update : 1 minute later:

Warning: main(./chat/lib/index.lib.php3): failed to open stream: No such file or directory in /home/farr/public_html/chat/index.php on line 4

Fatal error: main(): Failed opening required './chat/lib/index.lib.php3' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/farr/public_html/chat/index.php on line 4

nz_liam
26-05-2004, 07:47 PM
Correct, that is the error everyone is getting at the moment, until I can do a restore from home.

nz_liam
26-05-2004, 08:15 PM
Woot, I tried to run before I could walk here, and subsequently fell over, (and a few other "interesting" problems with cPanel and squid). ChatF1 is back up again, with a temporary fix, and should be properly fixed this eve when I get home.

nz_liam
27-05-2004, 01:14 AM
Woot; after much learning about how the ChatF1 Style sheet switcher works, how it integrates with the core php modules and the JavaScript modules that handle the cookies we have everything back to normal :):):)

When you go-to ChatF1 now you are greeted by the Blue login page as default, and have the choice of either Blue or Purple style from a dropdown box. Once you have made a selection from the drop down box you selection is saved in a cookie so that you receive the same style next time your login :)

Thanks goes out to Sal (wherever he may be) for building and implementing the style sheet/new look login system, I just tried to change it, broke it, worked out how it works, and fixed it tonight :D (And have to be up @ 5:45 tomorrow morn, so should be going to sleep now :))