PDA

View Full Version : netscape/opera and java



kiwitwat
20-04-2004, 10:00 AM
Hi all. I use netscape and opera browsers on 2 machines running XP pro but java does no work in either machine or with IE. According to the netscape site I have jave installed. What do I do now? TIA

Oxie
20-04-2004, 10:16 AM
kiwitwat

What version of Netscape are you using? The reason I ask is when I had Communicator (I think 4.79) Java would crash Netscape, but all is well since having Netscape 7.1.

Oxie (Lyn)

Jim B
20-04-2004, 10:57 AM
Start|Settings|Control Panel
Scroll down the list and if there is Java installed, it should be listed there. Java Plug-in 1.4.0

Also, look in Edit|Preferences|Advanced
Have you enabled Java?

Do you recall when you installed Netscape 7, if you selected Java as a component to install? You were given that choice on the "Select Additional Components" window. If you deselected Sun Java 2, then you will need to install Java 1.4,

http://www.java.com/en/index.jsp
Select the Free Download link

Also testing and help at this link
http://www.java.com/en/download/help/testvm.jsp

kiwitwat
20-04-2004, 01:01 PM
I've been having a play and it seems that only animated gif files do not work?

Jim B
20-04-2004, 01:37 PM
Do you have ZoneAlarm Pro installed? If so, open the programme, go to the Privacy Tab and click on the custom button. Make sure that the option to block animation is turned OFF.

Go to IE tools/internet options/advanced/multimedia. Ensure the option to show animations is turned on. If no joy, make sure your .gifs are associated to Internet Explorer - if you click on a .gif in windows explorer, IE should open to display it. :
Easy way (Doug Knox's script utility):
http://www.dougknox.com/utility/scripts_desc/fixpix.htm

Harder way:

Go to start/run and type:

regsvr32.exe /i shdocvw.dll (all versions of IE) ... and then
regsvr32.exe /i shdoc401.dll (IE5 upwards)
If using WindowsME the command is:
regsvr32.exe /i thumbvw.dll

After a wait you will get a *succeeded* dialogue box after each command. Click ok, reboot and see if things are fixed.

But be warned, this resets a lot of file associations back to the standard defaults, so some image viewer programmes may complain - but that's an easy fix - you can pick and choose your file associations later.

If it still isn't fixed (make sure you reboot your system before checking) go to start/run and type the following:

regsvr32 /i occache.dll

kiwitwat
20-04-2004, 02:13 PM
Thanks Jim B Zone alarm was the problem
Thanks everyone for your help.

mikebartnz
21-04-2004, 01:20 AM
7.2 is comong shortly.