PDA

View Full Version : network problem



karent
18-04-2004, 01:12 PM
Good afternoon. We have 3 PCs running XP Pro. Have set up network (we thought!). One PC can see the other two, but two can't see the other one. The error message is:
"PC3is not accessible. You might not have permission to use this network resource. Contact ths administrator of this server to find out if you have access permissions.
Logon failure: user account restriction. Possible reasons are blank passwords not allowed, logon hour restrictions or a policy restriction has been enforced."
We do not use passwords to access any of the PCs.
Any help from the many of you who know heaps more about all this than we do is much appreciated. Ta.

whetu
18-04-2004, 02:47 PM
go into the local area network connection properties. there should be an authentication tab in there. from within that tab there should be an option to enable/disable IEEExxxx authentication. Disable it on all the pc's and see how that goes

karent
18-04-2004, 03:21 PM
Hi. I did as you suggested but it hasn't made any difference. Do the PCs/router need to be rebooted?

Graham L
18-04-2004, 03:24 PM
You may not use passwords, but you will need matching accounts on each machine. I believe that the "Guest" one will do, but it needs to be enabled.

karent
18-04-2004, 03:40 PM
Guest account enabled on all PCs. Still not working - one is now asking for a password to the PC it can't see on the network. Not sure if that's a result of the earlier suggested fix or the latter (disable IEEExxx authenticaton). Once again, having made these changes do the PCs have to be rebooted?

Graham L
18-04-2004, 03:46 PM
Probably a good idea. :D A lot of things need a cold start to be properly initialised.

aNtzy
18-04-2004, 03:52 PM
> Probably a good idea. :D A lot of things need a cold
> start to be properly initialised.

I saw you at the CHCH library (in the city) ... just a few minutes ago in fact ... forgive me for not introducing myself but you looked like you we busy typing. Well anyway, carry on!

- aNtzy

Susan B
18-04-2004, 06:06 PM
> I saw you at the CHCH library (in the city) ... just a few minutes ago in fact ... forgive me for not introducing myself but you looked like you we busy typing.

How did you know it was Graham? Was he the only one busy on the PF1 page? :D

There are other people who use the library computers to do that too, you know. ;-)

karent
18-04-2004, 06:31 PM
Getting back to the subject ...
Made those changes, rebooted and still can't see PC3 on PC1 or PC2. Grateful for any other suggestions, thanks.

Susan B
18-04-2004, 08:30 PM
You don't have any firewalls running do you? Ensure that the Windows one is disabled as well until the network is set up.

karent
18-04-2004, 08:39 PM
The network is already set up. By the way, it seems I was wrong. We have two out of three machines working properly. There is something crook with the setup of only one of them, not two as stated in my original post. Would still like to get to the bottom of it...

aNtzy
19-04-2004, 03:51 AM
> > I saw you at the CHCH library (in the city) ...
> > just a few minutes ago in fact ... forgive me for not
> > introducing myself but you looked like you we busy
> > typing.

> How did you know it was Graham? Was he the only one
> busy on the PF1 page? :D

<snip>

Errr ... well, I was searching for a book by Robert Jordon and next to me there was this bloke who was typing in a reply on the Pressf1 forum and, well ..., I kinda peeked and saw his username :8}.

Okay I know. I should be ashamed of myself and I am, well kinda.

aNtzy
19-04-2004, 04:05 AM
> The network is already set up. By the way, it seems I
> was wrong. We have two out of three machines working
> properly. There is something crook with the setup of
> only one of them, not two as stated in my original
> post. Would still like to get to the bottom of it...

Is the network mask the same on all the machines?

karent
19-04-2004, 10:26 AM
Network mask ?:| I have no idea what you're talking about (but I am willing to learn). Cheers
P.S: Don't you ever sleep?

karent
19-04-2004, 11:06 AM
Good morning. This is an update/correction of my original post on this.
We have 3 networked PCs running XP Pro. One of them can see the other two. However, two of them can't see the other one. An error message on one of these two says:
"<pcname> is not accessible. You might not have permission to use this network resource. Contact ths administrator of this server to find out if you have access permissions.
Logon failure: user account restriction. Possible reasons are blank passwords not allowed, logon hour restrictions or a policy restriction has been enforced."
The other one asks for a password to the third PC. We have not set up passwords on any of the machines. Part of the difficulty is, we're not even sure which PC has the problem. Although everything appears sweet with one (it can see the others) could it be something to do with permissions or whatever on that PC, or is the problem somewhere with the other two?
Grateful for any assistance - but please not too technical, if possible.
Meantime, enjoy your day. The weather in the capital is fantastic today.:)

aNtzy
19-04-2004, 05:22 PM
> Network mask ?:| I have no idea what you're talking
> about (but I am willing to learn). Cheers

I'm wondering if you are able to ping your machines. Use the PC that can see the other two PCs (lets call them PC2 & PC3 for now). You will need the ip address of both PC2 & PC3. I maybe way of base here but here goes.

I'm not sure if you know how to do this so I'll go through the steps. If you do know the steps then ignore.

Do for both PC2 & PC3:

1. go to start
2. click run (right hand side)
3. type in cmd and hit enter.
4. in the command prompt type in ipconfig then hit enter.

For each PC (PC2 & PC3) note down the IP address. While you're at it note down the Subnet mask (for all the PCs it should be 255.255.255.0). Using PC1 repeat steps 1 -3. This time type in:

5. ping IP Address of PC2 (the address you jotted down).
6. repeat step 5 but this time replace IP Address of PC2 with IP Address of PC3.

When you pinged PC2 and PC3, what did it say? Are your subnet mask the same for all PCs?

> P.S: Don't you ever sleep?

Yep, I sleep :)

beama
19-04-2004, 05:54 PM
Have you checked the share's on all the pc's. I think there is an option in the shares area to grant access with password or without password ("access type" if a password is entered into there, that maybe where the password request is coming from) to check right click on the hard drive or folder you are trying to share and select sharing.. then the sharing tab check the options within there

Growly
19-04-2004, 06:12 PM
Provided they can all ping each other and localhost, then you can try this:

On both computers that cannot be accessed by the odd one out;

1) Go to Tools --> Folder Options --> View then down the bottom, make sure that the Use simple file sharing (recommended) check box is unticked.

2) Go to share any file/drive. In the share tab, there will be a drop down list beside Share Name, make sure it is not $ then the name of the drive/folder. (I.E. If sharing C drive, make sure that it does not say $C ). If it does, use the drop down menu to select one that doesnt. If there is no other option, then click "New Share". Fill our a share name, and dont worry about the user limit. Click OK. Back on the Share Tab of the folder properties screen, make sure that you have the share you just made gighlighted in the drop down menu beside "share name".

Click Permisson. Make sure that the only entry there is "Everyone", and that underneath that all the boxes under "Allow" are ticked.

Click OK, Apply, OK.

3) Go back to Tools --> Folder Options --> View then down the bottom, make sure that the Use simple file sharing (recommended) check box is ticked.

4) Go all the way back to the properies of the folder / drive you wish to share (like you did in step 3). Now, under the Sharing tab, down the bottom, make sure you have clicked all the underlined blue sentences (these come up as warnings to stop you from going too far, in this case, you want to. ie. It may say "If you understand the risks...."etc etc at the top. Click it) necessary to be able to see something that says Share this folder on the network. Make sure the box beside it is checked.

Click OK

^ That has worked for many with same symptoms, give it a try. In most cases, as Graham L pointed out, you need to keep the same accounts on all computers.

Growly
19-04-2004, 06:14 PM
Sorry.. havent slept for three days (oh the irony)...

*out

*highlighted

*permissons

aNtzy
19-04-2004, 09:42 PM
There are rather excellent pdfs on networking. It explains about network protocols as well as subnet masks, etc. It's very easy to read and understand with ample of diagrams. I'm not saying it will solve your current problem but it will help you in understanding certain concepts. If you are interested in reading the pdfs click here (http://www.techyon.co.nz/publications/).

Jester
19-04-2004, 10:26 PM
This has been suggested, I couldn't see your response though...

Disable all firewalls, incl the built in firewall that comes with XP. It has solved all my networking problems in the past. Once you have the network running correctly enable the firewalls one machine at a time and re-check if it still works.

Zonealarm didn't like my home network, even with the IP range set as trusted. Sygate seems better behaved.

J
:D

tech_meister
20-04-2004, 01:14 PM
It looks to me like you have not got file sharing enabled
to do this go to any folder or drive r/click select
sharing and security and share the folder or drive a dialog box should come up, select just enable file sharing, once shared you should be able to see other computers, you will have to do this on all PC's.
If this does not work make sure simple file sharing is enabled, in tools, folder options, it is enabled by default in XP pro so should be ok, with this enabled accounts are not needed.
If it is still no good disable all installed firewalls,
if you are using a ADSL router/modem with 4 port switch
they usually have a built-in firewall so you only need a good antivirus program and additional firewalls are unnecessary.

hope that helps
Cheers

karent
21-04-2004, 10:41 AM
Hi. As already mentioned all 3 PCs have file/folder sharing enabled. If it's any help, we are using a 4 port NETGEAR FM114P Cable Firewall Router. After trying some of the suggested fixes last night and having no success, Kevin finally unplugged PC 2 and 3 from the router, reset the router and at this stage we can at least get online. I guess he'll have another fiddle when he gets home this evening. [sigh!]

tech_meister
21-04-2004, 06:50 PM
It is not enough to just have file sharing enabled, you must
actually share a folder or drive.
In your previous post you mention one of the PC's comes up asking for a password for this to happen one or more of the PC's must not have
simple file sharing enabled.

odyssey
25-04-2004, 09:00 PM
I struck the same problem last week when I was trying to network my Desktop to my new Laptop (both using XP Pro). After a lot of playing around I managed to isolate the problem to a local security setting policy.

To access the security policy in question you will need to go to Control Panel -&gt; Administrative Tools -&gt; Local Security Settings. This will open up a new window that has two panels side by side (similar to the registry). On the left hand side panel select 'Local Policies' and then choose 'Security Options'. On the right hand side panel find the policy 'Network Access: Sharing and security model for local accounts' and double click on it. In the dialog box that comes up choose 'Classic - Local users authenticate as themselves'. Select 'Ok' and close the 'Local Security Settings' window. This should be performed on all the PCs.

Now you may still have a problem once you change this setting but post back with what comes up after you have tried the above steps.

Cheers
Dave

karent
27-04-2004, 02:18 PM
Hey Dave - tried your fix but no change. However, the latest is we have removed the third PC from the network temporarily until we can get another issue with that particular one sorted. Now we have two PCs "networked" where one can see/be the other but not vice versa. The one that can't see/be the other is the one with the cable modem/router connected directly to it.

Susan B
27-04-2004, 02:59 PM
You have still given no indication of whether you have any firewalls running or not despite being asked twice now.

If you have the Windows XP native firewall enabled it is highly unlikely that you will get your problem solved. It needs to be disabled on the machines that are not directly connected to the internet gateway for file and printer sharing to work.

Billy T
27-04-2004, 03:08 PM
Hi Karent

I don't see any confirmation in this thread that you have set the Router IP as your gateway, and the subnet mask in your network TCP/IP properties.

Subnet mask is 255.255.255.0 for all computers, the default gateway will be someting like 192.168.7.1 which is the IP address of your router, and each computer has an IP address that is a variation of the Router IP e.g
192.168.1.2/.3/.4 etc.

If you have done all this OK, but it doesn't show in the thread.

I am no expert on networking, but I have a six computer network running through a D-Link switch and a Nokia router and it only takes about 5 minutes to add another connection so something fairly basic must be wrong.

In my case the router is my Jetstream connection and if I didn't have that I guess I'd only have the switch betwwen the computers so what that does for the default gateway setting I'm not quite sure.

Cheers

Billy 8-{)

karent
28-04-2004, 11:56 AM
There was a process we went through with the router which involved putting IP addresses (is that the term?) into an online form on the NETGEAR site. Bear in mind that I did none of this myself - my partner did - and I am working from memory as it was about 3 weeks ago when we first tried to set things up. Anyhow, I am certain at least that the router has been set properly.
And Susan, I consider myself told off! However, yes, the WinXP firewall has been disabled on the "networked" PCs.

Chilling_Silence
28-04-2004, 12:41 PM
Can you do this for us please:

Click Start
Click Run
Type in:
cmd

Now, type the following commands and copy/paste the output into a response message on this thread:
ipconfig /all
ping 192.168.0.1
ping 192.168.1.1
ping 210.48.100.45


If you could do that from all the PC's, that'd be great!

Cheers


Chill.

karent
28-04-2004, 01:00 PM
"If you could do that from all the PC's, that'd be great!"

Okay - I'll do it when I get home this afternoon. Thanks.

aNtzy
28-04-2004, 06:59 PM
>> If you could do that from all the PC's, that'd be
>> great!

> Okay - I'll do it when I get home this afternoon.
> Thanks.

<grumbles ...> I asked you to do that ages ago!

ktee
29-04-2004, 02:45 PM
Hi all. Sorry for the delay getting back. For some reason I couldn't log on to F1 this morning (and I ran out of time yesterday). Anyhow, the details I was asked to post are as follows:
1st PC (LAN 1)
C:\Documents and Settings\Kevin>ipconfig/all
Windows IP Configuration
Host Name . . . . . . . . . . . . : PC1
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
Ethernet adapter Network Bridge:
Connection-specific DNS Suffix . : paradise.net.nz
Description . . . . . . . . . . . : MAC Bridge Miniport
Physical Address. . . . . . . . . : 72-81-E8-E7-AF-B1
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 203.96.152.4
203.96.152.12
Lease Obtained. . . . . . . . . . : Thursday, 29 April 2004 9:43:09 a.m.

Lease Expires . . . . . . . . . . : Sunday, 2 May 2004 9:43:09 a.m.

C:\Documents and Settings\Kevin>ping 192.168.0.1

Pinging 192.168.0.1 with 32 bytes of data:

Reply from 192.168.0.1: bytes=32 time=1ms TTL=64
Reply from 192.168.0.1: bytes=32 time=1ms TTL=64
Reply from 192.168.0.1: bytes=32 time=1ms TTL=64
Reply from 192.168.0.1: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\Documents and Settings\Kevin>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Documents and Settings\Kevin>ping 210.48.100.45

Pinging 210.48.100.45 with 32 bytes of data:

Reply from 210.48.100.45: bytes=32 time=29ms TTL=57
Reply from 210.48.100.45: bytes=32 time=26ms TTL=57
Reply from 210.48.100.45: bytes=32 time=30ms TTL=57
Reply from 210.48.100.45: bytes=32 time=36ms TTL=57

Ping statistics for 210.48.100.45:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 26ms, Maximum = 36ms, Average = 30ms


2nd PC
C:\Documents and Settings\Karen&Kevin>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : SNAKE
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Network Bridge (Network Bridge):

Connection-specific DNS Suffix . : paradise.net.nz
Description . . . . . . . . . . . : MAC Bridge Miniport
Physical Address. . . . . . . . . : E2-FD-38-14-72-E0
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 203.96.152.4
203.96.152.12
Lease Obtained. . . . . . . . . . : Thursday, 29 April 2004 9:43:02 a.m.

Lease Expires . . . . . . . . . . : Sunday, 2 May 2004 9:43:02 a.m.

C:\Documents and Settings\Karen&Kevin>ping 192.168.0.1

Pinging 192.168.0.1 with 32 bytes of data:

Reply from 192.168.0.1: bytes=32 time=1ms TTL=64
Reply from 192.168.0.1: bytes=32 time=1ms TTL=64
Reply from 192.168.0.1: bytes=32 time=1ms TTL=64
Reply from 192.168.0.1: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\Documents and Settings\Karen&Kevin>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Documents and Settings\Karen&Kevin>ping 210.48.100.45

Pinging 210.48.100.45 with 32 bytes of data:

Reply from 210.48.100.45: bytes=32 time=43ms TTL=57
Reply from 210.48.100.45: bytes=32 time=25ms TTL=57
Reply from 210.48.100.45: bytes=32 time=26ms TTL=57
Reply from 210.48.100.45: bytes=32 time=30ms TTL=57

Ping statistics for 210.48.100.45:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 25ms, Maximum = 43ms, Average = 31ms

C:\Documents and Settings\Karen&Kevin>


3rd PC
C:\>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : PIGLET
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 3:

Connection-specific DNS Suffix . : paradise.net.nz
Description . . . . . . . . . . . : 3Com EtherLink 10/100 PCI For Comple
te PC Management NIC (3C905C-TX)
Physical Address. . . . . . . . . : 00-50-DA-29-20-5A
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.4
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 203.96.152.4
203.96.152.12
Lease Obtained. . . . . . . . . . : Thursday, 29 April 2004 9:43:28 a.m.

Lease Expires . . . . . . . . . . : Sunday, 2 May 2004 9:43:28 a.m.

C:\>ping 192.168.0.1

Pinging 192.168.0.1 with 32 bytes of data:

Reply from 192.168.0.1: bytes=32 time=1ms TTL=64
Reply from 192.168.0.1: bytes=32 time=1ms TTL=64
Reply from 192.168.0.1: bytes=32 time=1ms TTL=64
Reply from 192.168.0.1: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\>ping 210.48.100.45

Pinging 210.48.100.45 with 32 bytes of data:

Reply from 210.48.100.45: bytes=32 time=27ms TTL=57
Reply from 210.48.100.45: bytes=32 time=24ms TTL=57
Reply from 210.48.100.45: bytes=32 time=24ms TTL=57
Reply from 210.48.100.45: bytes=32 time=24ms TTL=57

Ping statistics for 210.48.100.45:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 24ms, Maximum = 27ms, Average = 24ms


And apologies for not providing it as requested earlier. Thanks.

Chilling_Silence
29-04-2004, 03:55 PM
Okay....

All OS's are connected to the net fine and your networking looks 100% on that level.

Its File / Printer sharing that's at fault here (Go figure).

So, from the PC that you cannot access via Network Neighbourhood, you will need to add a user account that is EXACTLY the same as on the other two PC's.

This means username and password, right down to case sensitivity.

So, lets say you're logging into PC 1 and 2 (The ones that work) as user "Ktee", then create an account on PC 3 with the same username and password.

Now.. Something to watch for:
Passwords

You NEED one. Blank passwords arent allowed :-)

I just noted you said this in your first post:
We do not use passwords to access any of the PCs.

So that's probably half the problem.

Give everybody a password (The same one for the same account...):
So, try the following:
username:
ktee
password:
*anything you like, but make sure its the same for all PC's and all PC's actually have one...*


Then get back to us :-)


Chill.

ktee
29-04-2004, 05:37 PM
Hi again. I haven't made any changes yet because I need some more clarification - okay, so I'm a little cautious. The latest is as folllows:
PC2 and PC3 can see/access files on PC1 (the host computer).
PC1 cannot see PC2 at all, but can see PC3 when I click "view workgroup computers".
However, PC1 cannot see/access any files on PC3. When I click on the PC3 name in view workgroup computers I get an error message: "PC3 is not accessible. You might not have permission to use this network resource... etc".
PC2 cannot see PC3 at all.
PC3 cannot see PC2 at all.
Soooo, my questions are:
1. If I need passwords to access all PCs, how come I can get to PC1 from PC2 and PC3?
2. How do I check/change usernames, passwords, etc?
3. You refer to Network Neighbourhood. Is that the same as My Network Places? (I have never seen anything referred to as Network Neighbourhood).
Sorry for being so duhhh, and thanks.

Billy T
29-04-2004, 05:53 PM
I didn't have to set up accounts, user names or passwords on any of my networked computers (4 W2K, 1 W98 & 1 W95) chill. All I have ever done is setup the IP addresses, gateway and subnet mask & used Xtras DNS. I don't use DHCP and after setting up disk sharing it has always been instant connectivity.

Some computer do have passwords, but most don't. The only point of difference seems to be that I have both TCP-IP and NetBui enabled. I have no idea whether NetBui makes a difference but there it is, everything works fine.

I do accept that network security is not good, but environment security is very good so unauthorised access to computers is not an issue. Online security is via a Nokia router backed up by Zonealarm.

I am curious as to why my minimalist setup works so well when more complex arrangements don't, though I am not promoting my system as a good idea or even desirable.

Cheers

Billy 8-{) ?:|

CYaBro
29-04-2004, 06:12 PM
Hey Billy, I think it is a new Windows XP Pro (not sure about XPHome) security update.
If you want to share a folder/drive on a network then to access it you must have a username and password setup on the PC sharing the folder/drive and these must be put in to access them unless you are logging into Windows with the same username/password.

Jester
29-04-2004, 08:38 PM
Billy, I agree wholeheartedly, and this has been covered before. I wasn't going to say anything in this thread to avoid more confusion, but ah well, here I go.

I have never had to set up usernames/passwords etc on any PC's networked at home here. I hold mini-lans here at home and there are a mixture of XP home, XP pro and win 98 PC's involved. All are up to date as security fixes go (mine and kid's PCs are XP pro).

All we do is set the workgroup as the same name, and enable sharing on whatever folders we want to leech off each other. As long as at least one folder is shared and the XP in-built firewall is off, each PC can see what's in each other's shared folders (network neighbourhood in 98, Network Places in XP).

Sounds to be getting all rather too complicated.

J
:D

tech_meister
30-04-2004, 03:39 AM
Some of the ipconfig stuff looks bit odd to me.
2 of the PC's (PC1,Snake) lan cards are MAC bridge mini port!?
You are unable to ping the router's ip address of 192.168.0.1 which you must be able to do.
What sort of Cable/ADSL modem are you using?
If you use simple file sharing no user accounts or pass words are
needed, but to see and comunicate with the other PC's you must share a drive or folder, also do not enable guest account it is a security risk.
All the PC's must be using use automatic ip address as the router has
a built in DHCP server and is enabled by default.
Let me know about the modem.

karent
30-04-2004, 10:26 AM
Good grief! If I wasn't already confused, I sure am now. We have a 4 port NETGEAR FM114P Cable Firewall Router and the modem is one provided by TelstraClear - a Motorola model I think (I'm not at home so I can't check). All the PC's have automatic IP address enabled. I'm beginning to think we'll have to settle for being able to access the 'net from all PCs and forget about file/resource sharing. :_|

karent
30-04-2004, 10:31 AM
One other question while I remember. The host PC is part of a workgroup called teepee (don't ask). PC3 is also in that workgroup. However, for some reason PC2 sits in a workgroup called, strangely enough, workgroup. Even Kevin thinks that's a bit odd, but as he hasn't had time to get back to addressing the networking issue, we haven't really looked into that as a possible cause of some (or all?) of the problems. What do you clever people think?

godfather
30-04-2004, 10:50 AM
All PC's must be in the same workgroup.

Rename the "workgroup" one to "teepee", as "workgroup" is just the default MS allocated name.

And I won't ask....

Jester
30-04-2004, 10:52 AM
they all must have the same workgroup name. Possibly the cause of most of your problems!

I won't ask, either ;)

karent
30-04-2004, 11:06 AM
Will we end up with two teepees, or will one over-write the other? :)

Jester
30-04-2004, 11:11 AM
you should have 3 teepee's.

A nice little camp fire

And some horses contentedly sitting nearby.

Think of "teepee" as the village that all your computers sit in, so their address is 'teepee'. Each computer has its own individual name, but they all live in the teepee village.

So that when they need to communicate with each other, they know to look in their village, rather than looking to the next village, called "workgroup" - where, the dastardly cowboy Wild Bill Gates lives. They don't want to go there.

J
:D

Jester
30-04-2004, 11:20 AM
On your desktop, on each PC, right click the ' My Computer ' icon, then select the 'Computer Name' tab , then click the 'Change' button.

Chnage the computer name and workgroup as shown in the attached image.

J
:D

http://sal.neoburn.net/imagef1/files/teepee.jpg

Fire-and-Ice
30-04-2004, 12:16 PM
As a matter of interest how come my computer name dialogue box is different to yours Jester? Mine doesn't have a domain name as an option. Thats with XP home - is yours XP pro? ?:|
http://sal.neoburn.net/imagef1/files/fire-network.jpg

Fire-and-Ice
30-04-2004, 12:20 PM
PS You forgot the bag of marshmellows to toast on the campfire while we all sit outside the teepees discussing this problem. :D

Jester
30-04-2004, 12:22 PM
Mine is XP Pro, yes. I have never entered anything in the Domain name part though, :)

J aka Big Chief Running Water (heavy rain and floods here :( )

tech_meister
30-04-2004, 01:34 PM
Xp home cannot be part of a domain.
and yes all pc's must be in the same workgroup (or village)
good one Jester lol. :^O :^O

I don't think that will be all your problems as you should still be able to ping the router's ip address 192.168.0.1 but I'll keep my fingers crossed

ktee
30-04-2004, 03:20 PM
A (small) breakthrough. I now have all three PCs appearing in the same workgroup, and I can see all three computer names when I view them in My Network Places/View Workgroup Computers on each.
PC2 can access all files/resources on PC1.
PC3 can access all files/resources on PC1.
PC2 asks for a username/password when I attempt to get to PC3.
PC3 asks for a username/password when I attempt to get to PC2.
PC1 asks for a username/password when I attempt to get to PC2.
PC1 reports the following error when I try to get to PC3:
"Piglet is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
Logon failure: user account restriction. Possible reasons are blank passwords not allowed, logon hour restrictions, or a policy restriction has been enforced."
There it is. Word-for-word.
As far as I am aware we have never set any of the PCs up to log on with passwords. Are we getting somewhere?
Apologies for the repetition of earlier parts of this post, but I just want to make everything clear as things stand right now.
And please no more indian/teepee jokes. :)
Thanks everyone.

ktee
30-04-2004, 05:30 PM
Another breakthrough. PC3 can see/access PCs 1 and 2. In other words, everything is okay as far as networking is concerned. However, PC2 and PC1 are still behaving as in my previous post asking for a password/permission error reporting. Assuming there's still someone out there who isn't totally fed up with all this, any suggestions on what I should try now? The only thing I changed on PC3 since my previous post is I enabled the guest account. It is now enabled on all machines. Thanks.

Chilling_Silence
30-04-2004, 05:45 PM
Re-read what I said in my previous post:

Try creating a user account on all PC's with the same name and password (Make sure you give it a password, no cutting edges here). Then, login as that user (Only temporarily if you would prefer) and try the file sharing then.


Chill.

odyssey
01-05-2004, 12:55 AM
Can I suggest you try changing one more setting in you local security settings. To access the security policy in question you will need to go to Control Panel -&gt; Administrative Tools -&gt; Local Security Settings. This will open up a new window that has two panels side by side. On the left hand side panel select 'Local Policies' and then choose 'Security Options'. On the right hand side panel find the policy 'Accounts: Limit local account use of blank passwords to console login only' and double click on it. In the dialog box that comes up choose 'Disabled'. Select 'Ok' and close the 'Local Security Settings' window. This should be performed on all the PCs.

Cheers
Dave

Growly
01-05-2004, 10:03 AM
Did you try what I said on the previous page? That fixed all my problems that are like this... and who's ping 192.168.1.1 ??

BTW, more often than not, if you cant see a computer in network places then you can acceess it by running or going to:

\\computernamehere

do for example, if youwanted to access "snake" you could run:

\\snake

hope that helps.

tech_meister
03-05-2004, 08:32 AM
Guest account does not need to be enabled and is in fact a security
problem.
If you have simple file sharing enabled on each PC, (goto explore my computer, folder options, veiw, and right at the bottom make sure simple file sharing is enabled), then share a folder or drive on each PC, if the same message still comes up then you have other problems with the network.
One question: Can all PC's access the internet?
if not then there is probably a problem with the config of your firewall/router.

Chilling_Silence
03-05-2004, 12:58 PM
> Guest account does not need to be enabled and is in
> fact a security
> problem.
Agreed!

> If you have simple file sharing enabled on each PC,
> (goto explore my computer, folder options, veiw, and
> right at the bottom make sure simple file sharing is
> enabled), then share a folder or drive on each PC, if
> the same message still comes up then you have other
> problems with the network.
We've already determined the problem is with File-sharing permissions....

> One question: Can all PC's access the internet?
> if not then there is probably a problem with the
> config of your firewall/router.
Again, read over the posts... You'll see that she can ping PressF1 from all PC's, so therefore the net should be working (Unless the router is blocking outbound traffic on port 80 - but that would be complicating life assuming so).

We are waiting for her to create the user accounts and get back to us :-)


Chill.

tech_meister
03-05-2004, 07:53 PM
Yep, thanks for pointing out my dumbness, Chilling it must have been late at night when I read that ping
data and in fact the router can be pinged as can pressF1, so I apologize
for being a dumb-ass.

I still maintain though that you do not need accounts in Xp pro
I have set up many networks and never had to set up accounts.That error message does come up at first but as soon as you share a drive or
folder it comes right, however it,s worth a go if all else fails I suppose.