PDA

View Full Version : Lucent Win Drivers For Redhat9



Gum Digger
16-04-2004, 11:53 PM
Hi
Iam trying to install my modem drivers on linux red hat9
my modem is lucent win modem, i dowlaoded the drivers file called ltmodem-kv_2.4.21_4.EL-8.30a1-1.i686.rpm from the official website.
but when i tryed installing it in linux a error window pops up saying PACKAGE CANNOT BE FOUND " the following package cannot be found on your system. installation cannot continue until it is installed.
Kernel = 2.4.21-4.E L ltmodem- KV_2.4.21_4.el

I dont understand anything
please help.

Graham L
17-04-2004, 03:00 PM
Ummm. It might be a "too modern" version of the modem module. That one has been built for kernel version 2.4.21-4 .I forget what version you should have in RH9 (I'm getting 2.6.3 tidied up ;-)). uname -a will tell you what version you have.

If your kernel is 2.4.21-4 or later, the module should load.

The other possible problem is that you have typed the name without enough care to get the cases right. "KV" is not the same as "kv"; "EL"is not the same as "el".

Gum Digger
19-04-2004, 12:16 AM
Srry mate i didnt get u there
could explain a bit more,
thanks

Chilling_Silence
19-04-2004, 11:25 AM
Graham is talking about the Kernel, which is "Linux".. Its the core of the OS right....

Now, you may have downloaded a driver that was meant for a newer kernel than what you actually have, So, try doing as Graham instructed and we can continue helping you from there....

So open a command prompt (konsole or gnome-terminal) and type:
uname -a
And tell us what it says back.

Graham>
You know that 2.6.5 is the latest dont you ;-)


Chill.

Gum Digger
19-04-2004, 01:02 PM
It says
Linux Localhost . localdomain 2.4.20-8 #1 thu mar 13 17:54:28 est 2003
i686 i686 i386 Gnu/linux.

Chilling_Silence
19-04-2004, 01:06 PM
Okay then, our suspicions were correct.

You've got a driver that's too new for your kernel, you want one for the 2.4.20 kernel....

Try going back to the site where you found that driver and seeing if they have one for that kernel release.


Chill.

Gum Digger
19-04-2004, 03:56 PM
Could you help me find this package, i dont know much about linux.

Chilling_Silence
20-04-2004, 09:42 AM
Where did you find your first one? Do you know anything else about the Modem? How did you find out that was the package you needed???