PDA

View Full Version : Installed Linux....but....



miknz
14-03-2004, 10:16 PM
Right I got the partitions sorted out and spent the last 30mins waiting for Linux 7.2 to install went to reboot and the boot manager never came up(Lilo) and I cant get into Linux, the partitions are still there, how do I get linux to boot up?

I also did a silly thing, at the end of install it gave me the option to create a linux boot disk, I was in such a hurry to see linux I didnt bother. Am I screwed?

I tried putting the cd in and getting the install screen back it I get this error when anaconda is running
"input error:/lib?libssl.so.2:invalid ECF header"
didnt do this before, what up?

have a 12gig win98se partiton
800 meg swap file for linux
20gig for linux

cheers
mike

JohnD
14-03-2004, 10:40 PM
Rule 1: always make a boot disk (easy to say in retrospect!)

If you look at the menu when you boot from the CD there should be a rescue option. Login with that - it should give you the Linux file system under a new directory. You will need to use the chroot command to make this the normal root directory.

From there check the /etc/lilo.conf file for accuracy. When you are OK, issue /sbin/lilo.

Reboot and all should be right.

JohnD
14-03-2004, 10:45 PM
References

http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/custom-guide/s1-rescuemode-boot.html

http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/custom-guide/s1-rescuemode-boot.html

JohnD
14-03-2004, 10:54 PM
When you get your system going make a boot disk with this command:

mkbootdisk --device /dev/fd0 2.2.16-22

Replace the Kernel version with the correct one for RH7.2 (can see it by "ls /boot" or by issuing "uname -a)

miknz
14-03-2004, 11:14 PM
okay, got the boot disk and got into linux
I still dont get the boot manager coming up when I turn the P.C. on, any ideas on that? When I was in the setup before I installed the other boot manager not Lilo but the other one(cant remeber what it was called its getting late) and it still not showing up at start up.

anyway going to hit the hay, if you guys could have a think and let me know I will check back tomorrow.
Thanks

Mike, the newest linux user on pf1

JohnD
14-03-2004, 11:26 PM
GRUB is the other boot loader (www.gnu.org/software/grub).

It starts numbering partitions at 0. Check out the config file at /etc/grub.conf. GRUB is different from LILO in that to write the mbr you just save the config file.

To have no boot loader after the install are you sure that:
1. you did choose to install a boot loader?
2. you chose to install it to the master boot record.

John

miknz
15-03-2004, 07:14 AM
er option 2 might be the problem. Dont think I got the option where to install it???????? Just had to select which one I wanted then install it.

bugger it

Mike

Chilling_Silence
15-03-2004, 09:31 AM
Redhat installs it to the MBR by default IIRC.

Otherwise, boot off the floppy and run the following:
grub> root (hd0,0) (Specify where your /boot partition resides)
grub> setup (hd0) (Install GRUB in the MBR)
grub> quit (Exit the GRUB shell)

So if your /boot partition is on your first HDD, second partition, itd be:
root (hd0,1)

Hope this helps

Might I suggest a slightly more recent version of the Distro?


Chill.

Mzee
15-03-2004, 01:57 PM
I may be mistaken but the last time I was involved with 7.2 (Mandrake) there were some Dos files on one of the CD's & one of them was to create a Boot disc.

Chilling_Silence
15-03-2004, 02:21 PM
That's using Rawrite to make a Boot Floppy to begin the installation if your OS doesnt support booting from CD-Rom.

Do what Graham (Or was it John) suggested to make the boot disk once you've chroot'ed into your Installation.


Chill.

miknz
15-03-2004, 10:52 PM
okay, I am a little confused with the boot manager so will leave that for a while.
The next problem is my modem and setting up dial up. I have "Red Hat Linux 7.3(not .2 sorry) for dummies. In there it says to configure internet connection goto Programs>Internet>Dial up Configuration. I have no Tab that says Dial up Configuration!!!!

I can go to a window that says internet configuration where i set my i.p address and dns.

Is a little frustrating

mike

Jen C
15-03-2004, 11:44 PM
The different RH releases will have slightly different layouts of the menu's due to KDE or Gnome updates. You can download PDF manuals still for Red Hat 7.2 here (http://www.redhat.com/docs/manuals/linux/) if that helps. The Getting Started Guide pdf looks good.

Are you using Gnome or KDE? In Gnome the manual says to click on the Start Here icon on the desktop > Settings. You will then see the Internet Configuration icon to use.

Jen C
15-03-2004, 11:49 PM
Oh ... even better. I have found the online users guide so that you just view the sections you want to without having to download the pdf. See Chapter 5. Getting Online (https://www.redhat.com/docs/manuals/linux/RHL-7.2-Manual/getting-started-guide/ch-ppp.html).

miknz
16-03-2004, 08:15 AM
Thanks Jen I will have a look tonight