PDA

View Full Version : Problem:File/Properties/Opens With/Change/Always use this program to open



ljhnz
27-01-2004, 12:03 PM
OS: Windows ME
NAV 2002 (Active, registered & up to date)
Zone Alarm Pro (Reg, active and up to date)

The option to "always use this program to open these files" is greyed out when I right click a file that the system isnt recognising. The icon doesn't change and the system still can't identify it. These are files within programs I've been using for ages.

This hasn't always been the case and was wondering if anyone has a fix?

If I use the Windows File Manager app I can apply file associations to these "unknown" files and it works fine, but it's kinda slow and tedious.

I still don't know why these files have become "unknown" to the comp either - the programs still seemed to be opening and working ok, so maybe it's usual to have them?

Also - what about .dll files being classed as "unknowns" by the computer? What should they be associated with (if anything) - or is it a case of "if it works don't fix it"

I only noticed this "unknown application" thing occurring with files recently when I was backing up a program's files and left clicked a file to see what was in it. I run several spyware and trojan detection apps which are all up to date and scan freqently for viruses - nothing has shown up that might have caused it. Maybe it's just a corruption that occured courtesy of windows - but maybe its always been like that and I've only just noticed?

Any comments welcome!

Cheers

Lynne Hawkins
:-)

Noel Nosivad
27-01-2004, 12:28 PM
Hi Lynne Hawkins,

What program are you talking about? What is the file extension in question?

.dll files or dynamic link library files are modules that contain functions or data that can be used by an application. They are not associated with any programs as the program should know how to access the information it requires from the files.

Not all files need to be associated and that is why they are classed as unknown, they are most commonly system related or program related and those programs should know how to use those files without being associated to them.


Noel Nosivad

ljhnz
27-01-2004, 12:59 PM
Hi Noel
Glad someone answered cos now I've really made a tangle of things! Don't suppose there's a quick way to undo any file associations I've changed? Now I've got one program opening all sorts of apps (wish I'd never started playing round with this now)
Lynne

Pheonix
27-01-2004, 01:23 PM
First thing is to try the restore function.

Click the Start button.
Point to Programs, point to Accessories, point to System Tools, and then click System Restore.
Choose Restore my computer to an earlier time, and then click Next.
Click a day on the calendar, click the restore point description, and then click Next.
Make sure you have closed all your files and open programs, and then click OK to close the dialog box.
Click Next.


Otherwise, there is an XP fix that MAY? work here (http://www.dougknox.com/xp/fileassoc/xp_fileassoc.zip) but use it only if there is nothing left but to reload ME.

TuThuR17
13-03-2008, 12:02 PM
Hi, I have the same type of problem, but kind of worst.

I tried opening a .exe file, but didn't know which program to use so I used microsoft office 2007 for no reason and I forgot to unchek the ''always use this program to open...''. So now, every program I open, like firefox or what ever, even the Run command, it always open a microsoft office 2007 page. I tried to uninstall microsoft office 2007, but as soon as I reinstalled it, it did it again. When I open the microsoft office 2007 it doesn't even open microsoft office 2007, it open it, but it says '' File Conversion - WINWORD.EXE''

Plz Help

P.S: I have vista

TuThuR17
13-03-2008, 12:04 PM
I can't zip any files

bevy121
13-03-2008, 02:15 PM
OK here's what to do

open notepad and copy the following and paste it in



Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"
"IsolatedCommand"="\"%1\" %*"



In the notepad file, goto "File/Save as" to open the save file box

Change the "Save as type"
from "Text Documents [*.txt]" TO "All files"

Name the file something.reg - anything you like as long as you add a ".reg" to the end...

Go to the top and select desktop in the "Save in" dropdown

Now click save and there will be a reg file with the name you called it on your desktop

Double click it and it will ask if you want to merge with the registry or something

Click Yes and your exe's should all be ok again