PDA

View Full Version : Constant OPENGL32.DLL error message, please help!



Wilky
15-01-2004, 12:50 PM
I've just started getting this error message when starting Simcity 4:

The OPENGL32.DLL file is linked to missing export KERNEL32.DLL:IsWow64Process.

Then another message will pop up giving the directory to the simcity 4 exe and it says "A device attached to the system is not functioning."

This also happened in a game I downloaded, "Tank Warfare." (except giving the directory to the tank warfare exe of course)

Please help, this is really irritating!
My specs:
Pentium 3 533mhz
nVidia TNT2 32mb
384mb SD-RAM (133mhz)
14.2gb hard drive
Windows 98SE.

thanks in advance

robsonde
15-01-2004, 01:11 PM
looks like a video driver issue.

basicly some of part of openGL thinks its running on windows XP

what have you changed?

Wilky
15-01-2004, 01:37 PM
nothing, I think. It first occured on that tank warfare game, when I first tried to play it. How can I fix this?

Chilling_Silently
15-01-2004, 01:56 PM
Try downloading another Driver set. Personally I like the 44.03 driver set from nVidia... ;-)

Either that, or get the latest if you're not already running the newest Forceware and see how it runs after that :-)

Wilky
15-01-2004, 02:37 PM
44.03 driver set? would that work with my tnt2?

robsonde
15-01-2004, 02:41 PM
I think it will.....

the website has a good system to lead you to the right drivers.

have a play and see how you go.

Wilky
16-01-2004, 06:24 AM
Dammit, new drivers didn't fix it. According to a computer guru I know, apparently I have the XP opengl32.dll. Is there anywhere where I can get the 98 one?

Chilling_Silently
16-01-2004, 08:30 AM
Im sure that the OpenGL stuff comes as part of the nVidia driver set???

Tried the latest Drivers? 50.xx series...

These are much smaller than the international 40.xx series (Around 7MB)

John Grieve
16-01-2004, 08:59 AM
Unfortunately this is a very common problem with no real fix yet.

However there are a few things to try.

Find win.ini and open it and see if there is a line saying DVA=0. If there is place a semi-colon ( ; ) in front of the line (disables it) and reboot and try games.

Try placing a copy of OpenGL32.dll from the system 32 folder into each games main folder.

If you are running dual monitors disable the second monitor.

Wilky
16-01-2004, 11:40 AM
Chill, I got the 50.x drivers, John, no luck :(
This problem only started happening a short while ago, and from what I make of it, it is trying to find something that isn't there.

Wilky
16-01-2004, 03:45 PM
help?