PDA

View Full Version : Red Hat 9 tweaking, fixing, and making hospitable



Jaguar
27-12-2003, 07:10 AM
This is a carry on from the thread of Mandrake 9.2 Networking with XP (that just got way off topic with the change of distros etc.

Anyway... installed Red Hat yesterday, and have been using Windows for... nine years? Yeah. So, first impression was... where's the coffee?

Trying to make it like home is going to be difficult, I can see that... but with your help, it's possible!

First on the shopping list:

1.) Get a MSN Messenger equivalent going. NB Gaim, when I download, fails to open, just a flash appears, Jen suggests that it's a lack of dependencies or something along those lines. :S aMSN just extracts into a folder, and I can't see the file to open, so I click on aMSN and it says something about a child error with aMSN... don't ask.
2.) Want to get into my hard drives just like everywhere else. Want to be able to save files onto them, access them, make a shortcut on my desktop!! NB. They are NTFS, and there is XP that is installed on the same hard drive as Red Hat, but the second hard drive has no OS.
3.) With Opera, the text is so miniscule, that I need a magnifying glass to read them! And no, that's not a hyperbole!!

Windows: Here (http://www.davidbowie.com/users/Zanmaz123/operawindows.JPG)
Linux:Here (http://www.davidbowie.com/users/Zanmaz123/Screenshot.png)

Look out for the text sizes, I need to make the Linux ones larger.

3.) nVidia drivers for my video card. I have a Leadtek Winfast A280 LE TDH MyVIVO Geforce 4 Ti4200 w 128MB RAM. Getting a driver for this in Linux I'm sure would make a difference, or so I've been told.

4.) Still thinking. You guys should have enough there to look at for the moment though...

Chilling_Silently
27-12-2003, 08:06 AM
> Anyway... installed Red Hat yesterday, and have been
> using Windows for... nine years? Yeah. So, first
> impression was... where's the coffee?
Try theming GNOME, its a lot of fun :D Im not a fan of Redhat's Bluecurve theme set ;-)

> Trying to make it like home is going to be difficult,
> I can see that... but with your help, it's possible!
Wont take too long either we hope :-)

> First on the shopping list:
>
> 1.) Get a MSN Messenger equivalent going. NB Gaim,
> when I download, fails to open, just a flash appears,
> Jen suggests that it's a lack of dependencies or
> something along those lines. :S aMSN just extracts
> into a folder, and I can't see the file to open, so I
> click on aMSN and it says something about a child
> error with aMSN... don't ask.
Basically, depending on where you extracted it to, here's what I'd do:
Open up a console:
su -
[enter root password]
cp amsn-0.83.tar.gz /usr/share
tar xvzf amsn-0.83.tar.gz
cd msn (it may have called the folder amsn, try both.. Mines amsn, but I compiled using Sources...)
./amsn

If that works, then close aMsn for a minute (Yes, you can come back to it in just a moment).
cd /usr/bin
ln -s /usr/share/msn/amsn

Now, try pressing Alt + F2 and it should bring up a Run box. Type:
amsn
and you should see amsn load :-)

Out of curiosity, are you using GNOME or kde?

> 2.) Want to get into my hard drives just like
> everywhere else. Want to be able to save files onto
> them, access them, make a shortcut on my desktop!!
> NB. They are NTFS, and there is XP that is installed
> on the same hard drive as Red Hat, but the second
> hard drive has no OS.
Basically you'll need the ntfs rpm. You'll only get read-only at this stage due to the nature of NTFS (Unless you upgrade to the 2.6 kernel, but Im not sure if Redhat have released that rpm yet).
See:
http://linux-ntfs.sourceforge.net/rpm/redhat9.html

> 3.) With Opera, the text is so miniscule, that I need
> a magnifying glass to read them! And no, that's not a
> hyperbole!!
Sorry, cant help here...

> 3.) nVidia drivers for my video card. I have a
> Leadtek Winfast A280 LE TDH MyVIVO Geforce 4 Ti4200 w
> 128MB RAM. Getting a driver for this in Linux I'm
> sure would make a difference, or so I've been told.

Jen has already posted a URL to nvidia.com IIRC

Go there and get the Linux ia32 .sh fle, then follow the instructions in the README (I reakon you should be pretty sweet with it).
To boot to runlevel 3 by default, you'll need to edit (as root)
/etc/inittab
change where it says:
# Default runlevel.
id:5:initdefault:
to say:
id:3:initdefault:

reboot your PC and you'll have noting but a command line interface.
follow the install instructions for it (sh NVIDIA-Linux-x86-1.0-4496.run)
and then modify your /etc/X11/XF86Config
You can even do this before-hand with a GUI if you need.

Edit the /etc/X11/XF86Config file and change the following from:
Driver "vesa" (or "nv" )
to
Driver "nvidia"
This should be about 4/5 the way down the config file.

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

That will be up the top part of the file.
If you get stuck, you can look in the /usr/doc/nvidia-glx-1.0.4496/README file :-)
That Readme is freely available on the nVidia.com website, and I'd suggest you quickly browse through it :-)

Let us know how you get on

Cheers


Chill.

Jen C
27-12-2003, 08:26 AM
OK, I see that Chill has just beaten me to giving instructions on how to install the nVidia drivers, but having spent the last 20 minutes writing them I will post it as an additional guide :D

************************************************** *****************
How to install nVidia drivers.

First download them from here (http://www.nvidia.com/object/linux_display_ia32_1.0-5328) - the package name is NVIDIA-Linux-x86-1.0-5328-pkg1.run

Also have a read of the README (ftp://download.nvidia.com/XFree86/Linux-x86/1.0-5328/README) as it covers everything, but I will do a quick summary for you.

NOTE 1: Everything is case sensitive so enter file paths exactly how you have them.
NOTE 2: You will need to be connected to the internet when you do this as it might want to run off and check the nVidia ftp server for some precompiled files during the process.

1. Save the downloaded file into your home directory /home/jaguar/

2. Next to install the driver, X or the graphical desktop (runlevel 5) cannot be running at the time so you have to be in the command line runlevel 3 to install it.

3. Close all open applications. Open up a Terminal window on the desktop and enter "su -" to change to root. Next enter teleinit 3 - this command will close down runlevel 5 and drop you into runlevel 3. You will see the services shutting down and then some restarting. When it has finished you will either end up at a root prompt, or be asked to login in - use root to login with.

4. You now need to navigate via the command line to your saved nVidia file. Enter in
cd /home/jaguar/ To make sure you are in the right place, enter the command ls which will list the contents of that directory and you should see the nVidia file listed.

5. Next enter in:
sh NVIDIA-Linux-x86-1.0-5328-pkg1.run
This will start the package installer and just follow the prompts that will appear.

6. Hopefully at the end you will get a message about the installation being successful and you should be back at the root prompt. Enter cd at the prompt and then teleinit 5 which will take you back to runlevel 5 and your desktop should load again.

NOTE 3: At anystage if you want out of runlevel 3 (command line) just enter at a root prompt teleinit 5 to get back to your desktop.



Now the next bit - telling X that you want to use these lovely drivers you have installed :D

You need to be root do this, and the easiest way is to use the GUI to navigate around and edit the config file.

On the desktop again, open up a Terminal window and su - to root again. Enter in Nautilus (or Konqueror). This will load Nautilus but with full root powers.

1. Using this window and navigation arrows, go up a level to / then navigate to /etc/X11. Here you will see a config file called XF86Config. Make a copy of this file as backup (one is normally made anyway, but I always make a manual copy as well - name it XF86Config(copy).

2. Double-click on the XF86Config to open it in a text editor. You will need to edit some lines in here.

Under the section called "Module" you will need to change these items:
*make sure you have:
Load "glx" (you should have this already anyway)
*remove the following lines:
Load "dri"
Load "GLcore"

Under the section called "Device", you will need to change the reference to what driver to use:
Change driver "nv" (or Driver "vesa") with:

Driver "nvidia"

NOTE: make sure you keep the " " marks.

3. Save the changes and exit out.

4. Big test time - you need to restart X for the new drivers to load. So log out of X and log back in again. You will know that the drivers were successfully installed because you will see a splash screen with the NVIDIA logo appear and also you can get back into KDE or Gnome without a system error :D. If something does go horribly wrong, you should be dumped into command line and asked if you want to load a default XF86Config file, so just say yes to that.

Below is an example of my XF86Config file with the references given to the new driver:

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Chilling_Silently
27-12-2003, 08:30 AM
Well, you've really covered it there Jen :-)

I remember you saying there were new drivers out... Im still using the older ones until Gentoo put out the newest on their portage tree.

Probably best Jaguar if you follow Jens instructions, they seem a bit clearer :-)

....And good luck :-) Its not really that hard once you've done it and are looking back on it ;-)

Cheers


Chill.

Susan B
27-12-2003, 08:46 AM
Gosh, thanks for all that Jen, those instructions will come in very handy to me as well. :-)

Incidentally, the text in Chill's post changed to a TNR font halfway through the post for some reason. I wonder how that happened? It looks rather weird!

http://www.mscandy.orcon.net.nz/pf1.jpg

Susan B
27-12-2003, 08:49 AM
Er, sorry. I meant to say thanks for all that Chill and Jen. :-)

Chilling_Silently
27-12-2003, 08:57 AM
> Incidentally, the text in Chill's post changed to a
> TNR font halfway through the post for some reason. I
> wonder how that happened? It looks rather weird!
>
> http://www.mscandy.orcon.net.nz/pf1.jpg

Yes, same here. Firebird 0.7 in Linux...

Anybody wanna check that with IE or Opera?

Weird.. I never knew you could do that :D

Jen C
27-12-2003, 09:10 AM
Yeah, I saw the huge fonts that Chill created in his post - just thought he was trying to make it easier for jaguar to read the fonts with his Opera browser :p

If you want to make your desktop look more like home and not the generic theme that Gnome loads (I guess you are using this from your previous Opera screenshoot), take a look at this site here (http://www.kde-look.org/) - yes, I know it is called KDE-Look but there are heaps of wallpapers, icons etc that you can use. As Chill has already mentioned, you can adjust anything you like with the themes via Preferences on the Gnome menu panel. Have a good play around :D

To show you how you can candy-up the desktop, here is a screenshot of my current KDE desktop (http://sal.neoburn.net/imagef1/uploaded/my_kde.jpg). Hopefully you can access that image - sometimes they don't won't display on ImageF1 for some weird reason.

Susan B
27-12-2003, 09:11 AM
Yes, it's the same in IE and in Opera. It will be in the coding somewhere......

Jaguar
27-12-2003, 09:14 AM
Ok, well my head is still spinning, I won't get onto the nVidia drivers until I get aMSN sorted out. (Easiest first, then kill yourself on the hard stuff later!)

>Now, try pressing Alt + F2 and it should bring up a Run box. Type:
amsn
and you should see amsn load

Well, got going past the ln -s etc. etc. (NB Stupid text makes the l (L) and I (i) the same! Can get awfully confusing... where's that coffee?

When I do the Alt + F2, the Run Box does open, but when I type amsn, it doesn't find anything... no such file or directory.

Yes, Bluecurve does look a little er... interesting... any ideas on how to change it?

Will do nVidia drivers tomorrow.

Jaguar
27-12-2003, 09:15 AM
>Yeah, I saw the huge fonts that Chill created in his post - just thought he was trying to make it easier for jaguar to read the fonts with his Opera browser

Hey! It's not funny! I see pixels and that's it!!

Chilling_Silently
27-12-2003, 09:36 AM
Jen thats a nice desktop! :D

Mines not quite as stylish, but it works... :-)
Chills GNOME 2.4 Desktop 1 (http://sal.neoburn.net/imagef1/uploaded/Chills1.png)

Maybe we should have a "Show us your Theme" thread... Would be a nice change from _just_ wallpapers :-)

Try opening a console (as your user) and running:
/usr/share/amsn/amsn
or if that doesnt work, type:
/usr/share/msn/amsn

Post back with the results :-)


Chill.

Jaguar
27-12-2003, 09:40 AM
[root@localhost root]# /usr/share/amsn/amsn
bash: /usr/share/amsn/amsn: No such file or directory
[root@localhost root]# /usr/share/msn/amsn
/usr/bin/env: wish: No such file or directory

Chilling_Silently
27-12-2003, 09:46 AM
Okay, you need to rm the symlink in /usr/bin and remake it so it points to /usr/share/msn/amsn

Next, wish is the Windowing Manager it uses IIRC. Try:
wish amsn
(once you've remade that symlink i mentioned above)

If that doesnt work,then you've not got tk/tcl setup right, but Im sure it worked fine out of the box for me with RH9.. Weird..

Try that and post back :-)

Jaguar
27-12-2003, 09:46 AM
Out for rest of day. Will post when I get back.

Jen C
27-12-2003, 10:29 AM
BIG TYPO ALERT!

OK, just noticed that I have done a major typo in my instructions for installing the nVidia drivers :8}

Where I keep saying to enter in teleinit it should really say telinit - no extra e!

At least I was consistant and spelt the command wrong the whole way through, very sorry about that :)

Yeah, so just make sure you use the telinit command.

Jaguar
27-12-2003, 06:55 PM
>Okay, you need to rm the symlink in /usr/bin and remake it so it points to /usr/share/msn/amsn

I need to what to who and do the what to which thing?

Coffee... I think I bought some today!!

Please go through it a little slower. :|

Chilling_Silently
27-12-2003, 10:48 PM
As root, type:
rm /usr/bin/amsn
cd /usr/bin
ln -s /usr/share/msn/amsn

Then quit that terminal and open a non-root one and type:
wish amsn

Jaguar
28-12-2003, 06:32 AM
[root@localhost root]# rm /usr/bin/amsn
rm: cannot lstat `/usr/bin/amsn': No such file or directory
[root@localhost root]# rm /usr/bin/msn
rm: cannot lstat `/usr/bin/msn': No such file or directory
[root@localhost root]# rm /usr/bin/msn/amsn
rm: cannot lstat `/usr/bin/msn/amsn': No such file or directory

Can't seem to find it anywhere... and also wondering... how am I supposed to "open a non-root" terminal? I only have a Default profile... and that is the root.

Jaguar
28-12-2003, 07:02 AM
Well, whatever happened went as horribly wrong as was humanly possible.

I boot up into Red Hat, get a blank screen. Push a key, get asked something (which I can't see because nothing is written there) I push no, so another question comes up. I push no. Then it tells me something which I can't read, I push OK. Then I get a blank screen.

Hmmmmmmmmm. Question mark.

Jaguar
28-12-2003, 07:03 AM
^^ That's for the nVidia drivers, by the way. ^^

Jen C
28-12-2003, 07:48 AM
> ^^ That's for the nVidia drivers, by the way. ^^

Oh dear. :O

Was this after you edited the XF86Config? When it was asking you questions after everything went horrbily wrong - you needed to say "yes". A simple typo in the XFConfig editing will enduce this as the config file is no longer readable in order for X to load.

Red Hat will give you the option of loading a default XF86Config when it encounters an error in the current one. Try booting up the machine again, and seeing whether it will give you the option of loading this default config again? Say yes this time. You should be able to get back into X (your desktop), and if you paste a copy of your edtited XF86Config, we will see if we can spot the problem line.

Hope the coffee supply hasn't gone already.

ilikelinux
28-12-2003, 08:07 AM
(chris drives coffee truck in)

:D

Chilling_Silently
28-12-2003, 08:08 AM
> Can't seem to find it anywhere... and also
> wondering... how am I supposed to "open a non-root"
> terminal? I only have a Default profile... and that
> is the root.

It'd be a good idea then to make a user for yourself

There's a Redhat tool somewhere that'll let you setup users from a GUI.

Try this then:
wish /usr/share/msn/amsn


..When you get the GUI of course.

If you screw up X big time, you can always post here and myself or Jen can send you our working XF86Config file.

Jen C
28-12-2003, 08:08 AM
>Can't seem to find it anywhere... and also wondering... how am I supposed to "open a non-root" terminal? I only have a Default profile... and that is the root.

This is a root termimal example:
[root@origin root]#

And a users terminal example:
[jennifer@origin jennifer]$

By simply opening up a Shell (Terminal Console) window, the first prompt you see should be the users example.

Did you not create a general users account during installation of Red Hat 9? The root account should only be used when absolutely required, and you will be often prompted for a root password when performing task that require root privileges.

Open up a console windows and enter in redhat-config-users. If you haven't created a user account (non-root) for yourself, you better make one now. You can find general information on this [url=http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/custom-guide/ch-redhat-config-users.htmlUser and Group Configuration[/url]]

Jen C
28-12-2003, 08:12 AM
Whoops - should of previewed that URL link

Here it is correctly:
User and Group Configuration (http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/custom-guide/ch-redhat-config-users.html)

ilikelinux
28-12-2003, 08:21 AM
can any one help me to make themes for kde?

Jen C
28-12-2003, 08:46 AM
> can any one help me to make themes for kde?

You should make your own thread, rather than trying to introduce a very different question in someone else's thread. Go and have a look here (http://www.kde-look.org/), and here (http://www.kde-look.org/help/index.php?PHPSESSID=db78cd135515cd2a3ea960640fc776 a8) in particular.

ilikelinux
28-12-2003, 08:59 AM
sorry

Jaguar
28-12-2003, 12:33 PM
OK, well I pushed yes, and if I turn my screen off and then on, it gives me the display options... and it hangs when I move the mouse.

I simply CAN'T get into Linux.

Jaguar
28-12-2003, 05:28 PM
Is there a safe mode or something to get back into Linux? Or do I need to reinstall?!

Jen C
28-12-2003, 05:41 PM
What you could do is to boot into a command line only and then re-edit your XF86Config or replace it with the backup copy of that file you made.

You might need to hang-10 for a bit for instructions as I haven't had to do that yet via command line, so it is pointless in me trying to instruct you - sorry :)

I am suprised that you couldn't load a default XF86Config file which would of got you out of this mess.

As you say, your final option would be to reinstall Red Hat 9 (make a user account this time when you do the root one). The installation CD does have a "rescue mode" but since this is a fresh install, it might just be easier to start again.

Wait a bit for further advice :)

Chilling_Silently
28-12-2003, 07:32 PM
Here's what you're going to need to do:
Download a working XF86Config file (I'll put up mine on a website soon and hope you can run 1024x768@70hz on your monitor.. should be able to)

Now, copy that to a floppy disk and boot your Linux PC
Hit Ctrl + Alt + F2
Put in the Floppy disk
type:

cp /etc/X11/XF86Config /etc/X11/XF86Config.old (This is just in case...)
mount /dev/fd0 /mnt/floppy
cd /mnt/floppy
cp XF86Config /etc/X11/
shutdown -r now

Take out the floppy disk and watch your PC reboot.

You may need to re-setup the mouse settings after this. If you installed the Driver fine, then when it starts to load X, you'll be greeted with a 1 second nVidia image :-)

I'll just go upload my XF86Config file somewhere

Cheers


Chill.

Jaguar
29-12-2003, 06:51 AM
You guys try and save me, I'll wait here for instructions/that boot disk.

Jen C
29-12-2003, 07:52 AM
OK well I have zipped up two X86Config files. The one named "X86Config" is my current config with the reference to the nVidia drivers. The other one "X86Config(orig)" is a standard non-nVidia driver X86Config file.

The mouse settings are for a 3-button (scroll) mouse which should be fine for you, however my video card is referenced as a "NVIDIA GeForce 2 MX (generic)". Hopefully that won't cause a problem, but you will need to change that to the correct card once you have X up and running again. The monitor setting is for a generic monitor 1024x768 so that should also be fine.

I would use the X86Config file to replace your munted one, as it already references the nVidia drivers.

Download zipped file here (http://sal.neoburn.net/imagef1/uploaded/x86Config_files.zip)

Use Chill's instructions that he gave on how to replace the config file.

Chilling_Silently
29-12-2003, 08:04 AM
Bet me to it Jen, Just as I'd started Apache and was hosting it :p

If you want to unzip it in Linux, after (mount /dev/fd0 /mnt/floppy), just type:
cd /mnt/floppy
unzip Zipfilename.zip

And carry on...

Just covering all bases here :-)

Let us know how you get on.

Jaguar
29-12-2003, 08:29 AM
Well, CTRL+ALT+F2 doesn't seem to be doing much, when exactly do I push it??

Jaguar
29-12-2003, 08:30 AM
OK, there we go, now trying to do those instructions.

Jaguar
29-12-2003, 08:42 AM
Yes... seems to hang after a while... need to type quicker. Hangs after about 1 minute or so. Very odd.

Chilling_Silently
29-12-2003, 08:44 AM
Im guessing you've figured you push it when its waiting for login (Or has brought up the "Fix X" thingy whatsit).

You can use between F1 and F6, with F7 being the start of X (If you're really clever you'll get X running on 8/9 etc) ;-)

Chilling_Silently
29-12-2003, 08:47 AM
Hangs as its doing what though?
Loading X after you've followed the instructionis?
After it boots?

Jaguar
29-12-2003, 09:07 AM
When it asks if I want to overwrite, do I press Y?

If so, then I did the whole thing and still no luck...

Jaguar
29-12-2003, 09:16 AM
I'm beginning to lose hope here. I'll do those instructions again.

By the way, I copied the XF86Config file, not the XF86Config.old

Jaguar
29-12-2003, 09:21 AM
Did it again, still no luck... any ideas, or should I reinstall?! :S

Jaguar
29-12-2003, 09:23 AM
Heading out, be back afternoon. Think away.

Chilling_Silently
29-12-2003, 09:45 AM
Forget the cp XF86Config XF86Cofnig.old then...
And yes, over-write...

Try re-installing the drivers..
Andy chance you can post here Exactly what happens (In detail...)

As well as the last 10-15 lines of any error message...

Jaguar
30-12-2003, 06:20 AM
What do I push when it asks me to overwrite?

Anyway, the problem is this: Once all of the XF86Config replacement is completed, there is no change. Out of curiousity, I went into /etc/X11/ and found XF86Config as well as a XF86Config~. There were also some backups.

The problem when Linux is loaded is that I can't read that error message because it is blank. When I choose yes, however, it comes up with a ReadMe type file for XF86Config. The only option from there is Exit.

Chilling_Silently
30-12-2003, 10:28 AM
Push Y when it asks you to over-write and hit Enter
That XF86Config~ file was likely created by gedit, as a backup file.

Try this:
cp /etc/X11/XF86Config~ /etc/X11/XF86Config

Then restart X.

After that, always keep a backup of your XF86Config file..

You'll be back to a vesa display, but at least a distplay is better than none, so you can take it at a steady pace if you screw up ;-)

took me about 3 weeks before I got drivers right with Lycoris Desktop/LX ;-)

Jaguar
30-12-2003, 10:56 AM
Woohoo, time to celebrate because I am back into Linux.

Now, about the nVidia drivers. I'm hoping to actually get them installed... so I'll give it another go later this afternoon. Wow, it feels good to be back here. Anyway, I hope that this time it will work. Will report back late afternoon/evening on how it went. If I again fail, I think it would be time for something else... by the way: there is no GLCore in the XF86Config to remove... I'll do a more detailed post of what I've done when I do it later. Hang in there and I'll keep you guys posted.

Chilling_Silently
30-12-2003, 11:16 AM
Yes, that'd be about right, as you're running vesa drivers and not nv (nv are open-sourced nvidia drivers, which dont offer as good performance as the Official drivers)

Stick with it, its worth it :-)


Chill.

Jen C
30-12-2003, 11:30 AM
Excellent news! :D

Well done Chill for guiding Jaguar through this, and good on you Jaguar for persisting with it :D (how's the coffee supply going?)

>Now, about the nVidia drivers. I'm hoping to actually get them installed

Didn't you already install them? By following the instructions and booting into runlevel 3 with "telinit 3" and running the installer and getting a "successful" message? You only now need to have another crack at the XF86Config to tell X to use them. Have a look at my XF86Config file to see how I have made the changes - you only need to change the Section "Module" and the Section "Device".

Also, take a look at your current XF86Config and make sure that your nVidia card has been detected and recorded correctly. (Just trying to eliminate the possibility of another "horribly wrong" experience :) )

Example:
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
Your card will obviously be different as I think you have a GeForce 4 Ti4200 from memory.

If you like, you can post here your default XF86Config file and we can show you exactly how to change it.

Jaguar
30-12-2003, 01:12 PM
OK, since Opera can't handle Java right now and doesn't want to install any Shockwave, I can't use my www.davidbowie.com webspace as a host! :(

Instead, I've relied to my good old pal (no, not really) of Angelfire. Hope it works.

Here! (http://www.angelfire.com/mi3/zanshomepage/XF86Config)

Tell me what to do... Need some stronger coffee... better head over to Foodtown... :|

Jen C
30-12-2003, 01:27 PM
Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri" <---remove this whole line
EndSection

**It should then look like this:

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

-----------------------------------------------------

Next, the driver reference:

Section "Device"
Identifier "Videocard0"
Driver "nv" <---- change this to nvidia
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 131072
EndSection

**It should then look like this:

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 131072
EndSection

Save the changes and restart X, fingers & toes crossed :D

Jaguar
30-12-2003, 01:46 PM
I hate to be the bearer of bad news, but the same thing happened again after doing all of that.

I was just wondering, how can you change the XF86Config while X is still running? Wouldn't it be better to shut down X and then do it?

Anyway, seeing as that didn't work... where to from here?

Jen C
30-12-2003, 01:53 PM
:_| :_| !!

Well you have me stumped now - you can change the XF86Config file whilst X is running as it has already "read" the file when you first loaded X. That is why you need to restart X so that it can read off the new instructions. I have done this quite a few times now myself and I only killed off X once due to a typo I made in the config file.

>Anyway, seeing as that didn't work... where to from here?

ChillLL ...!!?!

Jaguar
30-12-2003, 01:55 PM
Better get the coffee out, because by the sounds of things, this is going to get a lot worse and a lot harder!!

Jen C
30-12-2003, 02:01 PM
I have to check ... you definitely installed the NVIDIA-Linux-x86-1.0-5328-pkg1.run OK? It gave you a successful installation message?

Try running the installer again, from the command line. Just navigate to where ever you have the file saved and install it again. Make sure there are no error messages.

> Better get the coffee out, because by the sounds of things, this is going to get a lot worse and a lot harder!!

Think of this as a good learning experience, get this sorted and you will have already lost a bit of your linux-newbie shine :D.

Jaguar
30-12-2003, 02:03 PM
>Think of this as a good learning experience, get this sorted and you will have already lost a bit of your linux-newbie shine

Wow, you put in in perspective for me, thanks!! :P

I'm outat the moment, will reinstall when I get back.

Jaguar
30-12-2003, 02:20 PM
Right, I reinstalled the nVidia drivers and zilch. Same result. Now I'm really going to head out.

So, we tried it several times to no avail... suggest away.

Chilling_Silently
30-12-2003, 02:30 PM
Im still going to suggest you havent installed the Drivers correctly

Try booting, and when you get the Blue Screen to fix it or whatver, Hit Ctrl + Alt + F2 and type:
tail /var/log/XFree86.0.log

Then let us know what it says.

If you still have a floppy, then do the following, otherwise ignore it:
Put the floppy in
mount /dev/fd0 /mnt/floppy
rm -rf /mnt/floppy * <-- This is removing the contents of your floppy
cp /var/log/XFree86.0.log /mnt/floppy
umount /mnt/floppy

Then if you can post it on here, or upload it to the net somewhere, that'd be brill :-)

Cheers


Chill.

Jaguar
30-12-2003, 04:23 PM
Right I did all of that (had to redo the XF86Config again in order to get that blue screen and stuffed up-ness (by the way, it no longer hangs on me).

The file is right here. (http://www.angelfire.com/mi3/zanshomepage/XFree86.0.log)

Jen C
30-12-2003, 04:49 PM
Been doing a bit of reading on the nV Linux forum (http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14). Do you have a newish VIA chipset board - like the KT400? The are numerous report of problems like you are experiencing with the newer VIA chipsets and AGP problems in combination with the recent nVidia drivers.

Your XFree86.0.log doesn't show any errrors (EE) but you haven't posted all of it, there should be more. Right where your one ends there should be this sort of log:

(II) NVIDIA(0): AGP 2X successfully initialized
(II) NVIDIA(0): Setting mode "1024x768"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled This is been cropped short of the end, as I was using it as an example.

Jaguar
30-12-2003, 05:59 PM
> Do you have a newish VIA chipset board - like the KT400?

You mean a newish video card? Yes. Newish mother board? I think so...

If you want me to post my computer specs, just give me a holar.

That's all that the log had, there was no more, I copied it from that directory straight to the floppy. There was no more...

Jen C
30-12-2003, 06:24 PM
Might as well rule out the VIA chipset/AGP nVidia thingy, so yes, if you could tell us what your motherboard is and whether it has the VIA chipset - thanks :)

>That's all that the log had, there was no more, I copied it from that directory straight to the floppy. There was no more...

Well that could be significant, as you can see from my example log, that is where the AGP info is logged.

Jaguar
30-12-2003, 06:59 PM
Righteo, this is of the top of my head here:

Shuttle AK39 Motherboard (has VIA network card)
AMD Athlon XP 2400+
1GB RAM (DDR 333)
2 x 7200rpm ATA-100 HD (1x Seagate 8MB Cache, 1x Western Digital 2MB Cache)
nVidia Geforce 4 Ti4200 w AGP 8x 128MB VRAM (Leadtek Winfast A280 LE TDH My VIVO)
AOpen CD-RW (52x24x52x)
AOpen DVD-ROM (16x)
AOpen 17" F70ES LCD screen

You may think this is a fast computer... it is. :)

Jaguar
30-12-2003, 07:03 PM
By the way, those hard drives are both 80GB, although that should be of no significance whatsoever.

Also note that the screen will struggle to read below 800x600 and above 1280x1024 in resolution, and it runs best with 75Hz as a refresh rate.

Jen C
30-12-2003, 07:18 PM
Bingo! Your motherboard has the VIA KT400 chipset. See the specs here (http://us.shuttle.com/specs.asp?pro_id=251).

So, reading previous posts on the VIA new chipsets and the newer nVidia drivers, they were getting the same problem as you. The driver would install with no error messages, the editing of the XF86Config was done correctly, and yet X would not load and they ended up with blank screens.

Couple of options here.
1. Try the workaround given on the nV forum which involved disabling the reference to AGP in the XF86Config file.
2. Try a much older nVidia driver which hasn't had problems reported with it (not sure how far back you would need to go).
3. Get to love the standard nv driver that Red Hat installs and do without your full graphic card potential (no 3D games like tuxracer), until someone fixes this problem.
4. There is a 3rd party driver which you could try here (http://www.minion.de/nvidia.html) which has a work around for the VIA chipset problem.

If you want to do another round of editing the XF86Config with the possibility of it going pear-shaped again, the option #1 might work for you.

Let us know what you want to do from here.

Jaguar
30-12-2003, 07:21 PM
Number 1 and number 4 seem to be the most logical.

Jaguar
30-12-2003, 07:27 PM
But I think at this point in time, I need some shut eye tonight, I'll leave it for tomorrow when I have good concentration.

Also, it would be easier if we could do it via IM, simply a quicker response time... don't want to lag down the PF1 forums more than they already are! Have a good night, and look forward to hearing from both you and Chill on New Years' Eve!

Jen C
31-12-2003, 07:58 AM
Morning Jaguar :)

>You may think this is a fast computer... it is.

That is a nice system you have there, Linux will fairly rock along on it :D

But, back to the current problem ...

In all honesty, since we have moved on from simply installing a nVidia driver and editing a XF86Config and then troubleshooting problems for that, the sort of issues you have now would be best dealt with by the Linux and nVidia forum (http://www.nvnews.net/vbulletin/forumdisplay.php?s=156468a51534fd6903933f8538206b8 b&forumid=14) as they specialise with this. You will see from the dates on threads about this problem, that it is a current problem.


But anyway, some background info on the nVidia 5328 problem can be found here (http://www.nvnews.net/vbulletin/showthread.php?threadid=22643). You will see they discuss using the minion patched driver (option #4) but you will need your kernel-source rpm's installed to compile the driver with - and even then people report problems using it (for others it worked).

But if you want to give the easiests of all your options a whirl ....

Option one
Well for option number 1, some people have been saying that if you disable the AGP option, X will load. You can read the some of the comments on the Linux vNvidia forum, but this one mentions what disabling the AGP support will mean here (http://www.nvnews.net/vbulletin/showthread.php?s=43a8164ecf2a55b3a2826e180a6fa7a9&threadid=22831).

Add this to your XF86Config file under Section "Device" : Option "NvAgp" "0"

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 131072
Option "NvAgp" "0"
EndSection

Don't forget to make the other changes to the XF86Config file for the "nvidia" driver reference and the removal of the Load "dri" line.

This will kill X (again!) if it doesn't work, so yeah sorry, not much else I can say here. :( It is also only a work-around and not a solution.


Having read quite a lot of posts over the net on this issue, it does sound like a combination of problems, including your current RH 9 kernel not having proper support for the KT400 chipset and the AGP x8 with the nVidia drivers. A newer kernel (2.6) and an official improved/fixed driver could solve this. But as the open-source community is constantly moving forward with improvements/fixes it might be only a matter of time until this is overcome.

This must be a horrible experience for you with your first introduction to Linux, so I really hope it doesn't put you off, as Linux has a lot to offer and it is normally a much smoother ride.

You ought to treat yourself to a double-expresso as I think you deserve it after all this, and Happy New Years! :)

Jaguar
31-12-2003, 09:46 AM
Thanks a lot Jen. Help is much appreciated. I'll give it a go later this morning and post the results. Even if it doesn't work, I'm sure to do something, I really want to play TuxRacer! :)

You and Chill have definitely been a great help to me, and if there is ANYTHING, and I stress ANYTHING that you want, just let me know. I have everything you can possibly imagine under the horizon (for Windows), though most is of course illegal. Drop me a line if you ever need anything to: zan.m@ihug.co.nz <---Note to PF1 users, any SPAM will result in me doing some techno karate!! Look out! :P

Cheers, have a brill new year.

Jaguar
31-12-2003, 03:54 PM
And voila, it works! TuxRacer, what a novelty game. :)

Last thing to do before I give you a short New Years break ;)

Need aMSN to get going... the problem we had was that it simply wouldn't work. When I tried to install, nothing happened...

Chilling_Silently
31-12-2003, 04:21 PM
Did you try:
wish /usr/local/msn/amsn

Congrats on the Drivers :-)

Jen C
31-12-2003, 04:36 PM
> And voila, it works!

Really!?! <falls off chair in dead faint>
Well done! :D Have to confess I wasn't holding out too much hope on the disabling the AGP option bit.

That should get you sorted for a wee while, but remember to look out for updates on your situation so that you can get it fixed properly (and to remove the Option "NvAgp" "0") when you do.

I see Chill is sorting out your aMSN problem, but did you remember to make yourself a user account somewhere along the line? :)

You certainly don't give up easily when it comes to dealing with problems :D

Cheers
Jen

Jaguar
31-12-2003, 05:05 PM
>[guest@localhost guest]$ wish /usr/local/msn/amsn
>bash: wish: command not found

I found that I had created a Guest account...

>You certainly don't give up easily when it comes to dealing with problems :D

I've been on Windows for too long! ;)

Chilling_Silently
31-12-2003, 07:40 PM
> >[guest@localhost guest]$ wish /usr/local/msn/amsn
> >bash: wish: command not found
>
See:
http://amsn.sourceforge.net/
You'll need to install tcl/tk packages (tcl & tk)
Run:
redhat-config-packages
Try and locate it, I think it may be under the devel tools, but I may be wrong...

Jaguar
31-12-2003, 08:21 PM
I found tk, couldn't find tcl... installed tk.

Chilling_Silently
31-12-2003, 08:51 PM
Did it work when you ran:
wish /usr/share/msn/amsn
then??

Jaguar
01-01-2004, 08:21 AM
Well, it won't install.

I then went browsing in the CD, found some tcl and one tk rpm, of course, I can't run them. It said something about unable to execute binary... didn't quite catch it. Anyway, should I burn another copy of the CD and try again? I can't seem to install anything.

Chilling_Silently
01-01-2004, 09:04 AM
When you run:
redhat-config-packages
It'll just ask you for your origional install CD's.

If you installed Redhat with it, then surely it'll be a good and working CD.

Ive got a friend with Fedora, I'll send him a txt and ask him what section tcl/tk are under :-)

Keep with it, you're almost there... :-)


Chill.

Jaguar
01-01-2004, 09:19 AM
Well, if it isn't the CD, then what? I try to install and it just fails when it gets to the tk file. The other files in that section install correctly.

Can't find tcl packages anywhere...

Chilling_Silently
01-01-2004, 09:33 AM
Note down what CD it wants you to install it from (eg, CD3 I think it was)
Put the CD in and mount it (mount /dev/cdrom /mnt/cdrom)
then:
cd /mnt/cdrom/RedHat/RPMS (Or a similar folder structure, I cannot remember coz its been a while...)

ls | grep tk
ls | grep tcl

Now, run the following two commands and post back if you get errors:
rpm -Uvh tcl*.rpm
rpm -Uvh tk*.rpm

That should have installed both tcl/tk so you can run:
wish /usr/local/msn/amsn


Chill.

Jaguar
01-01-2004, 09:42 AM
[root@localhost RPMS]# rpm -Uvh tcl*.rpm
error: Failed dependencies:
libtk8.3.so is needed by tclx-8.3-88
[root@localhost RPMS]# rpm -Uvh tk*.rpm
error: Failed dependencies:
libtix8.1.8.3.so is needed by tkinter-2.2.2-26

Looks like I need a couple of files. Heading out on vintage car rally, will post wjhen I get back.

Chilling_Silently
01-01-2004, 09:46 AM
That complicates life then doesnt it... Hmm....

Dont do this immediately, wait for somebody else to agree/disagree, but Im going to suggest:
rpm -ivh tcl*.rpm --force --nodeps
rpm -ivh tk*.rpm --force --nodeps

This will install the new rpm's and leave the old ones, hopefully satisfy'ing the lot..

Jaguar
01-01-2004, 04:24 PM
Too impatient to wait, I'm going in.

If it fails, I'll just blame a rock, that way, the rock doesn't protest, and I don't get blamed. It's a win-win situation.

Jen C
01-01-2004, 04:31 PM
I have just installed amsn to see whether I get the dependency errors, and I didn't.

I downloaded amsn-0_83.tar.gz

Went into the folder where I had saved it and opened a terminal window with the right-click option. Stay as whatever user you are logged in as (don't use su).

Entered:
tar xvzf amsn-0_83.tar.gz

This resulted in a large list of files scrolling past. Then in the same window enter in:
cd msn

Then enter in ./asm (there is a full stop in front of the / which may not show clearly on this page). This should open up the program.

Just try this first.

Jaguar
01-01-2004, 04:33 PM
[root@localhost RPMS]# rpm -ivh tcl*.rpm --force --nodeps
Preparing...
########################################### [100%] 1:tclx
########################################### [ 33%] 2:tcl-html
########################################### [ 67%] 3:tcllib
########################################### [100%][root@localhost RPMS]# rpm -ivh tk*.rpm --force --nodeps
Preparing...
########################################### [100%] 1:tkinter
########################################### [ 50%] 2:tk
########################################### [100%]

I assume that was what you were expecting, if not, damnit...

When I did:

wish /usr/share/msn/amsn

It opened... can't all be bad. Anyway... how do I get it into the little 'Start Menu'?

Jen C
01-01-2004, 04:49 PM
Okay Dokey - you got it running anyway now - excellant :D

>Then enter in ./asm
Another typo alert - that should of course read ./amsn

>how do I get it into the little 'Start Menu'?

You are using Gnome? Well I use KDE, but the general gist of these instruction should give you enough to follow your nose.

Right-click on the Gnome Red Hat which opens up the menu, and look for menu editor (or something along those lines). Pick a category that you want your shortcut to go under, like "Internet". Create a new item, give it a name and under command, enter in wish /usr/share/msn/amsn. Click apply. Then go and try the new shortcut.

If my instructions bear no correlation to how Gnome does things and you can't figure out how to do this, let me know and I will boot up Gnome (I have it also installed) and give some more decent instructions. :)

Chilling_Silently
01-01-2004, 06:05 PM
Try this (as root)
ln -s /usr/local/msn/amsn /usr/bin/amsn

Then you can just:
wish amsn

Right-click on your Taskbar and click:
Add to Panel
-Launcher

Follow your nose from there... :-)

Jaguar
02-01-2004, 05:37 AM
OK, got it into the Launcher, but can't seem to get it into the menu... operation failed or something to the likes of it. Anyway, now I feel a bit more at home here, and now it's time to explore!!

See if I can get into my hard drives somehow... want to watch those TV episodes on there.

Chilling_Silently
02-01-2004, 07:25 AM
Your Hard Drive partitions will be stored under /mnt (Stands for Mount).

In Linux, each drive must be Mounted before it can be used and UnMounted before it can be removed....
I found it a bit of a pain at the start, but in the end its kinda good.

Heres a few places that you might like to check out:
http://www.tldp.org
The Linux Documentation Project - The name says it all - Documentation for Linux

man application_name
If you wanna know more info about an Application, type man (for Manual) followed by the program name...!

http://www.google.co.nz
Google - What a place to check into when you've got a problem or wanna know about something, have a look here

http://www.pressf1.co.nz
Last but not least, here! Have a question, most people will be more than happy to go out of their way to help you :-)

There is a way to get it into the Applications Menu, but Ive forgotten.. I'll post back if it comes to me ;-)


Chill.

Jaguar
02-01-2004, 08:04 AM
That Linux documentation site is very useful! Thanks!

Yes, I've figured out this mounting business... but both hard drives are NTFS, and I don't think it reads that... I'll give it a go though.

Jaguar
02-01-2004, 08:27 AM
Hmmm, downloaded the rpm from http://linux-ntfs.sourceforge.net/

First I tried the double-click... it did the prepare, told me it was queued... I clicked continue and that's the last I saw of it. Tried doing

[root@localhost Downloads]# sh kernel-ntfs-2.4.20-27.9.i386.rpm
kernel-ntfs-2.4.20-27.9.i386.rpm: kernel-ntfs-2.4.20-27.9.i386.rpm: cannot execute binary file

Remembered that from you. :)

Chilling_Silently
02-01-2004, 08:34 AM
rpm -Uvh kernel-ntfs*.rpm

:-)

The 2.6 kernel should be available for download in an rpm soon from Redhat, it supports writing to ntfs :-)

Jaguar
02-01-2004, 09:10 AM
That's good, I'll keep an eye out for it.

To my horror, I found out that XMMS player doesn't do MPEG 1, 2 and 3!! DId someone want to tell me this? I mean... does Red Hat... do ANYTHING?! :S

Never mind, I'm sure there's a complicated sollution to it... :)

Jen C
02-01-2004, 09:25 AM
> To my horror, I found out that XMMS player doesn't do
> MPEG 1, 2 and 3!! DId someone want to tell me this? I
> mean... does Red Hat... do ANYTHING?! :S

That is an easy fix :D

Go here (http://www.gurulabs.com/downloads.html) and download the XMMS MP3 Plugin for Red Hat Linux - grab the xmms-mp3-1.2.7-21.p.i386.rpm for Red Hat 9 (don't get the SRPM). Just run that, and try out XMMS again.

This site here is also excellent for tips on command lines things - Newbie's Top Ten Commands (http://www.cmm.uklinux.net/steve/ntt.html)

Jen

Jaguar
02-01-2004, 09:39 AM
Wow, excellent! Those commands are bound to come in handy!

Yes, well I had found an XMMS player plug-in with similar filename minus the p.

Now the player doesn't work... is there a way to remove these packages? Need to reinstall it... or rather replace it with the one you suggested.

Dolby Digital
02-01-2004, 09:44 AM
>>To my horror, I found out that XMMS player doesn't do MPEG 1, 2 and 3!! DId someone want to tell me this? I mean... does Red Hat... do ANYTHING?! :S
Nope, better uninstall it now.

Maybe you should have gone with Mandrake ?:|

Jen C
02-01-2004, 09:45 AM
Was this plugin you found a RPM?

To remove that rpm, open up a console window, and enter this:

rpm -e name_of_rpm. Make sure you enter the full file name correctly.

Jaguar
02-01-2004, 09:51 AM
Right... I assume Linux has a reinstall feature... because I need it. That program has completely gone kaput.

After I do the remove package command, it doesn't give me my [root@localhost root] again. Just flashes there. That obviously isn't a good thing...

In fact, this Evolution E-mail seems to have died on me too. Open it up, gives me the splash screen and just sits there. I've seen ducks that are more interesting...

Jaguar
02-01-2004, 09:55 AM
>Maybe you should have gone with Mandrake

Yeah, that died on me too... I mean, it couldn't get onto my network. It did zilcho. It was actually similar to a wall. It just didn't do anything.

Dolby Digital
02-01-2004, 09:57 AM
Very strange. I run both RedHat and Mandrake...

Jen C
02-01-2004, 10:04 AM
> Right... I assume Linux has a reinstall feature... because I need it. That program has completely gone kaput.

Yes it does. Either enter into a console windows redhat-config-packages or look for Add/Remove Applications or similiar in your Gnome menu - might be under System Settings.

When Add or Remove Packages opens up, go to "Sounds & Video" and click on the Details link. Look for xmms and remove the tick from beside it and then close and then update. This should remove the package for you. You can then reinstall it the same way and you will be asked for one of the installation CD's at some point.

Jen C
02-01-2004, 10:39 AM
>In fact, this Evolution E-mail seems to have died on me too. Open it up, gives me the splash screen and just sits there. I've seen ducks that are more interesting...

Evolution will do this if it wasn't properly shut down. The process will still be running in the background so you will need to kill it. Look under System Tools on the gnome menu, or if you enter into a console window gnome-system-monitor it will pop open. Under the process listing tab, look for Evolution (there may be a few entries) and end the process.

Jaguar
02-01-2004, 11:03 AM
Did a restart and fixed it.

I think it can now play mp3... though it does seem to hang when I press play, previously I just got a message...

Jaguar
02-01-2004, 11:17 AM
Yeah, that doesn't work at all... just hangs...

Also want to play some videos too... avi, mpg... have some Stargates to watch. :)

Jaguar
02-01-2004, 11:35 AM
That time it got one second into the song and hung... something very fishy is going on.

Chilling_Silently
02-01-2004, 12:17 PM
Right-click on XMMS and go Options
-Preferences
click Audio I/O Plugins
Configure your Output Plugin down the bottom to use Esound.
If that doesnt work, then go OSS
If that wont play, go ALSA

If that wont work, then your soundcards not setup, so open a terminal:
su -
[enter root password]
sndconfig

Follow the prompts then try xmms again :-)


Chill.

Jaguar
02-01-2004, 12:30 PM
Excellent, works under OSS.

Now I can listen to some David Bowie.

I'll do some fiddling around and come moaning back here some time soon, I'm sure... remember to get in touch if you ever need anything... movies... games.. software (windows)... of course, they're not 'warez' Wink wink nudge nudge ;)

Chilling_Silently
02-01-2004, 01:46 PM
Jaguar>
A few things to keep in mind:
OSS = Opensource Sound Server - Its been depreciated for Alsa with the new 2.6 kernel, but if you're not going to be upgrading, then dont worry, OSS will do everything you need fine :-)
ALSA = Advanced Linux Sounds Architecture (I hope Ive got these Acronyms right) - Its the new kid on the block thats used with the 2.6 Kernel.

I'll email you later and you can get a small rpm off my ftp, I also have a fair few other rpm's you might find useful :-)

Good to hear you stuck with it and have had good results from it :-) You should congratulate yourself!

Cheers


Chill.