PDA

View Full Version : Linux and ttys0



mikebartnz
11-12-2003, 01:03 AM
Hi there all.
Have just installed Fedora and having a little trouble getting my external modem working. It is on Com1 or ttys0. I have tried setserial /dev/ttys0 and just get an I/O error. When querying the modem from kppp the tr led lights up then it says modem not responding. Any help would be much appreciated.

b1naryb0y
11-12-2003, 01:41 AM
Try using ttyS0. Everything in linux is CaSe sensitive :)

mikebartnz
11-12-2003, 08:24 PM
Yes that was a bit slack of me for not noticing that it was a capital S. Had a play around with setserial but still can't get my modem to work

Gorela
11-12-2003, 09:17 PM
By "play around" do you mean that you also tried configuring using 1-3 as well as 0?

I have noticed that some distros seem to pop the modem on unusual locations :)

mikebartnz
12-12-2003, 12:12 AM
Yes I did try others but the one it was originaly on and is back on is what is set in the bios. As stated above in kppp when querying the modem the tr led goes on then it says modem not responding. In previous versions I had mapped it to /dev/modem but they say that is old hat :D now.

JohnD
12-12-2003, 11:48 AM
Something seems a bot odd here - external serial port modems normally "just go".

Does Fedora still call the GUI network configuration tool "redhat-config-network"? If so, I suggest you start it (or the equivalent tool) and check the devices tab for the modem. If the modem is there, remove it, add it again, then reactivate.

Normally this would get the modem going.

JohnD

JohnD
12-12-2003, 11:50 AM
P.S.

You should check the hardware tab first.

b1naryb0y
12-12-2003, 11:59 AM
Maybe setserial has stuffed the port settings up.
Generally for standard Com ports, ie. Com1-4 setserial is not required.

Setserial should only really be used if you want to add more Com ports from Com5 onwards or to change the standard Com port settings.

Graham L
12-12-2003, 04:30 PM
Have a look with dmesg and see what serial ports the Linux knows about. If it says it has found ttyS0 and ttyS1, that's what it knows about.

I haven't had to do this for a long time, but I seem to remember having a command which just looked for modems and set /dev/modem appropriately.

O: That might be the problem. Just about all the modem using software knows that there will be a logical link "/dev/modem" which it can talk to.

mikebartnz
12-12-2003, 10:04 PM
dmesg certainly gives a bit of info. It found ttyS0.
As I stated setting the /dev/modem is old hat :D now although I don't know about pci modems. In kppp you can point to /dev/ttyS0 as your modem. I did try it with the same results of the tr led on the modem lighting up and then "modem not responding". This is bugging me as I had no problems in RH9.
Not related but I get two errors on close down 1) mouse services not closing down. 2) It has four goes at unmounting /usr saying it is busy on the first three. This doesn't seem right.
Thanks for your time

Graham L
13-12-2003, 02:32 PM
There's a mini terminal (forget the name -- have never needed it ;-) which talks through serial ports. Basically, sending "AT" should get "OK" back if the selected port and the modem are working properly.

What about using "diald" --- that should work the same?

But I rather suspect that your "fixes" might have changed enough defaults that the "automatic user fiendly wizards" are now non-functional.

I've done this myself. The quickest solution is to do a reinstall. :D I've often done that in the early stages of working with a new version. It's easier than trying to undo everything I've done. :D I'm nearly at that stage on RH9 ... I'm playing with IRda ... and it is interesting.

A standard thing like a modem on an external port should have needed no intervention from you. The fact that it did indicates that something is rotten in the state of Denmark.

b1naryb0y
13-12-2003, 03:17 PM
> There's a mini terminal (forget the name -- have
> never needed it ;-) which talks through serial ports.
> Basically, sending "AT" should get "OK" back if the
> selected port and the modem are working properly.

Minicom.

pppsetup (http://linux.tucows.com/preview/8576.html) is also a handy wee program for setting up modems and dial-up-networking. Works from a shell too, so there is no need for X11 if you swing that way :)

mikebartnz
13-12-2003, 08:02 PM
Have done quite a bit of searching and have tried "lsof /dev/ttyS*" and "wvdialconf mymodem.conf" with no joy. Have noticed that there is no "/etc/serial.conf" and I have the impression there should be one so if someone could give me a listing of what is in there's I will create it. I had the impression that running "setserial" was mean't to create it.

mikebartnz
13-12-2003, 08:09 PM
The fact that the original install left the modem non operational doesn't give me much hope with a reinstall and while I have changed things they are back to there original sttings. As well as that I like to know what is going on so that I learn and hopefully remember the next time. :p

Graham L
14-12-2003, 01:55 PM
How about a reinstall with RH9? :D

Do I get the impression that Fedora is a beta release?

mikebartnz
14-12-2003, 02:01 PM
No I understand it to be a finale

mikebartnz
14-12-2003, 06:43 PM
What I did was change the bios setting for com1 from irq4 3F8 to auto and the modem is working ok.
ttyS0 is still pointing to irq 4 3F8 so I don't realy understand why it wasn't working before.
In RH9 even after altering a few settings from connect to the actual dial took quite a while whereas with Fedora it is instant.

Graham L
15-12-2003, 02:34 PM
Magic. :D

Maybe setting the port explicitly in the BIOS makes it a "legacy DOS" port, whereas "auto" makes it part of the Plug and Pray system. I'd expect working/non-working to go th other way.:D