PDA

View Full Version : autorun



azzy77
30-11-2003, 11:19 PM
hey i know this might sound silly, but on xp when i put a CD in it used to give me options of what to do, with it, run, play wit h media player, open. But recently it has stopped offering me those options, does anyone know how to get them back

Robby
01-12-2003, 09:22 AM
gidday,

check the registry entry, it may have been temporarily disabled, or it
may be what is on the cd? I have struck the occasional cd that wont
activate automatically.

here is the registry entry to check, please be careful, any wrong change here, could cause big problems.

start, run, type regedit, follow these: HKEY_local_machine\sytem\
currentcontrolset\services\cdbcdrom (or it could be cdrom)

doubleclick the autorun entry, if its reading 0 change it to 1 exit all the way out, and restart.

Pheonix
01-12-2003, 09:33 AM
Welcome to pressf1 azzy77.
If you have XP, then for each type of disk you have put in, it has memorised what you did with it. When it knows, it won't pop up that menu for you to decide. Until you put in a CD it doesn't know what to do.

If you want to change what to do with a particular type of disk, open "My Computer" , right click on your CD drive and choose "Properties" from the menu that pops up. Click on the "Autoplay" tab and then you can click on the arrow beside the name to choose the type of disk and what to "open" it with.

Hope this helps and if it isn't XP, post back the Windows flavour you do have.

Cheers

parry
01-12-2003, 12:20 PM
Hi if the above suggestions dont work then read this (http://www.annoyances.org/exec/forum/winxp/n1035002575) which discusses the same problem I had with AutoRun. I could get one drive to work and not the other until I tried the suggestion to delete the NoDriveTypeAutorun key found in the registry under -

HKEY_CURRENT_USER\SOFTWARE\MICROSOFT\WINDOWS\Curre ntVersion\Policies\Explorer

The article was regarding WinXP while I have WinMe so the same solution applies to both.

hth