PDA

View Full Version : Bad Checksum



effie C
13-11-2003, 11:40 AM
Hi,
Twice this week I have tried to download two available updates, for Spybot- each time I have been told "bad checksum error" - how do I get past this and what is a checksum?
effie c

Kame
13-11-2003, 11:48 AM
Checksum is a method of making sure that bits (data) in a program have not been altered, if altered the checksum number will be different and when compared with what the original checksum should be it'd be reported differently, which gives an checksum error message, which could mean data has been altered or corrupted.

The problem could be the file on the server, or your method of downloading it, you may not have an efficient connection which is not grabbing all the neccessary data needed.

effie C
13-11-2003, 11:51 AM
Hi Kame,
I must be old- I see I asked a similar question several months ago- tho it got me no better informed- I assume I shall just redownload Spybot to get past this effie c

rsnic
13-11-2003, 11:57 AM
Are you using a download accelerator? Where you downloading it from?

Graham L
13-11-2003, 02:50 PM
A checksum is a simple test for a correct file transfer. It is a "number" generated in a particular way based on all the actual data bits. If after a file transfer, a new calculation, done at the recieving end, does not match the original checksum there has been an error in the transfer.

The checksum you are having probably having trouble with is one "owned" by the compression used on the programme file. Compression always includes a test, because the files have to be perfect.

There is no fix for a bad file based on the checksum ... it only finds errors. (It can't even find all errors, but it will usually find bad errors ;-)).

It needn't even be a bad connection to cause errors: it is possible to create errors with a single command. :D If you are using FTP, you must use the binary mode. The ascii mode "corrects" the endofline treatment for text files between *nix/DOS type files, which is a destructive process on compressed/binary file. :_|

Just check the settings on your download method, and try again. I'd "possibly" mistrust any "accellerator".
:D

Pheonix
13-11-2003, 05:49 PM
Don't worry about it effie. I have had the same thing a couple of times. Leave it for a few days and try again. Has been up to a week before I finally get a good copy.

beama
14-11-2003, 12:27 AM
effie
I also had the same problem but with a different solution to Pheonix, I changed the mirror to downlaod from, you have theat option to the right of the download button on the toolbar in the update area of spybot