PDA

View Full Version : Problem when turning PC off



sarel
07-10-2003, 09:13 AM
Hi there everybody

Running Win98SE, when I access the Internet thru a 56K modem, no problem. When I try to log off or shut down my PC, I get the message :

msdtcvs
You must quit this program before you quit Windows.

This is very annoying - can anybody please help?

Sarel

Babe Ruth
07-10-2003, 09:36 AM
Sarel,

It sounds like you have the Microsoft Distributed Transaction Coordinator service running (for some reason)...
From the MS KB:

# MSDTC Service Is Being Loaded from the StartUp Folder

Remove the MSDTC service from the StartUp folder. To do so, follow these steps:

* Click Start, point to Settings, and then click Taskbar & Start Menu.
* On the Start Menu Programs tab, click Remove.
* Double-click the StartUp folder.
* Click the MSDTC service, and then click Remove.
* Click Close, click OK, and then restart your computer.
* If you do not want to remove the MSDTC service from the StartUp folder, configure Internet Explorer to connect to your ISP using a local area network (LAN). When you want to connect to the Internet, first connect to your ISP using Dial-Up Networking, and then start Internet Explorer.
* To configure Internet Explorer to use a LAN, follow these steps:
* Right-click the Internet Explorer icon on the desktop, and then click Properties.
* Click the Connection tab, click "Connect to the Internet using a local area network," and then click OK.

NOTE: If the MSDTC service is not being loaded from the StartUp folder, remove the Msdtc value from the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\
RunServices

Notes:
By default, the Microsoft Distributed Transaction Coordinator (MS DTC) is configured to start automatically when a Windows NT or Windows 98 system starts. To prevent MS DTC from automatically starting after rebooting a Windows 98 computer, use the registry editor to find the HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\RunServices registry key and then delete the value entry named MSDTC. To prevent MS DTC from automatically starting after rebooting a Windows NT machine, open the Services icon in the Control Panel. Click "MSDTC" to open the service configuration window for MS DTC. In the Startup Type section, select Manual.

If you want to enable automatic startup of MS DTC again on a Windows 98 computer, use the registry editor to create a value entry named MSDTC with the string value "msdtcw -start" under the HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\RunServices registry key. You can start MS DTC through the Services option in the Control Panel on a Windows NT computer.

Important: It is strongly recommended that you configure MS DTC to start automatically on any computer running transactional MTS components, SQL Server, or MSMQ.

Cheers, Babe.

sarel
08-10-2003, 10:14 AM
Babe Ruth

The suggested fix did not work - Microsoft Distributed Transaction Coordinator was not on/activated so the same problem still exists. Any other suggestions?

Thanks guys

Sarel

godfather
08-10-2003, 02:51 PM
Well, if you say its not on/activated, then its a bit unusual that its telling you/warning you that it is?

Are you certain the spelling of "msdtcvs" is correct in your error message?

sarel
08-10-2003, 03:02 PM
I will make sure and get back to you

Sarel

sarel
12-10-2003, 06:42 AM
Yep the spelling is correct