PDA

View Full Version : Windows stuck in MS-DOS Mode - Exit command won't work



cookee.nz
06-10-2003, 05:18 PM
Here's a tricky and frustrating problem.

I have a customer’s PC here which when you boot it, it comes up with a message saying “You are currently running in MS-DOS Mode, do you want to return to normal mode to run Windows applications again (Y/N)”

If you answer ‘Y’, it reboots and you get the same error, and it just keeps looping like that.

If you answer ‘N’, you get a further message telling you “You are still running in MS-DOS mode, to return to normal mode, exit the application you are running, or type WIN again.”

And of course typing ‘Win’ just puts you back into the earlier loop.

I’ve had this problem only a couple of times before, and in both cases it was due to the user (a child) running or doing something with a DOS game. On one of them, I spent ages trying to resolve it, tried various tips from the web but nothing would clear it. Everything pointed to a setting in one of the boot files, io.sys or similar but despite all attempts I could not fix it and ended up having to reinstall.

Now that I have a further one I’m sure there must be an easier way to fix it. All the customer could tell me was that "the kids were doing something with games".

The system WILL boot into the Windows GUI from Safe Mode. There has got to be a clue in that fact.

If anyone has encountered this and has a proven remedy please let me know.

godfather
06-10-2003, 05:43 PM
There are a few cures, but you appear right on the cause.

#1 option (these copied from the web)

Sometimes when you go to msdos mode to play a game you cant get back. Here's how to get back manually

Type this

edit config.sys

In your config.sys file you will find a line reading

dos = single

This causes windows to run in msdos mode.

Delete the line saying dos = single. Now press the ALT key and the F key at the same time.
The file menu will come down and you will see save. Use the error keys and move the highlite bar to the line that says save. Press the ENTER key.

BUT!!! Your not fixed yet

In the autoexec.bat file you will find these 2 gems.

call c:\windows\note.bat
call c:\windows\command.com

Delete these 2 lines. Now press the ALT key and the F key at the same time. The file menu will come down and you will see save. Use the error keys and move the highlite bar to the line that says save. Press the ENTER key. Now restart your computer.


Option #2

Start in safe mode.

Go to MSDOS mode
At the command prompt, type: Win /wx. Press ENTER.


Option #3

[i]

edit the MSDOS.SYS file.

You will see a line that says BootGUI=0

Change it to BootGUI=1

Graham L
06-10-2003, 05:49 PM
I love the "error keys". I think the writer meant arrow keys. :D

Editing MSDOS.SYS is best done after changing the attributes from System and Hidden and Readonly ... (If you are doing this from DOS, you'll have to. :D)

godfather
06-10-2003, 06:06 PM
I rather liked the "error keys " as well.
Could catch on?

mejobloggs
06-10-2003, 06:16 PM
Hey, I had this and stressed.

My dad got angry and pressed every key on the keyboard, randomly, then restarted, and it worked.

Dunno what it is though, could be any combination, but i think it may have been something in the top right corner of the keyboard.

Try you luck.