PDA

View Full Version : Is there an automatic modem configuration script for linux?



smashedlittlebugger
30-09-2003, 05:28 PM
I have the drivers installed for my winmodem but I can't get the link between com3 and the other thing, I can't figure out how to do it. Is there a script that automaticaly configures your modem? I'm running Redhat 9.0.

Cheers
John

Graham L
30-09-2003, 06:20 PM
You could try ln -s /dev/ttyS2 /dev/modem (the ports on *nix start at 0). Did you compile your drivers, or install an RPM? Either should have made the link --- I think :D -- if you compiled, did you "make install"?

smashedlittlebugger
30-09-2003, 08:02 PM
I used the pctel driver, latest version. I started with <./configure -auto> and that did some working then finished. The Readme told me then to input the command <make>, did some more working then <make install>. Finally I was ready to use my modules with <insmod pctel.o> and <insmod ptserial.o>. Thats what I did. After I input the command you said <ln -s... something something>, then kppp wouldnt freeze, it will just hang on "Initializing modem..." and I get the "ready" dialtone when I pick up the phone to see if it is actually dialing.

John

Lachlan
30-09-2003, 09:04 PM
Usually /dev/ttyS2 would work fine if you were using a external serial modem,but for winmodems you might have to use /dev/ttySLT0(Mandrake),/dev/ttyLT00(Suse),not sure about Redhat.You could try running KPPP-Setup-modem-Querry Modem to see if your modem is detected.

Lachlan

smashedlittlebugger
30-09-2003, 09:37 PM
In modem querry all the boxes were empty (I didn't have it open for long). I changed some settings under my modem tab, changed it from /dev/modem to /dev/ttyS2 and now it says my modem is busy. When I run modem querry again, it also says the modem is busy.
Can ya help any further?

Lachlan
30-09-2003, 10:30 PM
Run lsmod and make sure your driver modules are loaded.Next run dmesg,this will hopefully give you some info about your modem,ie irq , io port , and maybe /dev/ttyxxx
Then setserial /dev/ttyxxxx uart 16550a port xxxxx irq xx.ln -s /dev/ttyxxx /dev/modem.
If you can not get ttyxxx from dmesg,run wvdialconf /etc/wvdial.conf and with a bit of luck this will give you the info you need.

Lachlan

smashedlittlebugger
01-10-2003, 09:42 AM
ARG! they arn't loaded. How do I get them loaded?

Graham L
01-10-2003, 02:00 PM
Oops, I suppose I was automatically thinking external modem on "COM3". Obviously, that's a "virtual" serial port. The "modem is busy" often means that a lock file has been left there. I think leftovers should be removed at bopt time, but have a look in /var/lock/ for a file which looks like a modem thing, and delete it. (Lock files can be removed without doing any damage ... they are to stop multiple people using the somethjing which is by its nature single-user.)

Lachlan
01-10-2003, 09:01 PM
You usually load a module with either insmod ot insmod -f (force) or modprobe.If this does not work it usually comes back with a warning or file ,directory not found.
Sometimes you might have to use the the full path before the drivers would load: insmod -f /lib/modules/2.4.21-0.13mdk/ltmodem/lt_serial.o(/lt_modem.o).Substitute for Redhat.
Your pctel and serial drivers have to loaded before you can go any further.

Lachlan

ex-parrot
04-02-2004, 09:31 PM
The eventual solution:

Convincing John his winmodem didn't have a com port, and linking /dev/modem to whatever device the drivers created, iirc, it was something like /dev/dssometherearion.