PDA

View Full Version : internet access using KPPP



agent
26-09-2003, 10:30 AM
I've got Mandrake 9.0 installed on my computer, and I've pretty much set it up how I like it.

Problem is, I can't get internet access.

The modem that's in my computer is a Conexant modem, and as I'm not willing to pay money to get speeds of higher than 14.4KBps using a 56KBps modem (see [url=https://www.linuxant.com/store/faq.php]this page[url] if you're interested in the details), I plugged an external modem into my computer for Linux to use.

The modem is set up correctly in Linux, and I can dialup to the internet and KPPP puts a little icon in the tray. However, I can't actually do much after this.

Going to sites using their hostnames or IP addresses doesn't work. I did some searching on Google and this site, but didn't find much.

If I run ping 210.48.100.45 -I ppp0 the icon in the tray flashes green on both the two circles, but no results come back to the program (and I can't really be bothered leaving it running for more than 10 seconds), and so it registers as 100% loss when I cancel it.

I also read another site which said to add the lines defaultroute
noauth or something like that to /etc/ppp/options, and I have done that, but to no effect.

So does anyone know just what I have to do to get internet access?

Susan B
26-09-2003, 10:59 AM
Strange.... once I figured out how to get connected I was away, but that was in RedHat.

It wouldn't be the firewall blocking access would it? My modem was switched on when I installed RH so it would have configured everything for me upon installation.

Just a thought - I know nothing about Linux. :p :D

Lachlan
26-09-2003, 04:03 PM
I use kppp and MDK 9.1 and you should end up with login box in your tray.In it you will see your connection speed,time on line,volume and details of download speed.I have never seen small green icons and I have been using Mandrake for 1 1/2 years.
You could try setting up and running wvdial,this just might give you the info. on what is happenig when you make your connection.

Lachlan